Tagging module Mom - Mom-2.2-8
[mom.git] / pl_mom.spec
index 770521c..aa726a6 100644 (file)
@@ -1,7 +1,9 @@
 %define name pl_mom
-%define version 0.4
-%define release 4%{?pldistro:.%{pldistro}}%{?date:.%{date}}
+%define version 2.2
+%define taglevel 8
+
+%define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
+
 Summary: PlanetLab node monitoring tools
 Name: %{name}
 Version: %{version}
@@ -28,9 +30,6 @@ process memory usage. At 90% utilization, resets the slice that is
 consuming the most physical memory. At 95% utilization, it reboots the
 machine to avoid a crash.
 
-bwmon is a cron job that monitors the average bandwidth usage of each
-slice and enforces a daily byte limit for each slice.
-
 pl_mop is a cron job that "fixes" various common problems with nodes
 (dead services, ext3 corruption, zombie SSH sessions, etc.).
 
@@ -46,14 +45,14 @@ rm -rf $RPM_BUILD_ROOT
 install -D -m 644 pl_mom.py $RPM_BUILD_ROOT/%{_datadir}/%{name}/pl_mom.py
 
 # Bandwidth monitor (bwmon), run periodically
-install -D -m 755 bwmon.py $RPM_BUILD_ROOT/%{_datadir}/%{name}/bwmon.py
+#install -D -m 755 bwmon.py $RPM_BUILD_ROOT/%{_datadir}/%{name}/bwmon.py
 
 # Swap monitoring daemon (swapmon)
 install -D -m 755 swapmon.py $RPM_BUILD_ROOT/%{_datadir}/%{name}/swapmon.py
 install -D -m 755 swapmon.init $RPM_BUILD_ROOT/%{_initrddir}/swapmon
 
 # Cleanup script
-install -D -m 755 pl_mop.sh $RPM_BUILD_ROOT/usr/local/planetlab/bin/pl_mop.sh
+install -D -m 755 pl_mop.sh $RPM_BUILD_ROOT/usr/bin/pl_mop.sh
 
 # Runs pl_mop and bwmon periodically
 install -D -m 644 pl_mom.cron $RPM_BUILD_ROOT/%{_sysconfdir}/cron.d/pl_mom
@@ -96,13 +95,46 @@ exit 0
 
 %files
 %defattr(-, root, root, -)
-%{_datadir}/%{name}/pl_mom.py
-%{_datadir}/%{name}/bwmon.py
-%{_datadir}/%{name}/swapmon.py
+%{_datadir}/%{name}/pl_mom.py*
+%{_datadir}/%{name}/swapmon.py*
 %{_initrddir}/swapmon
-/usr/local/planetlab/bin/pl_mop.sh
+/usr/bin/pl_mop.sh
 %{_sysconfdir}/cron.d/pl_mom
 
 %changelog
-* Mon July 10 2006 Faiyaz Ahmed <faiyaza@cs.princeton.edu>
-- bwlimit: Use cached values if NM stops responding
+* Thu Feb 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - Mom-2.2-8
+- minor cleanup
+
+* Wed Nov 19 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - Mom-2.2-7
+- Kill processes in context rather than restarting it.
+- * Fixes bug where reset processes lose connectivity.
+
+* Tue Jul 29 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - Mom-2.2-6
+- Update mop script to monitor relevant procs.  Update swapmon to avoid corner case when slice is being built.
+
+* Wed Jun 25 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - Mom-2.2-5
+- specfile was screwed, release number was not incremented upon tagging
+
+* Thu Apr 24 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - Mom-2.2-4
+- 
+- * Send mail from hostname if conf file can't be found
+- * Use MOM address in conf file insead of support address.
+- * Use new Vserver.  Start slices without INITSCRIPTS after kill so user can still log in.
+- 
+
+* Wed Jul 19 2006 Faiyaz Ahmed <faiyaza@cs.princeton.edu> 0.4-7.planetlab
+- swapmon: Added state info so same reset email does not keep getting
+  sent. If slice is already being killed, will wait for a timeout
+  before trying to kill again.
+
+* Mon Jul 17 2006 Faiyaz Ahmed <faiyaza@cs.princeton.edu> 0.4-6.planetlab
+- swapmon: Added state information per slice.  Slices are now killed
+  after consuming more memory than the threshold more than twice.
+  Also fixed the slice restart issue where slices would be restarted
+  and repeated restart emails would be sent.
+
+* Mon Jul 10 2006 Faiyaz Ahmed <faiyaza@cs.princeton.edu> 0.4-5.planetlab
+- bwmon: Initialize default limits
+
+* Mon Jul 10 2006 Faiyaz Ahmed <faiyaza@cs.princeton.edu> 0.4-4.planetlab
+- bwmon: Use cached values if NM stops responding