add a timeout command to the client package
[monitor.git] / Monitor.spec
1 #
2 # $Id$
3
4
5 %define url $URL: svn+ssh://svn.planet-lab.org/svn/monitor/trunk/monitor.spec $
6
7 %define name monitor
8 %define version 3.0
9 %define taglevel 18
10
11 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
12 %global python_sitearch %( python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)" )
13
14 Name: %{name}
15 Version: %{version}
16 Release: %{release}
17 Source0: %{name}-%{version}.tar.bz2
18 License: GPL
19 Group: Applications/System
20 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
21
22 Vendor: PlanetLab
23 Packager: PlanetLab Central <support@planet-lab.org>
24 Distribution: PlanetLab %{plrelease}
25 URL: %(echo %{url} | cut -d ' ' -f 2)
26
27 Summary: Monitor account initialization for the root image.
28 Group: Applications/System
29
30 %description
31 Monitor is a collection of secondary scripts for configuring the node polling
32 system, syncing the PLC db with the monitoring database, notifying users,
33 interacting with PCU hardware, applying penalties to sites that violate
34 acceptable use.
35
36 ######################################## CLIENT
37
38 %package client
39 Summary: Monitor hooks for a PLC node
40 Group: Applications/System
41 Requires: curl
42 Requires: coreutils
43
44 %description client
45 The client scripts handle account creation inside of a node.  This will
46 include configuration setup for the monitoring agent running on the node.  It
47 will also include any cron or init scripts needed to perform this kind of
48 maintenance.
49 ######################################## Server Deps
50 %package server-deps
51 Summary: Monitor hooks for the PLC server.
52 Group: Applications/System
53
54 Requires: python
55 Requires: python-setuptools-devel
56 Requires: python-peak-util-extremes
57 Requires: TurboGears
58
59 Requires: compat-libstdc++-296
60 Requires: openssh-clients
61 Requires: perl-libwww-perl
62 Requires: perl-IO-Socket-SSL 
63 Requires: MySQL-python
64 Requires: nmap
65 Requires: rt3
66
67 Requires: plewww-plekit
68
69 #Requires: zabbix-client
70 #Requires: zabbix-gui
71 #Requires: zabbix-server
72
73 %description server-deps
74 The server side include all python modules and scripts needed to fully
75
76 ######################################## Server
77 %package server
78 Summary: Monitor hooks for the PLC server.
79 Group: Applications/System
80
81 Requires: python
82
83 Requires: monitor-server-deps
84 Requires: monitor-pcucontrol
85 Requires: PLCWWW >= 4.2
86 Requires: bootcd-%{pldistro}-%{_arch} >= 4.2
87
88 %description server
89 The server side include all python modules and scripts needed to fully
90 operation, track, and interact with any third-party monitoring software, such
91 as Zabbix DB.
92
93 ######################################## PCU Control
94
95 %package pcucontrol
96 summary: pcu controls for monitor and plcapi
97 group: applications/system
98 requires: python
99 requires: OpenIPMI-tools
100
101 %description pcucontrol
102 both monitor and the plcapi use a set of common commands to reboot machines
103 using their external or internal pcus.  this package is a library of several
104 supported models.
105
106 ####################################### RunlevelAgent
107 %package runlevelagent
108 summary: the RunlevelAgent that reports node runlevels
109 group: applications/system
110 requires: python
111
112 %description runlevelagent
113 The RunlevelAgent starts as early as possible during boot-up and production
114 mode to actively report the observed runlevel to PLC and update the
115 'last_contact' field.
116
117 %prep
118 %setup -q
119
120 %build
121 # NOTE: the build uses g++ cmdamt/
122 # NOTE: TMPDIR is needed here b/c the tmpfs of the build vserver is too small.
123 cd pcucontrol/models/intelamt
124 export TMPDIR=$PWD/tmp
125 make
126 cd ..
127
128 %install
129 rm -rf $RPM_BUILD_ROOT
130 #################### CLIENT 
131 install -D -m 755 monitor-client.init $RPM_BUILD_ROOT/%{_initrddir}/monitor
132 install -D -m 644 monitor.cron $RPM_BUILD_ROOT/%{_sysconfdir}/cron.d/monitor
133 install -D -m 755 timeout.pl $RPM_BUILD_ROOT/usr/bin/timeout.pl
134
135
136 #################### SERVER
137 install -d $RPM_BUILD_ROOT/usr/share/%{name}
138 install -d $RPM_BUILD_ROOT/data/var/lib/%{name}
139 install -d $RPM_BUILD_ROOT/data/var/lib/%{name}/archive-pdb
140 install -d $RPM_BUILD_ROOT/var/lib/%{name}
141 install -d $RPM_BUILD_ROOT/var/lib/%{name}/archive-pdb
142 install -d $RPM_BUILD_ROOT/var/www/cgi-bin/monitor/
143 install -d $RPM_BUILD_ROOT/var/www/html/monitorlog/
144
145 install -D -m 644 monitor.functions $RPM_BUILD_ROOT/%{_sysconfdir}/plc.d/monitor.functions
146 install -D -m 755 monitor-server.init $RPM_BUILD_ROOT/%{_sysconfdir}/plc.d/monitor
147 install -D -m 755 zabbix/monitor-zabbix.init $RPM_BUILD_ROOT/%{_sysconfdir}/plc.d/zabbix
148
149 echo " * Installing core scripts"
150 rsync -a --exclude www --exclude archive-pdb --exclude .svn --exclude CVS \
151           ./ $RPM_BUILD_ROOT/usr/share/%{name}/
152
153 echo " * Installing web pages"
154 rsync -a www/ $RPM_BUILD_ROOT/var/www/cgi-bin/monitor/
155 rsync -a log/ $RPM_BUILD_ROOT/var/www/html/monitorlog/
156
157 echo " * Installing cron job for automated polling"
158 install -D -m 644 monitor-server.cron $RPM_BUILD_ROOT/%{_sysconfdir}/cron.d/monitor-server.cron
159 echo " * TODO: Setting up Monitor account in local MyPLC"
160 # TODO: 
161
162 install -d $RPM_BUILD_ROOT/%{python_sitearch}/monitor
163 install -d -D -m 755 monitor $RPM_BUILD_ROOT/%{python_sitearch}/monitor
164 # TODO: need a much better way to do this.
165 rsync -a monitor/ $RPM_BUILD_ROOT/%{python_sitearch}/monitor/
166 #for file in __init__.py database.py config.py ; do 
167 #       install -D -m 644 monitor/$file $RPM_BUILD_ROOT/%{python_sitearch}/monitor/$file
168 #done
169 rsync -a pcucontrol/ $RPM_BUILD_ROOT/%{python_sitearch}/pcucontrol/
170 install -D -m 755 threadpool.py $RPM_BUILD_ROOT/%{python_sitearch}/threadpool.py
171
172 touch $RPM_BUILD_ROOT/var/www/cgi-bin/monitor/monitorconfig.php
173 chmod 777 $RPM_BUILD_ROOT/var/www/cgi-bin/monitor/monitorconfig.php
174
175 #install -D -m 755 monitor-default.conf $RPM_BUILD_ROOT/etc/monitor.conf
176 #cp $RPM_BUILD_ROOT/usr/share/%{name}/monitorconfig-default.py $RPM_BUILD_ROOT/usr/share/%{name}/monitorconfig.py
177
178 #################### RunlevelAgent
179 install -D -m 755 RunlevelAgent.py $RPM_BUILD_ROOT/usr/bin/RunlevelAgent.py
180 install -D -m 755 monitor-runlevelagent.init $RPM_BUILD_ROOT/%{_initrddir}/monitor-runlevelagent
181
182 mkdir -p $RPM_BUILD_ROOT/var/log
183 touch $RPM_BUILD_ROOT/var/log/server-deps.log
184
185
186 %clean
187 rm -rf $RPM_BUILD_ROOT
188
189 %files server-deps
190 /var/log/server-deps.log
191
192 %files server
193 %defattr(-,root,root)
194 #%config /usr/share/%{name}/monitorconfig.py
195 #%config /etc/monitor.conf
196 /usr/share/%{name}
197 /var/lib/%{name}
198 /var/www/cgi-bin/monitor
199 %{_sysconfdir}/cron.d/monitor-server.cron
200 %{python_sitearch}/threadpool.py
201 %{python_sitearch}/threadpool.pyc
202 %{python_sitearch}/threadpool.pyo
203 %{python_sitearch}/monitor
204 %{_sysconfdir}/plc.d/monitor
205 %{_sysconfdir}/plc.d/monitor.functions
206 %{_sysconfdir}/plc.d/zabbix
207
208 %files client
209 %defattr(-,root,root)
210 %{_initrddir}/monitor
211 %{_sysconfdir}/cron.d/monitor
212 /usr/bin/timeout.pl
213
214 %files pcucontrol
215 %{python_sitearch}/pcucontrol
216
217 %files runlevelagent
218 /usr/bin/RunlevelAgent.py
219 /usr/bin/RunlevelAgent.pyo
220 /usr/bin/RunlevelAgent.pyc
221 /%{_initrddir}/monitor-runlevelagent
222
223 %post server-deps
224 #easy_install --build-directory /var/tmp -UZ ElementTree
225 ##easy_install --build-directory /var/tmp -UZ http://pypi.python.org/packages/2.5/E/Extremes/Extremes-1.1-py2.5.egg
226
227
228 ## TODO: something is bad wrong with this approach.
229 easy_install --build-directory /var/tmp -UZ http://files.turbogears.org/eggs/TurboGears-1.0.7-py2.5.egg
230 easy_install --build-directory /var/tmp -UZ http://pypi.python.org/packages/source/S/SQLAlchemy/SQLAlchemy-0.5.3.tar.gz
231 easy_install --build-directory /var/tmp -UZ Elixir
232
233 # crazy openssl libs for racadm binary
234 ln -s /lib/libssl.so.0.9.8b /usr/lib/libssl.so.2
235 mkdir %{_datadir}/%{name}/.ssh
236 chmod 700 %{_datadir}/%{name}/.ssh
237
238 if grep 'pam_loginuid.so' /etc/pam.d/crond ; then
239     sed -i -e 's/^session    required   pam_loginuid.so/#session    required   pam_loginuid.so/g' /etc/pam.d/crond
240 fi
241
242 # NOTE: enable monitor by default, since we're installing it.
243 plc-config --save /etc/planetlab/configs/site.xml \
244                         --category plc_monitor --variable enabled --value true
245 plc-config --save /etc/planetlab/configs/site.xml \
246                         --category plc_monitor --variable from_email --value monitor@localhost.localdomain
247 plc-config --save /etc/planetlab/configs/site.xml \
248                         --category plc_monitor --variable cc_email --value monitor@localhost.localdomain
249 plc-config --save /etc/planetlab/configs/site.xml \
250                         --category plc_monitor --variable rt_queue --value support
251
252 # NOTE: setup default values until myplc includes them by default.
253 plc-config --save /etc/planetlab/configs/site.xml \
254                         --category plc_rt --variable enabled --value false
255 plc-config --save /etc/planetlab/configs/site.xml \
256                         --category plc_rt --variable host --value localhost.localdomain
257 plc-config --save /etc/planetlab/configs/site.xml \
258                         --category plc_rt --variable ip --value ""
259 plc-config --save /etc/planetlab/configs/site.xml \
260                         --category plc_rt --variable web_user --value root
261 plc-config --save /etc/planetlab/configs/site.xml \
262                         --category plc_rt --variable web_password --value password
263
264 # zabbix:
265 plc-config --save /etc/planetlab/configs/site.xml \
266                         --category plc_zabbix --variable enabled --value false
267 plc-config --save /etc/planetlab/configs/site.xml \
268                         --category plc_zabbix --variable host --value localhost.localdomain
269 plc-config --save /etc/planetlab/configs/site.xml \
270                         --category plc_zabbix --variable ip --value ""
271
272 %post server
273 # TODO: this will be nice when we have a web-based service running., such as
274 #               an API server or so on.
275 # TODO: create real monitorconfig.py from monitorconfig-default.py
276 # TODO: create monitorconfig.php using phpconfig.py 
277 # TODO: create symlink in /var/lib/monitor for chroot environments
278 # TODO: update the content of automate_pl03.sh 
279 # TODO: Use the installed version of bootcd to create custom boot images. ( or, use the api now).
280
281 # NOTE: generate the python defines from zabbix include files.
282 #php /usr/share/%{name}/zabbix/getdefines.php > %{python_sitearch}/monitor/database/zabbixapi/defines.py
283
284 # apply patches to zabbix
285 #patch -d /var/www/html/zabbix/ -p0 < /usr/share/%{name}/zabbix/zabbix-auto-login.diff
286
287 #chkconfig --add monitor-server
288 #chkconfig monitor-server on
289
290 %post client
291 chkconfig --add monitor
292 chkconfig monitor on
293
294 %post runlevelagent
295 chkconfig --add monitor-runlevelagent
296 chkconfig monitor-runlevelagent on
297 if [ "$PL_BOOTCD" != "1" ] ; then
298         service monitor-runlevelagent restart
299 fi
300
301
302 %changelog
303 * Sun Jun 28 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-18
304 - bug fixes.
305 - improved templates and views
306 - cleaned controller code for web
307 - added IPMI requirement to pcucontrol package.
308
309 * Thu Jun 18 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-17
310 - added bootmanager log links
311 - addressed root cause of IntegrityErrors ; big deal
312 - adjusted templates to accomodate fix for IntegrityErrors
313 - added session.flush() to bootman.py to write out ActionsRecords
314 - fixed policy to either pause penalties or apply them ; not both.
315
316 -* Wed Jun 17 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-16
317 -- Added Rpyc from 1.0 branch.
318 -- add pcuhistory
319 -- add setup-agent for password protected keys.
320 -- other minor improvements.
321
322 * Wed Jun 17 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-15
323 - automate install
324 - auto-close tickets
325
326 * Fri Jun 12 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-14
327 - update web
328 - update policy
329 - added statistics dir
330
331 * Mon Jun 08 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-13
332 - remove plccache from controllers, all lookups from db.
333 - reformat emailTxt messags
334 - updated bootstates in bootman.py
335
336 * Tue Jun 02 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-12
337 - tag of latest changes.
338 - need to test end to end.
339
340 * Sat May 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - Monitor-3.0-11
341 - big merge from the 2.0 branch
342
343 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - Monitor-3.0-10
344 - minor improvements in rendering with sortable tables
345
346 * Tue May 19 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - Monitor-3.0-9
347
348 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - Monitor-3.0-8
349 - first draft with sortable tables + checkpoint
350
351 * Fri May 15 2009 Baris Metin <tmetin@sophia.inria.fr>
352 - use plekit tables from plewww.
353 - depend on plewww-plekit
354
355 * Tue May 12 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-7
356 - make docs a noop
357 - fix for package name dependency
358 - correct docs
359
360 * Mon May 04 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-6
361 - add improved docs to the latest build and tag.
362
363 * Mon May 04 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-5
364 - add documentation hooks for adding in-line docs like NM and PLCAPI
365
366 * Fri May 01 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-4
367 - Rough pass over monitor-3.0 to allow it to work with 4.3 API.
368 - replaced GetNodeNetworks, nodeinterface_ids and using new bootstates
369 - 'safeboot', 'failboot', 'reinstall', etc.
370
371 * Tue Apr 28 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-3
372 - same as 2.0-12 tag.
373
374 * Mon Apr 27 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-2
375 - merge from 2.0, remove more zabbix code, simplify install, etc.
376
377 * Thu Apr 16 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-1
378 - major merge from 2.0 branch.
379 - ready to be updated with 4.3 and web changes.
380
381 * Fri Feb 27 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-2.0-1
382 - preparing to make a 2.0 branch for monitor.
383
384 * Mon Jan 05 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-2.0-0
385 - new changes are significantly different, that I'm upping the number for clarity.
386
387 * Wed Sep 24 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-8
388 - These are all changes in the latest Monitor code.  I will branch this version
389 - next, before making additional large changes.
390
391 * Mon Sep 01 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - Monitor-1.0-7
392 - Checkpointing current version for 4.2-rc21 - many many changes
393
394 * Mon Aug 11 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-6
395 - This is a major tag of every thing.  probably needs a very different release
396 - number.
397
398 * Fri Jul 18 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-5
399 - Incremental improvements
400
401 * Mon May 19 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-4
402 - tagging everything for OneLab tech-transfer.
403
404
405 * Fri May 09 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-3
406
407
408 * Mon May 05 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-2
409
410
411 * Wed Apr 23 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-1
412 - This should be ready for 4.2rc2
413
414
415 * Mon Apr 07 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - monitor-1.0-0
416 - initial addition.
417
418 %define module_current_branch 2.0