remove rt from monitor package.
[monitor.git] / Monitor.spec
1 #
2 # $Id$
3
4
5 %define url $URL: svn+ssh://svn.planet-lab.org/svn/monitor/trunk/monitor.spec $
6
7 %define name monitor
8 %define version 3.0
9 %define taglevel 17
10
11 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
12 %global python_sitearch %( python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)" )
13
14 Name: %{name}
15 Version: %{version}
16 Release: %{release}
17 Source0: %{name}-%{version}.tar.bz2
18 License: GPL
19 Group: Applications/System
20 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
21
22 Vendor: PlanetLab
23 Packager: PlanetLab Central <support@planet-lab.org>
24 Distribution: PlanetLab %{plrelease}
25 URL: %(echo %{url} | cut -d ' ' -f 2)
26
27 Summary: Monitor account initialization for the root image.
28 Group: Applications/System
29
30 %description
31 Monitor is a collection of secondary scripts for configuring the node polling
32 system, syncing the PLC db with the monitoring database, notifying users,
33 interacting with PCU hardware, applying penalties to sites that violate
34 acceptable use.
35
36 ######################################## CLIENT
37
38 %package client
39 Summary: Monitor hooks for a PLC node
40 Group: Applications/System
41 Requires: curl
42 Requires: coreutils
43
44 %description client
45 The client scripts handle account creation inside of a node.  This will
46 include configuration setup for the monitoring agent running on the node.  It
47 will also include any cron or init scripts needed to perform this kind of
48 maintenance.
49 ######################################## Server Deps
50 %package server-deps
51 Summary: Monitor hooks for the PLC server.
52 Group: Applications/System
53
54 Requires: python
55 Requires: python-setuptools-devel
56 Requires: python-peak-util-extremes
57 Requires: TurboGears
58
59 Requires: compat-libstdc++-296
60 Requires: openssh-clients
61 Requires: perl-libwww-perl
62 Requires: perl-IO-Socket-SSL 
63 Requires: MySQL-python
64 Requires: nmap
65 Requires: rt3
66
67 Requires: plewww-plekit
68
69 #Requires: zabbix-client
70 #Requires: zabbix-gui
71 #Requires: zabbix-server
72
73 %description server-deps
74 The server side include all python modules and scripts needed to fully
75
76 ######################################## Server
77 %package server
78 Summary: Monitor hooks for the PLC server.
79 Group: Applications/System
80
81 Requires: python
82
83 Requires: monitor-server-deps
84 Requires: monitor-pcucontrol
85 Requires: PLCWWW >= 4.2
86 Requires: bootcd-%{pldistro}-%{_arch} >= 4.2
87
88 %description server
89 The server side include all python modules and scripts needed to fully
90 operation, track, and interact with any third-party monitoring software, such
91 as Zabbix DB.
92
93 ######################################## PCU Control
94
95 %package pcucontrol
96 summary: pcu controls for monitor and plcapi
97 group: applications/system
98 requires: python
99 requires: OpenIPMI-tools
100
101 %description pcucontrol
102 both monitor and the plcapi use a set of common commands to reboot machines
103 using their external or internal pcus.  this package is a library of several
104 supported models.
105
106 ####################################### RunlevelAgent
107 %package runlevelagent
108 summary: the RunlevelAgent that reports node runlevels
109 group: applications/system
110 requires: python
111
112 %description runlevelagent
113 The RunlevelAgent starts as early as possible during boot-up and production
114 mode to actively report the observed runlevel to PLC and update the
115 'last_contact' field.
116
117 %prep
118 %setup -q
119
120 %build
121 # NOTE: the build uses g++ cmdamt/
122 # NOTE: TMPDIR is needed here b/c the tmpfs of the build vserver is too small.
123 cd pcucontrol/models/intelamt
124 export TMPDIR=$PWD/tmp
125 make
126 cd ..
127
128 %install
129 rm -rf $RPM_BUILD_ROOT
130 #################### CLIENT 
131 install -D -m 755 monitor-client.init $RPM_BUILD_ROOT/%{_initrddir}/monitor
132 install -D -m 644 monitor.cron $RPM_BUILD_ROOT/%{_sysconfdir}/cron.d/monitor
133
134 #################### SERVER
135 install -d $RPM_BUILD_ROOT/usr/share/%{name}
136 install -d $RPM_BUILD_ROOT/data/var/lib/%{name}
137 install -d $RPM_BUILD_ROOT/data/var/lib/%{name}/archive-pdb
138 install -d $RPM_BUILD_ROOT/var/lib/%{name}
139 install -d $RPM_BUILD_ROOT/var/lib/%{name}/archive-pdb
140 install -d $RPM_BUILD_ROOT/var/www/cgi-bin/monitor/
141 install -d $RPM_BUILD_ROOT/var/www/html/monitorlog/
142
143 install -D -m 644 monitor.functions $RPM_BUILD_ROOT/%{_sysconfdir}/plc.d/monitor.functions
144 install -D -m 755 monitor-server.init $RPM_BUILD_ROOT/%{_sysconfdir}/plc.d/monitor
145 install -D -m 755 zabbix/monitor-zabbix.init $RPM_BUILD_ROOT/%{_sysconfdir}/plc.d/zabbix
146
147 echo " * Installing core scripts"
148 rsync -a --exclude www --exclude archive-pdb --exclude .svn --exclude CVS \
149           ./ $RPM_BUILD_ROOT/usr/share/%{name}/
150
151 echo " * Installing web pages"
152 rsync -a www/ $RPM_BUILD_ROOT/var/www/cgi-bin/monitor/
153 rsync -a log/ $RPM_BUILD_ROOT/var/www/html/monitorlog/
154
155 echo " * Installing cron job for automated polling"
156 install -D -m 644 monitor-server.cron $RPM_BUILD_ROOT/%{_sysconfdir}/cron.d/monitor-server.cron
157 echo " * TODO: Setting up Monitor account in local MyPLC"
158 # TODO: 
159
160 install -d $RPM_BUILD_ROOT/%{python_sitearch}/monitor
161 install -d -D -m 755 monitor $RPM_BUILD_ROOT/%{python_sitearch}/monitor
162 # TODO: need a much better way to do this.
163 rsync -a monitor/ $RPM_BUILD_ROOT/%{python_sitearch}/monitor/
164 #for file in __init__.py database.py config.py ; do 
165 #       install -D -m 644 monitor/$file $RPM_BUILD_ROOT/%{python_sitearch}/monitor/$file
166 #done
167 rsync -a pcucontrol/ $RPM_BUILD_ROOT/%{python_sitearch}/pcucontrol/
168 install -D -m 755 threadpool.py $RPM_BUILD_ROOT/%{python_sitearch}/threadpool.py
169
170 touch $RPM_BUILD_ROOT/var/www/cgi-bin/monitor/monitorconfig.php
171 chmod 777 $RPM_BUILD_ROOT/var/www/cgi-bin/monitor/monitorconfig.php
172
173 #install -D -m 755 monitor-default.conf $RPM_BUILD_ROOT/etc/monitor.conf
174 #cp $RPM_BUILD_ROOT/usr/share/%{name}/monitorconfig-default.py $RPM_BUILD_ROOT/usr/share/%{name}/monitorconfig.py
175
176 #################### RunlevelAgent
177 install -D -m 755 RunlevelAgent.py $RPM_BUILD_ROOT/usr/bin/RunlevelAgent.py
178 install -D -m 755 monitor-runlevelagent.init $RPM_BUILD_ROOT/%{_initrddir}/monitor-runlevelagent
179
180 mkdir -p $RPM_BUILD_ROOT/var/log
181 touch $RPM_BUILD_ROOT/var/log/server-deps.log
182
183
184 %clean
185 rm -rf $RPM_BUILD_ROOT
186
187 %files server-deps
188 /var/log/server-deps.log
189
190 %files server
191 %defattr(-,root,root)
192 #%config /usr/share/%{name}/monitorconfig.py
193 #%config /etc/monitor.conf
194 /usr/share/%{name}
195 /var/lib/%{name}
196 /var/www/cgi-bin/monitor
197 %{_sysconfdir}/cron.d/monitor-server.cron
198 %{python_sitearch}/threadpool.py
199 %{python_sitearch}/threadpool.pyc
200 %{python_sitearch}/threadpool.pyo
201 %{python_sitearch}/monitor
202 %{_sysconfdir}/plc.d/monitor
203 %{_sysconfdir}/plc.d/monitor.functions
204 %{_sysconfdir}/plc.d/zabbix
205
206 %files client
207 %defattr(-,root,root)
208 %{_initrddir}/monitor
209 %{_sysconfdir}/cron.d/monitor
210
211 %files pcucontrol
212 %{python_sitearch}/pcucontrol
213
214 %files runlevelagent
215 /usr/bin/RunlevelAgent.py
216 /usr/bin/RunlevelAgent.pyo
217 /usr/bin/RunlevelAgent.pyc
218 /%{_initrddir}/monitor-runlevelagent
219
220 %post server-deps
221 #easy_install --build-directory /var/tmp -UZ ElementTree
222 ##easy_install --build-directory /var/tmp -UZ http://pypi.python.org/packages/2.5/E/Extremes/Extremes-1.1-py2.5.egg
223
224
225 ## TODO: something is bad wrong with this approach.
226 easy_install --build-directory /var/tmp -UZ http://files.turbogears.org/eggs/TurboGears-1.0.7-py2.5.egg
227 easy_install --build-directory /var/tmp -UZ http://pypi.python.org/packages/source/S/SQLAlchemy/SQLAlchemy-0.5.3.tar.gz
228 easy_install --build-directory /var/tmp -UZ Elixir
229
230 # crazy openssl libs for racadm binary
231 ln -s /lib/libssl.so.0.9.8b /usr/lib/libssl.so.2
232 mkdir /usr/share/monitor/.ssh
233 chmod 700 /usr/share/monitor/.ssh
234
235 if grep 'pam_loginuid.so' /etc/pam.d/crond ; then
236     sed -i -e 's/^session    required   pam_loginuid.so/#session    required   pam_loginuid.so/g' /etc/pam.d/crond
237 fi
238 # NOTE: add the default xml stuff if it's not already in the default xml config.
239 if ! grep '<category id="plc_monitor">' /etc/planetlab/default_config.xml ; then 
240     sed -i 's|<category id="plc_net">| <category id="plc_monitor">\n <name>Monitor Service Configuration</name>\n <description>Monitor</description>\n <variablelist>\n <variable id="enabled" type="boolean">\n <name>Enabled</name>\n <value>true</value>\n <description>Enable on this machine.</description>\n </variable>\n <variable id="email">\n <value></value>\n </variable>\n <variable id="dbpassword">\n <value></value>\n </variable>\n <variable id="host" type="hostname">\n <name>Hostname</name>\n <value>pl-virtual-06.cs.princeton.edu</value>\n <description>The fully qualified hostname.</description>\n </variable>\n <variable id="ip" type="ip">\n <name>IP Address</name>\n <value/>\n <description>The IP address of the monitor server.</description>\n </variable>\n </variablelist>\n </category>\n <category id="plc_net">|' /etc/planetlab/default_config.xml
241 fi
242 if ! grep '<category id="plc_zabbix">' /etc/planetlab/default_config.xml ; then 
243     sed -i 's|<category id="plc_net">| <category id="plc_zabbix">\n <name>Zabbix Configuration</name>\n <description>Zabbix</description>\n <variablelist>\n <variable id="enabled" type="boolean">\n <name>Enabled</name>\n <value>false</value>\n <description>Enable on this machine.</description>\n </variable>\n <variable id="host" type="hostname">\n <name>Hostname</name>\n <value>localhost.localdomain</value>\n <description>The fully qualified hostname.</description>\n </variable>\n <variable id="ip" type="ip">\n <name>IP Address</name>\n <value/>\n <description>The IP address of the Zabbix server.</description>\n </variable>\n </variablelist>\n </category>\n <category id="plc_net">|' /etc/planetlab/default_config.xml
244 fi
245
246 # NOTE: enable monitor by default, since we're installing it.
247 plc-config --save /etc/planetlab/default_config.xml \
248                         --category plc_monitor --variable enabled --value true
249
250 %post server
251 # TODO: this will be nice when we have a web-based service running., such as
252 #               an API server or so on.
253 # TODO: create real monitorconfig.py from monitorconfig-default.py
254 # TODO: create monitorconfig.php using phpconfig.py 
255 # TODO: create symlink in /var/lib/monitor for chroot environments
256 # TODO: update the content of automate_pl03.sh 
257 # TODO: Use the installed version of bootcd to create custom boot images. ( or, use the api now).
258
259 # NOTE: generate the python defines from zabbix include files.
260 #php /usr/share/%{name}/zabbix/getdefines.php > %{python_sitearch}/monitor/database/zabbixapi/defines.py
261
262 # apply patches to zabbix
263 #patch -d /var/www/html/zabbix/ -p0 < /usr/share/%{name}/zabbix/zabbix-auto-login.diff
264
265 #chkconfig --add monitor-server
266 #chkconfig monitor-server on
267
268 %post client
269 chkconfig --add monitor
270 chkconfig monitor on
271
272 %post runlevelagent
273 chkconfig --add monitor-runlevelagent
274 chkconfig monitor-runlevelagent on
275 if [ "$PL_BOOTCD" != "1" ] ; then
276         service monitor-runlevelagent restart
277 fi
278
279
280 %changelog
281 * Thu Jun 18 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-17
282 - added bootmanager log links
283 - addressed root cause of IntegrityErrors ; big deal
284 - adjusted templates to accomodate fix for IntegrityErrors
285 - added session.flush() to bootman.py to write out ActionsRecords
286 - fixed policy to either pause penalties or apply them ; not both.
287
288 -* Wed Jun 17 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-16
289 -- Added Rpyc from 1.0 branch.
290 -- add pcuhistory
291 -- add setup-agent for password protected keys.
292 -- other minor improvements.
293
294 * Wed Jun 17 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-15
295 - automate install
296 - auto-close tickets
297
298 * Fri Jun 12 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-14
299 - update web
300 - update policy
301 - added statistics dir
302
303 * Mon Jun 08 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-13
304 - remove plccache from controllers, all lookups from db.
305 - reformat emailTxt messags
306 - updated bootstates in bootman.py
307
308 * Tue Jun 02 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-12
309 - tag of latest changes.
310 - need to test end to end.
311
312 * Sat May 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - Monitor-3.0-11
313 - big merge from the 2.0 branch
314
315 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - Monitor-3.0-10
316 - minor improvements in rendering with sortable tables
317
318 * Tue May 19 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - Monitor-3.0-9
319
320 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - Monitor-3.0-8
321 - first draft with sortable tables + checkpoint
322
323 * Fri May 15 2009 Baris Metin <tmetin@sophia.inria.fr>
324 - use plekit tables from plewww.
325 - depend on plewww-plekit
326
327 * Tue May 12 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-7
328 - make docs a noop
329 - fix for package name dependency
330 - correct docs
331
332 * Mon May 04 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-6
333 - add improved docs to the latest build and tag.
334
335 * Mon May 04 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-5
336 - add documentation hooks for adding in-line docs like NM and PLCAPI
337
338 * Fri May 01 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-4
339 - Rough pass over monitor-3.0 to allow it to work with 4.3 API.
340 - replaced GetNodeNetworks, nodeinterface_ids and using new bootstates
341 - 'safeboot', 'failboot', 'reinstall', etc.
342
343 * Tue Apr 28 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-3
344 - same as 2.0-12 tag.
345
346 * Mon Apr 27 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-2
347 - merge from 2.0, remove more zabbix code, simplify install, etc.
348
349 * Thu Apr 16 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-1
350 - major merge from 2.0 branch.
351 - ready to be updated with 4.3 and web changes.
352
353 * Fri Feb 27 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-2.0-1
354 - preparing to make a 2.0 branch for monitor.
355
356 * Mon Jan 05 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-2.0-0
357 - new changes are significantly different, that I'm upping the number for clarity.
358
359 * Wed Sep 24 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-8
360 - These are all changes in the latest Monitor code.  I will branch this version
361 - next, before making additional large changes.
362
363 * Mon Sep 01 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - Monitor-1.0-7
364 - Checkpointing current version for 4.2-rc21 - many many changes
365
366 * Mon Aug 11 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-6
367 - This is a major tag of every thing.  probably needs a very different release
368 - number.
369
370 * Fri Jul 18 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-5
371 - Incremental improvements
372
373 * Mon May 19 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-4
374 - tagging everything for OneLab tech-transfer.
375
376
377 * Fri May 09 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-3
378
379
380 * Mon May 05 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-2
381
382
383 * Wed Apr 23 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-1
384 - This should be ready for 4.2rc2
385
386
387 * Mon Apr 07 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - monitor-1.0-0
388 - initial addition.
389
390 %define module_current_branch 2.0