setuptools don't really care about --build-directory.
[monitor.git] / Monitor.spec
1 #
2 # $Id$
3
4
5 %define url $URL: svn+ssh://svn.planet-lab.org/svn/monitor/trunk/monitor.spec $
6
7 %define name monitor
8 # keep this version in sync with monitor/monitor_version.py
9 %define version 3.0
10 %define taglevel 26
11
12 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
13 %global python_sitearch %( python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)" )
14
15 Name: %{name}
16 Version: %{version}
17 Release: %{release}
18 Source0: %{name}-%{version}.tar.bz2
19 License: GPL
20 Group: Applications/System
21 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
22
23 Vendor: PlanetLab
24 Packager: PlanetLab Central <support@planet-lab.org>
25 Distribution: PlanetLab %{plrelease}
26 URL: %(echo %{url} | cut -d ' ' -f 2)
27
28 BuildRequires: python-setuptools-devel
29
30
31 Summary: Monitor account initialization for the root image.
32 Group: Applications/System
33
34 %description
35 Monitor is a collection of secondary scripts for configuring the node polling
36 system, syncing the PLC db with the monitoring database, notifying users,
37 interacting with PCU hardware, applying penalties to sites that violate
38 acceptable use.
39
40 ######################################## CLIENT
41
42 %package client
43 Summary: Monitor hooks for a PLC node
44 Group: Applications/System
45 Requires: curl
46 Requires: coreutils
47
48 %description client
49 The client scripts handle account creation inside of a node.  This will
50 include configuration setup for the monitoring agent running on the node.  It
51 will also include any cron or init scripts needed to perform this kind of
52 maintenance.
53 ######################################## Server Deps
54 %package server-deps
55 Summary: Monitor hooks for the PLC server.
56 Group: Applications/System
57
58 Requires: python
59 Requires: python-peak-util-extremes
60
61 Requires: compat-libstdc++-296
62 Requires: openssh-clients
63 Requires: perl-libwww-perl
64 Requires: perl-IO-Socket-SSL 
65 Requires: MySQL-python
66 Requires: nmap
67 Requires: nc
68 Requires: rt3
69
70 Requires: plewww-plekit
71
72 #Requires: zabbix-client
73 #Requires: zabbix-gui
74 #Requires: zabbix-server
75
76 %description server-deps
77 The server side include all python modules and scripts needed to fully
78
79 ######################################## Server
80 %package server
81 Summary: Monitor hooks for the PLC server.
82 Group: Applications/System
83
84 Requires: python
85
86 Requires: monitor-server-deps
87 Requires: monitor-pcucontrol
88 Requires: PLCWWW >= 4.2
89 Requires: bootcd-%{pldistro}-%{_arch} >= 4.2
90
91 %description server
92 The server side include all python modules and scripts needed to fully
93 operation, track, and interact with any third-party monitoring software, such
94 as Zabbix DB.
95
96 ######################################## PCU Control
97
98 %package pcucontrol
99 summary: pcu controls for monitor and plcapi
100 group: applications/system
101 requires: python
102 requires: OpenIPMI-tools
103
104 %description pcucontrol
105 both monitor and the plcapi use a set of common commands to reboot machines
106 using their external or internal pcus.  this package is a library of several
107 supported models.
108
109 ####################################### RunlevelAgent
110 %package runlevelagent
111 summary: the RunlevelAgent that reports node runlevels
112 group: applications/system
113 requires: python
114
115 %description runlevelagent
116 The RunlevelAgent starts as early as possible during boot-up and production
117 mode to actively report the observed runlevel to PLC and update the
118 'last_contact' field.
119
120 %prep
121 %setup -q
122
123 %build
124 # NOTE: the build uses g++ cmdamt/
125 # NOTE: TMPDIR is needed here b/c the tmpfs of the build vserver is too small.
126 cd pcucontrol/models/intelamt
127 export TMPDIR=$PWD/tmp
128 make
129 cd ..
130
131 %install
132 rm -rf $RPM_BUILD_ROOT
133 #################### CLIENT 
134 #install -D -m 755 monitor-client.init $RPM_BUILD_ROOT/%{_initrddir}/monitor
135 #install -D -m 644 monitor.cron $RPM_BUILD_ROOT/%{_sysconfdir}/cron.d/monitor
136 install -D -m 755 tools/timeout.pl $RPM_BUILD_ROOT/usr/bin/timeout.pl
137
138
139 #################### SERVER
140 install -d $RPM_BUILD_ROOT/usr/share/%{name}
141 install -d $RPM_BUILD_ROOT/data/var/lib/%{name}
142 install -d $RPM_BUILD_ROOT/data/var/lib/%{name}/archive-pdb
143 install -d $RPM_BUILD_ROOT/var/lib/%{name}
144 install -d $RPM_BUILD_ROOT/var/lib/%{name}/archive-pdb
145 install -d $RPM_BUILD_ROOT/var/www/html/monitorlog/
146 install -d $RPM_BUILD_ROOT/etc/httpd/conf.d/
147 install -d $RPM_BUILD_ROOT/%{python_sitearch}/monitor
148
149 # pack monitor's dependencies in RPM to make it easier to deploy.
150 export TMPDIR=/var/tmp/
151 export PYTHONPATH=$PYTHONPATH:$RPM_BUILD_ROOT/%{python_sitearch}/
152 easy_install -d $RPM_BUILD_ROOT/%{python_sitearch}/ -UZ http://files.turbogears.org/eggs/TurboGears-1.0.7-py2.5.egg
153 easy_install -d $RPM_BUILD_ROOT/%{python_sitearch}/ -UZ http://pypi.python.org/packages/source/S/SQLAlchemy/SQLAlchemy-0.5.3.tar.gz
154 easy_install -d $RPM_BUILD_ROOT/%{python_sitearch}/ -UZ Elixir
155 rm -rf $RPM_BUILD_ROOT/%{python_sitearch}/site.py*
156
157 # plc.d scripts
158 install -D -m 644 monitor.functions $RPM_BUILD_ROOT/%{_sysconfdir}/plc.d/monitor.functions
159 install -D -m 755 monitor-server.init $RPM_BUILD_ROOT/%{_sysconfdir}/plc.d/monitor
160 install -D -m 755 zabbix/monitor-zabbix.init $RPM_BUILD_ROOT/%{_sysconfdir}/plc.d/zabbix
161
162 # cron job for automated polling
163 install -D -m 644 monitor-server.cron $RPM_BUILD_ROOT/%{_sysconfdir}/cron.d/monitor-server.cron
164
165 # apache configuration
166 install -D -m 644 web/monitorweb-httpd.conf $RPM_BUILD_ROOT/etc/httpd/conf.d/
167
168 # we'll install monitor and pcucontrol in site-packages
169 # install rest to /usr/share/monitor
170 rsync -a --exclude archive-pdb --exclude .svn --exclude CVS  \
171     --exclude monitor/ \
172     --exclude pcucontol/ \
173     ./  $RPM_BUILD_ROOT/usr/share/%{name}/
174
175 # install monitor python package
176 rsync -a --exclude .svn  ./monitor/   $RPM_BUILD_ROOT/%{python_sitearch}/monitor/
177
178 # and pcucontrol
179 rsync -a --exclude .svn  ./pcucontrol/    $RPM_BUILD_ROOT/%{python_sitearch}/pcucontrol/
180
181 # install third-party module to site-packages
182 install -D -m 755 threadpool.py $RPM_BUILD_ROOT/%{python_sitearch}/threadpool.py
183
184 # TODO: 
185 echo " * TODO: Setting up Monitor account in local MyPLC"
186
187 #touch $RPM_BUILD_ROOT/var/www/cgi-bin/monitor/monitorconfig.php
188 #chmod 777 $RPM_BUILD_ROOT/var/www/cgi-bin/monitor/monitorconfig.php
189
190 #install -D -m 755 monitor-default.conf $RPM_BUILD_ROOT/etc/monitor.conf
191 #cp $RPM_BUILD_ROOT/usr/share/%{name}/monitorconfig-default.py $RPM_BUILD_ROOT/usr/share/%{name}/monitorconfig.py
192
193 #################### RunlevelAgent
194 install -D -m 755 RunlevelAgent.py $RPM_BUILD_ROOT/usr/bin/RunlevelAgent.py
195 install -D -m 755 monitor-runlevelagent.init $RPM_BUILD_ROOT/%{_initrddir}/monitor-runlevelagent
196
197 mkdir -p $RPM_BUILD_ROOT/var/log
198 touch $RPM_BUILD_ROOT/var/log/server-deps.log
199
200
201 %clean
202 rm -rf $RPM_BUILD_ROOT
203
204 %files server-deps
205 /var/log/server-deps.log
206
207 %files server
208 %defattr(-,root,root)
209 #%config /usr/share/%{name}/monitorconfig.py
210 #%config /etc/monitor.conf
211 /usr/share/%{name}
212 /var/lib/%{name}
213 #/var/www/cgi-bin/monitor
214 %{_sysconfdir}/cron.d/monitor-server.cron
215 %{python_sitearch}/threadpool.py*
216 %{python_sitearch}/monitor
217 %{python_sitearch}/*.egg/
218 %{python_sitearch}/easy-install.pth
219 %{python_sitearch}/tg-admin
220 %{_sysconfdir}/plc.d/monitor
221 %{_sysconfdir}/plc.d/monitor.functions
222 %{_sysconfdir}/plc.d/zabbix
223 %{_sysconfdir}/httpd/conf.d
224
225 %files client
226 %defattr(-,root,root)
227 #%{_initrddir}/monitor
228 #%{_sysconfdir}/cron.d/monitor
229 /usr/bin/timeout.pl
230
231 %files pcucontrol
232 %{python_sitearch}/pcucontrol
233
234 %files runlevelagent
235 /usr/bin/RunlevelAgent.py
236 /usr/bin/RunlevelAgent.pyo
237 /usr/bin/RunlevelAgent.pyc
238 /%{_initrddir}/monitor-runlevelagent
239
240 %post server-deps
241
242 # crazy openssl libs for racadm binary
243 ln -s /lib/libssl.so.0.9.8b /usr/lib/libssl.so.2
244 mkdir %{_datadir}/%{name}/.ssh
245 chmod 700 %{_datadir}/%{name}/.ssh
246
247 if grep 'pam_loginuid.so' /etc/pam.d/crond ; then
248     sed -i -e 's/^session    required   pam_loginuid.so/#session    required   pam_loginuid.so/g' /etc/pam.d/crond
249 fi
250
251 # NOTE: enable monitor by default, since we're installing it.
252 if ! plc-config --category plc_monitor --variable enabled ; then 
253         plc-config --category plc_monitor --variable enabled --value true \
254                         --save /etc/planetlab/configs/site.xml  /etc/planetlab/configs/site.xml 
255 fi
256 if ! plc-config --category plc_monitor --variable from_email ; then
257         plc-config --category plc_monitor --variable from_email --value monitor@localhost.localdomain \
258                         --save /etc/planetlab/configs/site.xml /etc/planetlab/configs/site.xml 
259 fi
260 if ! plc-config --category plc_monitor --variable cc_email ; then
261         plc-config --category plc_monitor --variable cc_email --value monitor@localhost.localdomain \
262                         --save /etc/planetlab/configs/site.xml /etc/planetlab/configs/site.xml 
263 fi
264 if ! plc-config --category plc_monitor --variable rt_queue ; then
265         plc-config --category plc_monitor --variable rt_queue --value support \
266                         --save /etc/planetlab/configs/site.xml /etc/planetlab/configs/site.xml 
267 fi
268
269 # zabbix:
270 if ! plc-config --category plc_zabbix --variable enabled ; then
271         plc-config --category plc_zabbix --variable enabled --value false \
272                         --save /etc/planetlab/configs/site.xml /etc/planetlab/configs/site.xml 
273 fi
274 if ! plc-config --category plc_zabbix --variable host ; then
275         plc-config --category plc_zabbix --variable host --value localhost.localdomain \
276                         --save /etc/planetlab/configs/site.xml /etc/planetlab/configs/site.xml 
277 fi
278 if ! plc-config --category plc_zabbix --variable ip ; then
279         plc-config --category plc_zabbix --variable ip --value "" \ 
280                         --save /etc/planetlab/configs/site.xml /etc/planetlab/configs/site.xml 
281 fi
282
283 %post server
284 # TODO: this will be nice when we have a web-based service running., such as
285 #               an API server or so on.
286 # TODO: create real monitorconfig.py from monitorconfig-default.py
287 # TODO: create symlink in /var/lib/monitor for chroot environments
288 # TODO: update the content of automate_pl03.sh 
289 # TODO: Use the installed version of bootcd to create custom boot images. ( or, use the api now).
290
291 # NOTE: generate the python defines from zabbix include files.
292 #php /usr/share/%{name}/zabbix/getdefines.php > %{python_sitearch}/monitor/database/zabbixapi/defines.py
293
294 # apply patches to zabbix
295 #patch -d /var/www/html/zabbix/ -p0 < /usr/share/%{name}/zabbix/zabbix-auto-login.diff
296
297 #chkconfig --add monitor-server
298 #chkconfig monitor-server on
299
300 %post client
301 chkconfig --add monitor
302 chkconfig monitor on
303
304 %post runlevelagent
305 chkconfig --add monitor-runlevelagent
306 chkconfig monitor-runlevelagent on
307 if [ "$PL_BOOTCD" != "1" ] ; then
308         service monitor-runlevelagent restart
309 fi
310
311
312 %changelog
313 * Wed Dec 16 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - Monitor-3.0-26
314 - to many changes, but mostly moved stuff around. there are some small fixes here and there.
315
316 * Fri Nov 20 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-25
317 - add option for site status to include both node & pcu status
318 - improve ticket handling
319 - template gadget.xml for a site-specific google-gadget summary
320
321 * Thu Oct 22 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - Monitor-3.0-24
322 - - add install_date
323
324 * Mon Oct 19 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - Monitor-3.0-23
325 - - remove monitor-client.cron
326 - - remove unused monitor-client init script
327 - - fix UP/DOWN summary on nodes page.
328 - - make node page display all nodes by default
329 - - add boot_server field
330 - - add myops_ssh_key to the keychain
331 - - use ext_consortium_id to distinguish pending sites.
332
333 * Fri Oct 09 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - Monitor-3.0-22
334 - show/hide advance query form.
335
336 * Thu Sep 24 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-21
337 - fixed pause_penalty bug.
338 - fixed IPAL pcucontrol bug
339 - fixed bootman tunnel setup bug (occurred in rare cases)
340 - deprecated pcuview
341 - added BootmanSequenceRecords to separate config data from source code
342 - added get/setBootmanSequence(s) to xmlrpc API
343
344 * Fri Sep 04 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-20
345 - Major Features:
346 - added bm log collection and optional integration with BootManager's log Upload()
347 - added iptables_status
348 - expanded advanced query
349 - added differentiated bootmanager_restore actions so that actionsummary displays
350 - counts for each kind of bootmanager action
351 - added pcuerror notices (for mis-configurations) in addition to pcufailed notices
352 - added plain-text options for query page by adding tg_format=plain to URL
353 - fixed cross-module reference that prevented pcucontrol for working with RebootNodeWithPCU() api call.
354 - fixed a bug in determining whether comon's dir was running on a node
355
356 * Mon Aug 17 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-19
357 - Major increment -
358 - adds multiple features and web changes
359 - adds new fields to db
360 - improved layout
361 - general improvements otherwise
362
363 * Sun Jun 28 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-18
364 - bug fixes.
365 - improved templates and views
366 - cleaned controller code for web
367 - added IPMI requirement to pcucontrol package.
368
369 * Thu Jun 18 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-17
370 - added bootmanager log links
371 - addressed root cause of IntegrityErrors ; big deal
372 - adjusted templates to accomodate fix for IntegrityErrors
373 - added session.flush() to bootman.py to write out ActionsRecords
374 - fixed policy to either pause penalties or apply them ; not both.
375
376 -* Wed Jun 17 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-16
377 -- Added Rpyc from 1.0 branch.
378 -- add pcuhistory
379 -- add setup-agent for password protected keys.
380 -- other minor improvements.
381
382 * Wed Jun 17 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-15
383 - automate install
384 - auto-close tickets
385
386 * Fri Jun 12 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-14
387 - update web
388 - update policy
389 - added statistics dir
390
391 * Mon Jun 08 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-13
392 - remove plccache from controllers, all lookups from db.
393 - reformat emailTxt messags
394 - updated bootstates in bootman.py
395
396 * Tue Jun 02 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-12
397 - tag of latest changes.
398 - need to test end to end.
399
400 * Sat May 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - Monitor-3.0-11
401 - big merge from the 2.0 branch
402
403 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - Monitor-3.0-10
404 - minor improvements in rendering with sortable tables
405
406 * Tue May 19 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - Monitor-3.0-9
407
408 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - Monitor-3.0-8
409 - first draft with sortable tables + checkpoint
410
411 * Fri May 15 2009 Baris Metin <tmetin@sophia.inria.fr>
412 - use plekit tables from plewww.
413 - depend on plewww-plekit
414
415 * Tue May 12 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-7
416 - make docs a noop
417 - fix for package name dependency
418 - correct docs
419
420 * Mon May 04 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-6
421 - add improved docs to the latest build and tag.
422
423 * Mon May 04 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-5
424 - add documentation hooks for adding in-line docs like NM and PLCAPI
425
426 * Fri May 01 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-4
427 - Rough pass over monitor-3.0 to allow it to work with 4.3 API.
428 - replaced GetNodeNetworks, nodeinterface_ids and using new bootstates
429 - 'safeboot', 'failboot', 'reinstall', etc.
430
431 * Tue Apr 28 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-3
432 - same as 2.0-12 tag.
433
434 * Mon Apr 27 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-2
435 - merge from 2.0, remove more zabbix code, simplify install, etc.
436
437 * Thu Apr 16 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-1
438 - major merge from 2.0 branch.
439 - ready to be updated with 4.3 and web changes.
440
441 * Fri Feb 27 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-2.0-1
442 - preparing to make a 2.0 branch for monitor.
443
444 * Mon Jan 05 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-2.0-0
445 - new changes are significantly different, that I'm upping the number for clarity.
446
447 * Wed Sep 24 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-8
448 - These are all changes in the latest Monitor code.  I will branch this version
449 - next, before making additional large changes.
450
451 * Mon Sep 01 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - Monitor-1.0-7
452 - Checkpointing current version for 4.2-rc21 - many many changes
453
454 * Mon Aug 11 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-6
455 - This is a major tag of every thing.  probably needs a very different release
456 - number.
457
458 * Fri Jul 18 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-5
459 - Incremental improvements
460
461 * Mon May 19 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-4
462 - tagging everything for OneLab tech-transfer.
463
464
465 * Fri May 09 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-3
466
467
468 * Mon May 05 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-2
469
470
471 * Wed Apr 23 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-1
472 - This should be ready for 4.2rc2
473
474
475 * Mon Apr 07 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - monitor-1.0-0
476 - initial addition.
477
478 %define module_current_branch 2.0