Remove missing dirs from spec file
[monitor.git] / Monitor.spec
1 #
2 # $Id$
3
4
5 %define url $URL: svn+ssh://svn.planet-lab.org/svn/monitor/trunk/monitor.spec $
6
7 %define name monitor
8 # keep this version in sync with monitor/monitor_version.py
9 %define version 3.1
10 %define taglevel 2
11
12 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
13 %global python_sitearch %( python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)" )
14
15 Name: %{name}
16 Version: %{version}
17 Release: %{release}
18 Source0: %{name}-%{version}.tar.bz2
19 License: GPL
20 Group: Applications/System
21 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
22
23 Vendor: PlanetLab
24 Packager: PlanetLab Central <support@planet-lab.org>
25 Distribution: PlanetLab %{plrelease}
26 URL: %(echo %{url} | cut -d ' ' -f 2)
27
28
29 Summary: Monitor account initialization for the root image.
30 Group: Applications/System
31
32 %description
33 Monitor is a collection of secondary scripts for configuring the node polling
34 system, syncing the PLC db with the monitoring database, notifying users,
35 interacting with PCU hardware, applying penalties to sites that violate
36 acceptable use.
37
38 ######################################## NAGIOS
39
40 %package nagios
41 Summary: Monitor integration with Nagios
42 Group: Applications/System
43
44 Requires: coreutils
45 Requires: passwd
46 Requires: gd
47 Requires: gd-devel
48 Requires: mysql
49 Requires: mysql-server
50 Requires: mysql-devel
51 Requires: mysql-libs
52 Requires: mailx
53 Requires: sendmail
54 Requires: php
55 Requires: httpd
56
57 Requires: cronie
58 Requires: nagios
59 Requires: nagios-common
60 Requires: nagios-devel
61 Requires: nagios-plugins-all
62 Requires: ndoutils
63 Requires: ndoutils-mysql
64
65 Requires: rt3
66
67
68 %description nagios
69 Scripts and setup necessary to integrate and monitor PLC with Nagios.
70 Best suited to F12 or above.
71
72 ######################################## CLIENT
73
74 %package client
75 Summary: Monitor hooks for a PLC node
76 Group: Applications/System
77 Requires: curl
78 Requires: coreutils
79
80 %description client
81 The client scripts handle account creation inside of a node.  This will
82 include configuration setup for the monitoring agent running on the node.  It
83 will also include any cron or init scripts needed to perform this kind of
84 maintenance.
85 ######################################## Server Deps
86 %package server-deps
87 Summary: Monitor hooks for the PLC server.
88 Group: Applications/System
89
90 Requires: python
91 Requires: python-setuptools-devel
92 Requires: python-peak-util-extremes
93
94 Requires: compat-libstdc++-296
95 Requires: openssh-clients
96 Requires: perl-libwww-perl
97 Requires: perl-IO-Socket-SSL 
98 Requires: MySQL-python
99 Requires: perl-DBD-mysql
100 Requires: nmap
101 Requires: mailx
102 Requires: nc
103 Requires: rt3
104 Requires: traceroute
105 Requires: sendmail
106 # 5.0-18 is when the extra monitor plc-config values were added to myplc default_config.xml
107 Requires: myplc >= 5.0-18
108
109 Requires: plewww-plekit
110 Requires: pcucontrol
111 Requires: TurboGears
112
113 #Requires: zabbix-client
114 #Requires: zabbix-gui
115 #Requires: zabbix-server
116
117 %description server-deps
118 The server side include all python modules and scripts needed to fully
119
120 ######################################## Server
121 %package server
122 Summary: Monitor hooks for the PLC server.
123 Group: Applications/System
124
125 Requires: python
126 Requires: monitor-server-deps
127
128 # NOTE: removed b/c 'distroname' gets corrupted during build process.
129 # Requires: bootcd-%{pldistro}-%{distroname}-%{_arch} >= 5.0
130
131 %description server
132 The server side include all python modules and scripts needed to fully
133 operation, track, and interact with any third-party monitoring software, such
134 as Zabbix DB.
135
136 ######################################## RunlevelAgent
137 %package runlevelagent
138 summary: the RunlevelAgent that reports node runlevels
139 group: applications/system
140 requires: python
141
142 %description runlevelagent
143 The RunlevelAgent starts as early as possible during boot-up and production
144 mode to actively report the observed runlevel to PLC and update the
145 'last_contact' field.
146
147 %prep
148 %setup -q
149
150 %install
151 rm -rf $RPM_BUILD_ROOT
152 #################### CLIENT 
153 #install -D -m 755 monitor-client.init $RPM_BUILD_ROOT/%{_initrddir}/monitor
154 #install -D -m 644 monitor.cron $RPM_BUILD_ROOT/%{_sysconfdir}/cron.d/monitor
155 install -D -m 755 tools/timeout.pl $RPM_BUILD_ROOT/usr/bin/timeout.pl
156
157
158 #################### SERVER
159 install -d $RPM_BUILD_ROOT/usr/share/%{name}
160 install -d $RPM_BUILD_ROOT/data/var/lib/%{name}
161 install -d $RPM_BUILD_ROOT/data/var/lib/%{name}/archive-pdb
162 install -d $RPM_BUILD_ROOT/var/lib/%{name}
163 install -d $RPM_BUILD_ROOT/var/lib/%{name}/archive-pdb
164 install -d $RPM_BUILD_ROOT/var/www/html/monitorlog/
165 install -d $RPM_BUILD_ROOT/etc/httpd/conf.d/
166 install -d $RPM_BUILD_ROOT/%{python_sitearch}/monitor
167
168 # plc.d scripts
169 install -D -m 644 monitor.functions $RPM_BUILD_ROOT/%{_sysconfdir}/plc.d/monitor.functions
170 install -D -m 755 monitor-server.init $RPM_BUILD_ROOT/%{_sysconfdir}/plc.d/monitor
171 #install -D -m 755 zabbix/monitor-zabbix.init $RPM_BUILD_ROOT/%{_sysconfdir}/plc.d/zabbix
172
173 install -D -m 755 nagios/monitor-nagios.init $RPM_BUILD_ROOT/%{_sysconfdir}/plc.d/monitor-nagios
174 install -D -m 644 nagios/monitor-nagios.cron $RPM_BUILD_ROOT/%{_sysconfdir}/cron.d/monitor-nagios.cron
175
176 # cron job for automated polling
177 install -D -m 644 monitor-server.cron $RPM_BUILD_ROOT/%{_sysconfdir}/cron.d/monitor-server.cron
178
179 # apache configuration
180 install -D -m 644 web/monitorweb.conf $RPM_BUILD_ROOT/etc/httpd/conf.d/
181
182 # we'll install monitor in site-packages install rest to
183 # /usr/share/monitor
184 rsync -a --exclude archive-pdb --exclude .cvsignore --exclude .svn --exclude CVS  \
185     --exclude monitor/ \
186     ./  $RPM_BUILD_ROOT/usr/share/%{name}/
187
188 # install monitor python package
189 rsync -a --exclude .svn  ./monitor/   $RPM_BUILD_ROOT/%{python_sitearch}/monitor/
190
191 install -D -m 644 monitor/wrapper/plc.py $RPM_BUILD_ROOT/usr/share/%{name}/nagios/
192 install -D -m 644 monitor/generic.py $RPM_BUILD_ROOT/usr/share/%{name}/nagios/
193
194 # install third-party module to site-packages
195 install -D -m 755 threadpool.py $RPM_BUILD_ROOT/%{python_sitearch}/threadpool.py
196
197 # TODO: 
198 #touch $RPM_BUILD_ROOT/var/www/cgi-bin/monitor/monitorconfig.php
199 #chmod 777 $RPM_BUILD_ROOT/var/www/cgi-bin/monitor/monitorconfig.php
200
201 #install -D -m 755 monitor-default.conf $RPM_BUILD_ROOT/etc/monitor.conf
202 #cp $RPM_BUILD_ROOT/usr/share/%{name}/monitorconfig-default.py $RPM_BUILD_ROOT/usr/share/%{name}/monitorconfig.py
203
204 #################### RunlevelAgent
205 install -D -m 755 RunlevelAgent.py $RPM_BUILD_ROOT/usr/bin/RunlevelAgent.py
206 install -D -m 755 monitor-runlevelagent.init $RPM_BUILD_ROOT/%{_initrddir}/monitor-runlevelagent
207
208 mkdir -p $RPM_BUILD_ROOT/var/log
209 touch $RPM_BUILD_ROOT/var/log/server-deps.log
210
211
212 %clean
213 rm -rf $RPM_BUILD_ROOT
214
215 %files server-deps
216 /var/log/server-deps.log
217
218 %files nagios
219 %defattr(-,root,root)
220 %{_sysconfdir}/plc.d/monitor-nagios
221 /usr/share/%{name}/nagios 
222 %{_sysconfdir}/cron.d/monitor-nagios.cron
223
224 %files server
225 %defattr(-,root,root)
226 #%config /usr/share/%{name}/monitorconfig.py
227 #%config /etc/monitor.conf
228 /var/lib/%{name}
229 /usr/share/%{name}/MANIFEST.in
230 /usr/share/%{name}/Makefile
231 /usr/share/%{name}/Monitor.spec
232 /usr/share/%{name}/README.txt
233 /usr/share/%{name}/RunlevelAgent.py*
234 /usr/share/%{name}/automate-default.sh
235 /usr/share/%{name}/monitor-default.conf
236 /usr/share/%{name}/monitor-server.cron
237 /usr/share/%{name}/monitor-server.init
238 /usr/share/%{name}/monitor.functions
239 /usr/share/%{name}/setup.py*
240 /usr/share/%{name}/threadpool.py*
241 #/usr/share/%{name}/zabbix.spec
242
243 /usr/share/%{name}/bootcd
244 /usr/share/%{name}/commands
245 /usr/share/%{name}/config.d
246 #/usr/share/%{name}/cron.d
247 /usr/share/%{name}/docs
248 /usr/share/%{name}/keys
249 #/usr/share/%{name}/log
250 /usr/share/%{name}/statistics
251 /usr/share/%{name}/tests
252 /usr/share/%{name}/tools
253 /usr/share/%{name}/upgrade
254 /usr/share/%{name}/web
255 /usr/share/%{name}/zabbix
256
257 #/var/www/cgi-bin/monitor
258 %{_sysconfdir}/cron.d/monitor-server.cron
259 %{_sysconfdir}/plc.d/monitor
260 %{_sysconfdir}/plc.d/monitor.functions
261 #%{_sysconfdir}/plc.d/zabbix
262 %{_sysconfdir}/httpd/conf.d
263 %{python_sitearch}
264
265
266 %files client
267 %defattr(-,root,root)
268 #%{_initrddir}/monitor
269 #%{_sysconfdir}/cron.d/monitor
270 /usr/bin/timeout.pl
271
272 %files runlevelagent
273 /usr/bin/RunlevelAgent.py*
274 /%{_initrddir}/monitor-runlevelagent
275
276
277 %post server-deps
278 #
279 # TODO: depend on distribution packages where feasible.
280 #
281 #  it would be better to be able to depend on the distribution's
282 # packages for these additional python modules, but packages provided
283 # by fedora 8 (our current deployment) doesn't match the version
284 # requirements.
285 export TMPDIR=/var/tmp/
286 #easy_install -UZ http://files.turbogears.org/eggs/TurboGears-1.0.7-py2.5.egg
287 #easy_install -UZ http://pypi.python.org/packages/source/S/SQLAlchemy/SQLAlchemy-0.5.3.tar.gz
288 #easy_install -UZ Elixir
289 chkconfig sendmail on
290 chkconfig crond on
291
292 # crazy openssl libs for racadm binary
293 ln -s /lib/libssl.so.0.9.8b /usr/lib/libssl.so.2
294 mkdir %{_datadir}/%{name}/.ssh
295 chmod 700 %{_datadir}/%{name}/.ssh
296
297 if grep 'pam_loginuid.so' /etc/pam.d/crond ; then
298     sed -i -e 's/^session    required   pam_loginuid.so/#session    required   pam_loginuid.so/g' /etc/pam.d/crond
299 fi
300
301 # NOTE: enable monitor by default, since we're installing it.
302 if ! plc-config --category plc_monitor --variable enabled ; then 
303         plc-config --category plc_monitor --variable enabled --value true \
304                         --save /etc/planetlab/configs/site.xml  /etc/planetlab/configs/site.xml 
305 fi
306 if ! plc-config --category plc_monitor --variable from_email ; then
307         plc-config --category plc_monitor --variable from_email --value monitor@localhost.localdomain \
308                         --save /etc/planetlab/configs/site.xml /etc/planetlab/configs/site.xml 
309 fi
310 if ! plc-config --category plc_monitor --variable cc_email ; then
311         plc-config --category plc_monitor --variable cc_email --value monitor@localhost.localdomain \
312                         --save /etc/planetlab/configs/site.xml /etc/planetlab/configs/site.xml 
313 fi
314 if ! plc-config --category plc_monitor --variable rt_queue ; then
315         plc-config --category plc_monitor --variable rt_queue --value support \
316                         --save /etc/planetlab/configs/site.xml /etc/planetlab/configs/site.xml 
317 fi
318
319 %post nagios
320 # TODO: do as much as possible to get the host setup and running.
321 #chkconfig --add monitor-nagios
322 #chkconfig monitor-nagios on
323 chkconfig mysqld on
324
325 %post server
326 # TODO: this will be nice when we have a web-based service running., such as
327 #               an API server or so on.
328 # TODO: create real monitorconfig.py from monitorconfig-default.py
329 # TODO: create symlink in /var/lib/monitor for chroot environments
330 # TODO: update the content of automate_pl03.sh 
331 # TODO: Use the installed version of bootcd to create custom boot images. ( or, use the api now).
332
333 # NOTE: generate the python defines from zabbix include files.
334 #php /usr/share/%{name}/zabbix/getdefines.php > %{python_sitearch}/monitor/database/zabbixapi/defines.py
335
336 # apply patches to zabbix
337 #patch -d /var/www/html/zabbix/ -p0 < /usr/share/%{name}/zabbix/zabbix-auto-login.diff
338
339 #chkconfig --add monitor-server
340 #chkconfig monitor-server on
341
342 %post client
343 chkconfig --add monitor
344 chkconfig monitor on
345
346 %post runlevelagent
347 if [ -f /etc/planetlab/node_id ] ; then
348     chkconfig --add monitor-runlevelagent
349     chkconfig monitor-runlevelagent on
350     if [ "$PL_BOOTCD" != "1" ] ; then
351         service monitor-runlevelagent restart
352     fi
353 fi
354
355
356 %changelog
357 * Fri May 27 2011 s s <soltesz@cs.princeton.edu> - monitor-3.1-2
358 - Add better requirements list, work with TurboGears packaged by fedora,
359 - Remove some zabbix files
360 - Add a controllers_local.py for custom extensions
361
362 * Fri May 06 2011 s s <soltesz@cs.princeton.edu> - monitor-3.1-1
363 - last tag before some more major changes
364
365 * Thu May 20 2010 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-35
366 - Add CSV link on Advanced query
367 - Preparing to branch
368
369 * Wed May 12 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - Monitor-3.0-34
370 - * copy selections to clipbord on Advanced Query page
371 - * RPM Pattern as regexp
372 - * scan ipmi port
373
374 * Tue Apr 27 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - Monitor-3.0-33
375 - handle hostname changes
376
377 * Tue Apr 20 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - Monitor-3.0-32
378 - from this version, suitable for 5.0
379 - requires bootcd with the new 5.0 naming style 3-part nodefamily
380
381 * Mon Apr 12 2010 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-31
382 - added fix for node delete/add causing conflicts in MyOps db.
383 - added statistics scripts
384
385 * Thu Jan 21 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - Monitor-3.0-30
386 - * fix paths for automate script
387
388 * Tue Dec 22 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - Monitor-3.0-29
389 - - separate pcucontrol as an svn module
390 - - restore easy_instal back into post install stage of server-deps
391 - - template imporovements for web interface
392
393 * Thu Dec 17 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - Monitor-3.0-28
394 - do not need buildrequires. a new tag to fix centos builds
395
396 * Thu Dec 17 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - Monitor-3.0-27
397 - fix rpm build issues
398
399 * Wed Dec 16 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - Monitor-3.0-26
400 - to many changes, but mostly moved stuff around. there are some small fixes here and there.
401
402 * Fri Nov 20 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-25
403 - add option for site status to include both node & pcu status
404 - improve ticket handling
405 - template gadget.xml for a site-specific google-gadget summary
406
407 * Thu Oct 22 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - Monitor-3.0-24
408 - - add install_date
409
410 * Mon Oct 19 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - Monitor-3.0-23
411 - - remove monitor-client.cron
412 - - remove unused monitor-client init script
413 - - fix UP/DOWN summary on nodes page.
414 - - make node page display all nodes by default
415 - - add boot_server field
416 - - add myops_ssh_key to the keychain
417 - - use ext_consortium_id to distinguish pending sites.
418
419 * Fri Oct 09 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - Monitor-3.0-22
420 - show/hide advance query form.
421
422 * Thu Sep 24 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-21
423 - fixed pause_penalty bug.
424 - fixed IPAL pcucontrol bug
425 - fixed bootman tunnel setup bug (occurred in rare cases)
426 - deprecated pcuview
427 - added BootmanSequenceRecords to separate config data from source code
428 - added get/setBootmanSequence(s) to xmlrpc API
429
430 * Fri Sep 04 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-20
431 - Major Features:
432 - added bm log collection and optional integration with BootManager's log Upload()
433 - added iptables_status
434 - expanded advanced query
435 - added differentiated bootmanager_restore actions so that actionsummary displays
436 - counts for each kind of bootmanager action
437 - added pcuerror notices (for mis-configurations) in addition to pcufailed notices
438 - added plain-text options for query page by adding tg_format=plain to URL
439 - fixed cross-module reference that prevented pcucontrol for working with RebootNodeWithPCU() api call.
440 - fixed a bug in determining whether comon's dir was running on a node
441
442 * Mon Aug 17 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-19
443 - Major increment -
444 - adds multiple features and web changes
445 - adds new fields to db
446 - improved layout
447 - general improvements otherwise
448
449 * Sun Jun 28 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-18
450 - bug fixes.
451 - improved templates and views
452 - cleaned controller code for web
453 - added IPMI requirement to pcucontrol package.
454
455 * Thu Jun 18 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-17
456 - added bootmanager log links
457 - addressed root cause of IntegrityErrors ; big deal
458 - adjusted templates to accomodate fix for IntegrityErrors
459 - added session.flush() to bootman.py to write out ActionsRecords
460 - fixed policy to either pause penalties or apply them ; not both.
461
462 -* Wed Jun 17 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-16
463 -- Added Rpyc from 1.0 branch.
464 -- add pcuhistory
465 -- add setup-agent for password protected keys.
466 -- other minor improvements.
467
468 * Wed Jun 17 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-15
469 - automate install
470 - auto-close tickets
471
472 * Fri Jun 12 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-14
473 - update web
474 - update policy
475 - added statistics dir
476
477 * Mon Jun 08 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-13
478 - remove plccache from controllers, all lookups from db.
479 - reformat emailTxt messags
480 - updated bootstates in bootman.py
481
482 * Tue Jun 02 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-12
483 - tag of latest changes.
484 - need to test end to end.
485
486 * Sat May 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - Monitor-3.0-11
487 - big merge from the 2.0 branch
488
489 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - Monitor-3.0-10
490 - minor improvements in rendering with sortable tables
491
492 * Tue May 19 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - Monitor-3.0-9
493
494 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - Monitor-3.0-8
495 - first draft with sortable tables + checkpoint
496
497 * Fri May 15 2009 Baris Metin <tmetin@sophia.inria.fr>
498 - use plekit tables from plewww.
499 - depend on plewww-plekit
500
501 * Tue May 12 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-7
502 - make docs a noop
503 - fix for package name dependency
504 - correct docs
505
506 * Mon May 04 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-6
507 - add improved docs to the latest build and tag.
508
509 * Mon May 04 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-5
510 - add documentation hooks for adding in-line docs like NM and PLCAPI
511
512 * Fri May 01 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-4
513 - Rough pass over monitor-3.0 to allow it to work with 4.3 API.
514 - replaced GetNodeNetworks, nodeinterface_ids and using new bootstates
515 - 'safeboot', 'failboot', 'reinstall', etc.
516
517 * Tue Apr 28 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-3
518 - same as 2.0-12 tag.
519
520 * Mon Apr 27 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-2
521 - merge from 2.0, remove more zabbix code, simplify install, etc.
522
523 * Thu Apr 16 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-1
524 - major merge from 2.0 branch.
525 - ready to be updated with 4.3 and web changes.
526
527 * Fri Feb 27 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-2.0-1
528 - preparing to make a 2.0 branch for monitor.
529
530 * Mon Jan 05 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-2.0-0
531 - new changes are significantly different, that I'm upping the number for clarity.
532
533 * Wed Sep 24 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-8
534 - These are all changes in the latest Monitor code.  I will branch this version
535 - next, before making additional large changes.
536
537 * Mon Sep 01 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - Monitor-1.0-7
538 - Checkpointing current version for 4.2-rc21 - many many changes
539
540 * Mon Aug 11 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-6
541 - This is a major tag of every thing.  probably needs a very different release
542 - number.
543
544 * Fri Jul 18 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-5
545 - Incremental improvements
546
547 * Mon May 19 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-4
548 - tagging everything for OneLab tech-transfer.
549
550
551 * Fri May 09 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-3
552
553
554 * Mon May 05 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-2
555
556
557 * Wed Apr 23 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-1
558 - This should be ready for 4.2rc2
559
560
561 * Mon Apr 07 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - monitor-1.0-0
562 - initial addition.
563
564 %define module_current_branch 3.0