Setting tag Monitor-3.0-21
[monitor.git] / Monitor.spec
1 #
2 # $Id$
3
4
5 %define url $URL: svn+ssh://svn.planet-lab.org/svn/monitor/trunk/monitor.spec $
6
7 %define name monitor
8 %define version 3.0
9 %define taglevel 21
10
11 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
12 %global python_sitearch %( python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)" )
13
14 Name: %{name}
15 Version: %{version}
16 Release: %{release}
17 Source0: %{name}-%{version}.tar.bz2
18 License: GPL
19 Group: Applications/System
20 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
21
22 Vendor: PlanetLab
23 Packager: PlanetLab Central <support@planet-lab.org>
24 Distribution: PlanetLab %{plrelease}
25 URL: %(echo %{url} | cut -d ' ' -f 2)
26
27 Summary: Monitor account initialization for the root image.
28 Group: Applications/System
29
30 %description
31 Monitor is a collection of secondary scripts for configuring the node polling
32 system, syncing the PLC db with the monitoring database, notifying users,
33 interacting with PCU hardware, applying penalties to sites that violate
34 acceptable use.
35
36 ######################################## CLIENT
37
38 %package client
39 Summary: Monitor hooks for a PLC node
40 Group: Applications/System
41 Requires: curl
42 Requires: coreutils
43
44 %description client
45 The client scripts handle account creation inside of a node.  This will
46 include configuration setup for the monitoring agent running on the node.  It
47 will also include any cron or init scripts needed to perform this kind of
48 maintenance.
49 ######################################## Server Deps
50 %package server-deps
51 Summary: Monitor hooks for the PLC server.
52 Group: Applications/System
53
54 Requires: python
55 Requires: python-setuptools-devel
56 Requires: python-peak-util-extremes
57 Requires: TurboGears
58
59 Requires: compat-libstdc++-296
60 Requires: openssh-clients
61 Requires: perl-libwww-perl
62 Requires: perl-IO-Socket-SSL 
63 Requires: MySQL-python
64 Requires: nmap
65 Requires: nc
66 Requires: rt3
67
68 Requires: plewww-plekit
69
70 #Requires: zabbix-client
71 #Requires: zabbix-gui
72 #Requires: zabbix-server
73
74 %description server-deps
75 The server side include all python modules and scripts needed to fully
76
77 ######################################## Server
78 %package server
79 Summary: Monitor hooks for the PLC server.
80 Group: Applications/System
81
82 Requires: python
83
84 Requires: monitor-server-deps
85 Requires: monitor-pcucontrol
86 Requires: PLCWWW >= 4.2
87 Requires: bootcd-%{pldistro}-%{_arch} >= 4.2
88
89 %description server
90 The server side include all python modules and scripts needed to fully
91 operation, track, and interact with any third-party monitoring software, such
92 as Zabbix DB.
93
94 ######################################## PCU Control
95
96 %package pcucontrol
97 summary: pcu controls for monitor and plcapi
98 group: applications/system
99 requires: python
100 requires: OpenIPMI-tools
101
102 %description pcucontrol
103 both monitor and the plcapi use a set of common commands to reboot machines
104 using their external or internal pcus.  this package is a library of several
105 supported models.
106
107 ####################################### RunlevelAgent
108 %package runlevelagent
109 summary: the RunlevelAgent that reports node runlevels
110 group: applications/system
111 requires: python
112
113 %description runlevelagent
114 The RunlevelAgent starts as early as possible during boot-up and production
115 mode to actively report the observed runlevel to PLC and update the
116 'last_contact' field.
117
118 %prep
119 %setup -q
120
121 %build
122 # NOTE: the build uses g++ cmdamt/
123 # NOTE: TMPDIR is needed here b/c the tmpfs of the build vserver is too small.
124 cd pcucontrol/models/intelamt
125 export TMPDIR=$PWD/tmp
126 make
127 cd ..
128
129 %install
130 rm -rf $RPM_BUILD_ROOT
131 #################### CLIENT 
132 install -D -m 755 monitor-client.init $RPM_BUILD_ROOT/%{_initrddir}/monitor
133 install -D -m 644 monitor.cron $RPM_BUILD_ROOT/%{_sysconfdir}/cron.d/monitor
134 install -D -m 755 timeout.pl $RPM_BUILD_ROOT/usr/bin/timeout.pl
135
136
137 #################### SERVER
138 install -d $RPM_BUILD_ROOT/usr/share/%{name}
139 install -d $RPM_BUILD_ROOT/data/var/lib/%{name}
140 install -d $RPM_BUILD_ROOT/data/var/lib/%{name}/archive-pdb
141 install -d $RPM_BUILD_ROOT/var/lib/%{name}
142 install -d $RPM_BUILD_ROOT/var/lib/%{name}/archive-pdb
143 install -d $RPM_BUILD_ROOT/var/www/cgi-bin/monitor/
144 install -d $RPM_BUILD_ROOT/var/www/html/monitorlog/
145
146 install -D -m 644 monitor.functions $RPM_BUILD_ROOT/%{_sysconfdir}/plc.d/monitor.functions
147 install -D -m 755 monitor-server.init $RPM_BUILD_ROOT/%{_sysconfdir}/plc.d/monitor
148 install -D -m 755 zabbix/monitor-zabbix.init $RPM_BUILD_ROOT/%{_sysconfdir}/plc.d/zabbix
149
150 echo " * Installing core scripts"
151 rsync -a --exclude www --exclude archive-pdb --exclude .svn --exclude CVS \
152           ./ $RPM_BUILD_ROOT/usr/share/%{name}/
153
154 echo " * Installing web pages"
155 rsync -a www/ $RPM_BUILD_ROOT/var/www/cgi-bin/monitor/
156 rsync -a log/ $RPM_BUILD_ROOT/var/www/html/monitorlog/
157
158 echo " * Installing cron job for automated polling"
159 install -D -m 644 monitor-server.cron $RPM_BUILD_ROOT/%{_sysconfdir}/cron.d/monitor-server.cron
160 echo " * TODO: Setting up Monitor account in local MyPLC"
161 # TODO: 
162
163 install -d $RPM_BUILD_ROOT/%{python_sitearch}/monitor
164 install -d -D -m 755 monitor $RPM_BUILD_ROOT/%{python_sitearch}/monitor
165 # TODO: need a much better way to do this.
166 rsync -a monitor/ $RPM_BUILD_ROOT/%{python_sitearch}/monitor/
167 #for file in __init__.py database.py config.py ; do 
168 #       install -D -m 644 monitor/$file $RPM_BUILD_ROOT/%{python_sitearch}/monitor/$file
169 #done
170 rsync -a pcucontrol/ $RPM_BUILD_ROOT/%{python_sitearch}/pcucontrol/
171 install -D -m 755 threadpool.py $RPM_BUILD_ROOT/%{python_sitearch}/threadpool.py
172
173 touch $RPM_BUILD_ROOT/var/www/cgi-bin/monitor/monitorconfig.php
174 chmod 777 $RPM_BUILD_ROOT/var/www/cgi-bin/monitor/monitorconfig.php
175
176 #install -D -m 755 monitor-default.conf $RPM_BUILD_ROOT/etc/monitor.conf
177 #cp $RPM_BUILD_ROOT/usr/share/%{name}/monitorconfig-default.py $RPM_BUILD_ROOT/usr/share/%{name}/monitorconfig.py
178
179 #################### RunlevelAgent
180 install -D -m 755 RunlevelAgent.py $RPM_BUILD_ROOT/usr/bin/RunlevelAgent.py
181 install -D -m 755 monitor-runlevelagent.init $RPM_BUILD_ROOT/%{_initrddir}/monitor-runlevelagent
182
183 mkdir -p $RPM_BUILD_ROOT/var/log
184 touch $RPM_BUILD_ROOT/var/log/server-deps.log
185
186
187 %clean
188 rm -rf $RPM_BUILD_ROOT
189
190 %files server-deps
191 /var/log/server-deps.log
192
193 %files server
194 %defattr(-,root,root)
195 #%config /usr/share/%{name}/monitorconfig.py
196 #%config /etc/monitor.conf
197 /usr/share/%{name}
198 /var/lib/%{name}
199 /var/www/cgi-bin/monitor
200 %{_sysconfdir}/cron.d/monitor-server.cron
201 %{python_sitearch}/threadpool.py
202 %{python_sitearch}/threadpool.pyc
203 %{python_sitearch}/threadpool.pyo
204 %{python_sitearch}/monitor
205 %{_sysconfdir}/plc.d/monitor
206 %{_sysconfdir}/plc.d/monitor.functions
207 %{_sysconfdir}/plc.d/zabbix
208
209 %files client
210 %defattr(-,root,root)
211 %{_initrddir}/monitor
212 %{_sysconfdir}/cron.d/monitor
213 /usr/bin/timeout.pl
214
215 %files pcucontrol
216 %{python_sitearch}/pcucontrol
217
218 %files runlevelagent
219 /usr/bin/RunlevelAgent.py
220 /usr/bin/RunlevelAgent.pyo
221 /usr/bin/RunlevelAgent.pyc
222 /%{_initrddir}/monitor-runlevelagent
223
224 %post server-deps
225 #easy_install --build-directory /var/tmp -UZ ElementTree
226 ##easy_install --build-directory /var/tmp -UZ http://pypi.python.org/packages/2.5/E/Extremes/Extremes-1.1-py2.5.egg
227
228
229 ## TODO: something is bad wrong with this approach.
230 easy_install --build-directory /var/tmp -UZ http://files.turbogears.org/eggs/TurboGears-1.0.7-py2.5.egg
231 easy_install --build-directory /var/tmp -UZ http://pypi.python.org/packages/source/S/SQLAlchemy/SQLAlchemy-0.5.3.tar.gz
232 easy_install --build-directory /var/tmp -UZ Elixir
233
234 # crazy openssl libs for racadm binary
235 ln -s /lib/libssl.so.0.9.8b /usr/lib/libssl.so.2
236 mkdir %{_datadir}/%{name}/.ssh
237 chmod 700 %{_datadir}/%{name}/.ssh
238
239 if grep 'pam_loginuid.so' /etc/pam.d/crond ; then
240     sed -i -e 's/^session    required   pam_loginuid.so/#session    required   pam_loginuid.so/g' /etc/pam.d/crond
241 fi
242
243 # NOTE: enable monitor by default, since we're installing it.
244 if ! plc-config --category plc_monitor --variable enabled ; then 
245         plc-config --category plc_monitor --variable enabled --value true \
246                         --save /etc/planetlab/configs/site.xml  /etc/planetlab/configs/site.xml 
247 fi
248 if ! plc-config --category plc_monitor --variable from_email ; then
249         plc-config --category plc_monitor --variable from_email --value monitor@localhost.localdomain \
250                         --save /etc/planetlab/configs/site.xml /etc/planetlab/configs/site.xml 
251 fi
252 if ! plc-config --category plc_monitor --variable cc_email ; then
253         plc-config --category plc_monitor --variable cc_email --value monitor@localhost.localdomain \
254                         --save /etc/planetlab/configs/site.xml /etc/planetlab/configs/site.xml 
255 fi
256 if ! plc-config --category plc_monitor --variable rt_queue ; then
257         plc-config --category plc_monitor --variable rt_queue --value support \
258                         --save /etc/planetlab/configs/site.xml /etc/planetlab/configs/site.xml 
259 fi
260
261 # zabbix:
262 if ! plc-config --category plc_zabbix --variable enabled ; then
263         plc-config --category plc_zabbix --variable enabled --value false \
264                         --save /etc/planetlab/configs/site.xml /etc/planetlab/configs/site.xml 
265 fi
266 if ! plc-config --category plc_zabbix --variable host ; then
267         plc-config --category plc_zabbix --variable host --value localhost.localdomain \
268                         --save /etc/planetlab/configs/site.xml /etc/planetlab/configs/site.xml 
269 fi
270 if ! plc-config --category plc_zabbix --variable ip ; then
271         plc-config --category plc_zabbix --variable ip --value "" \ 
272                         --save /etc/planetlab/configs/site.xml /etc/planetlab/configs/site.xml 
273 fi
274
275 %post server
276 # TODO: this will be nice when we have a web-based service running., such as
277 #               an API server or so on.
278 # TODO: create real monitorconfig.py from monitorconfig-default.py
279 # TODO: create monitorconfig.php using phpconfig.py 
280 # TODO: create symlink in /var/lib/monitor for chroot environments
281 # TODO: update the content of automate_pl03.sh 
282 # TODO: Use the installed version of bootcd to create custom boot images. ( or, use the api now).
283
284 # NOTE: generate the python defines from zabbix include files.
285 #php /usr/share/%{name}/zabbix/getdefines.php > %{python_sitearch}/monitor/database/zabbixapi/defines.py
286
287 # apply patches to zabbix
288 #patch -d /var/www/html/zabbix/ -p0 < /usr/share/%{name}/zabbix/zabbix-auto-login.diff
289
290 #chkconfig --add monitor-server
291 #chkconfig monitor-server on
292
293 %post client
294 chkconfig --add monitor
295 chkconfig monitor on
296
297 %post runlevelagent
298 chkconfig --add monitor-runlevelagent
299 chkconfig monitor-runlevelagent on
300 if [ "$PL_BOOTCD" != "1" ] ; then
301         service monitor-runlevelagent restart
302 fi
303
304
305 %changelog
306 * Thu Sep 24 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-21
307 - fixed pause_penalty bug.
308 - fixed IPAL pcucontrol bug
309 - fixed bootman tunnel setup bug (occurred in rare cases)
310 - deprecated pcuview
311 - added BootmanSequenceRecords to separate config data from source code
312 - added get/setBootmanSequence(s) to xmlrpc API
313
314 * Fri Sep 04 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-20
315 - Major Features:
316 - added bm log collection and optional integration with BootManager's log Upload()
317 - added iptables_status
318 - expanded advanced query
319 - added differentiated bootmanager_restore actions so that actionsummary displays
320 - counts for each kind of bootmanager action
321 - added pcuerror notices (for mis-configurations) in addition to pcufailed notices
322 - added plain-text options for query page by adding tg_format=plain to URL
323 - fixed cross-module reference that prevented pcucontrol for working with RebootNodeWithPCU() api call.
324 - fixed a bug in determining whether comon's dir was running on a node
325
326 * Mon Aug 17 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-19
327 - Major increment -
328 - adds multiple features and web changes
329 - adds new fields to db
330 - improved layout
331 - general improvements otherwise
332
333 * Sun Jun 28 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-18
334 - bug fixes.
335 - improved templates and views
336 - cleaned controller code for web
337 - added IPMI requirement to pcucontrol package.
338
339 * Thu Jun 18 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-17
340 - added bootmanager log links
341 - addressed root cause of IntegrityErrors ; big deal
342 - adjusted templates to accomodate fix for IntegrityErrors
343 - added session.flush() to bootman.py to write out ActionsRecords
344 - fixed policy to either pause penalties or apply them ; not both.
345
346 -* Wed Jun 17 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-16
347 -- Added Rpyc from 1.0 branch.
348 -- add pcuhistory
349 -- add setup-agent for password protected keys.
350 -- other minor improvements.
351
352 * Wed Jun 17 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-15
353 - automate install
354 - auto-close tickets
355
356 * Fri Jun 12 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-14
357 - update web
358 - update policy
359 - added statistics dir
360
361 * Mon Jun 08 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-13
362 - remove plccache from controllers, all lookups from db.
363 - reformat emailTxt messags
364 - updated bootstates in bootman.py
365
366 * Tue Jun 02 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-12
367 - tag of latest changes.
368 - need to test end to end.
369
370 * Sat May 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - Monitor-3.0-11
371 - big merge from the 2.0 branch
372
373 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - Monitor-3.0-10
374 - minor improvements in rendering with sortable tables
375
376 * Tue May 19 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - Monitor-3.0-9
377
378 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - Monitor-3.0-8
379 - first draft with sortable tables + checkpoint
380
381 * Fri May 15 2009 Baris Metin <tmetin@sophia.inria.fr>
382 - use plekit tables from plewww.
383 - depend on plewww-plekit
384
385 * Tue May 12 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-7
386 - make docs a noop
387 - fix for package name dependency
388 - correct docs
389
390 * Mon May 04 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-6
391 - add improved docs to the latest build and tag.
392
393 * Mon May 04 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-5
394 - add documentation hooks for adding in-line docs like NM and PLCAPI
395
396 * Fri May 01 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-4
397 - Rough pass over monitor-3.0 to allow it to work with 4.3 API.
398 - replaced GetNodeNetworks, nodeinterface_ids and using new bootstates
399 - 'safeboot', 'failboot', 'reinstall', etc.
400
401 * Tue Apr 28 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-3
402 - same as 2.0-12 tag.
403
404 * Mon Apr 27 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-2
405 - merge from 2.0, remove more zabbix code, simplify install, etc.
406
407 * Thu Apr 16 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-1
408 - major merge from 2.0 branch.
409 - ready to be updated with 4.3 and web changes.
410
411 * Fri Feb 27 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-2.0-1
412 - preparing to make a 2.0 branch for monitor.
413
414 * Mon Jan 05 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-2.0-0
415 - new changes are significantly different, that I'm upping the number for clarity.
416
417 * Wed Sep 24 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-8
418 - These are all changes in the latest Monitor code.  I will branch this version
419 - next, before making additional large changes.
420
421 * Mon Sep 01 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - Monitor-1.0-7
422 - Checkpointing current version for 4.2-rc21 - many many changes
423
424 * Mon Aug 11 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-6
425 - This is a major tag of every thing.  probably needs a very different release
426 - number.
427
428 * Fri Jul 18 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-5
429 - Incremental improvements
430
431 * Mon May 19 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-4
432 - tagging everything for OneLab tech-transfer.
433
434
435 * Fri May 09 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-3
436
437
438 * Mon May 05 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-2
439
440
441 * Wed Apr 23 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-1
442 - This should be ready for 4.2rc2
443
444
445 * Mon Apr 07 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - monitor-1.0-0
446 - initial addition.
447
448 %define module_current_branch 2.0