Merge branch 'master' of git://git.planet-lab.org/monitor
[monitor.git] / Monitor.spec
1 #
2 # $Id$
3
4
5 %define url $URL: svn+ssh://svn.planet-lab.org/svn/monitor/trunk/monitor.spec $
6
7 %define name monitor
8 # keep this version in sync with monitor/monitor_version.py
9 %define version 3.1
10 %define taglevel 1
11
12 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
13 %global python_sitearch %( python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)" )
14
15 Name: %{name}
16 Version: %{version}
17 Release: %{release}
18 Source0: %{name}-%{version}.tar.bz2
19 License: GPL
20 Group: Applications/System
21 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
22
23 Vendor: PlanetLab
24 Packager: PlanetLab Central <support@planet-lab.org>
25 Distribution: PlanetLab %{plrelease}
26 URL: %(echo %{url} | cut -d ' ' -f 2)
27
28
29 Summary: Monitor account initialization for the root image.
30 Group: Applications/System
31
32 %description
33 Monitor is a collection of secondary scripts for configuring the node polling
34 system, syncing the PLC db with the monitoring database, notifying users,
35 interacting with PCU hardware, applying penalties to sites that violate
36 acceptable use.
37
38 ######################################## NAGIOS
39
40 %package nagios
41 Summary: Monitor integration with Nagios
42 Group: Applications/System
43
44 Requires: coreutils
45 Requires: passwd
46 Requires: gd
47 Requires: gd-devel
48 Requires: mysql
49 Requires: mysql-server
50 Requires: mysql-devel
51 Requires: mysql-libs
52 Requires: mailx
53 Requires: sendmail
54 Requires: php
55 Requires: httpd
56
57 Requires: cronie
58 Requires: nagios
59 Requires: nagios-common
60 Requires: nagios-devel
61 Requires: nagios-plugins-all
62 Requires: ndoutils
63 Requires: ndoutils-mysql
64
65 Requires: rt3
66
67
68 %description nagios
69 Scripts and setup necessary to integrate and monitor PLC with Nagios.
70 Best suited to F12 or above.
71
72 ######################################## CLIENT
73
74 %package client
75 Summary: Monitor hooks for a PLC node
76 Group: Applications/System
77 Requires: curl
78 Requires: coreutils
79
80 %description client
81 The client scripts handle account creation inside of a node.  This will
82 include configuration setup for the monitoring agent running on the node.  It
83 will also include any cron or init scripts needed to perform this kind of
84 maintenance.
85 ######################################## Server Deps
86 %package server-deps
87 Summary: Monitor hooks for the PLC server.
88 Group: Applications/System
89
90 Requires: python
91 Requires: python-setuptools-devel
92 Requires: python-peak-util-extremes
93
94 Requires: compat-libstdc++-296
95 Requires: openssh-clients
96 Requires: perl-libwww-perl
97 Requires: perl-IO-Socket-SSL 
98 Requires: MySQL-python
99 Requires: nmap
100 Requires: nc
101 Requires: rt3
102 Requires: traceroute
103
104 Requires: plewww-plekit
105 Requires: pcucontrol
106 Requires: TurboGears
107
108 #Requires: zabbix-client
109 #Requires: zabbix-gui
110 #Requires: zabbix-server
111
112 %description server-deps
113 The server side include all python modules and scripts needed to fully
114
115 ######################################## Server
116 %package server
117 Summary: Monitor hooks for the PLC server.
118 Group: Applications/System
119
120 Requires: python
121
122 Requires: monitor-server-deps
123 Requires: PLCWWW >= 4.2
124 # NOTE: removed b/c 'distroname' gets corrupted during build process.
125 # Requires: bootcd-%{pldistro}-%{distroname}-%{_arch} >= 5.0
126
127 %description server
128 The server side include all python modules and scripts needed to fully
129 operation, track, and interact with any third-party monitoring software, such
130 as Zabbix DB.
131
132 ####################################### RunlevelAgent
133 %package runlevelagent
134 summary: the RunlevelAgent that reports node runlevels
135 group: applications/system
136 requires: python
137
138 %description runlevelagent
139 The RunlevelAgent starts as early as possible during boot-up and production
140 mode to actively report the observed runlevel to PLC and update the
141 'last_contact' field.
142
143 %prep
144 %setup -q
145
146 %install
147 rm -rf $RPM_BUILD_ROOT
148 #################### CLIENT 
149 #install -D -m 755 monitor-client.init $RPM_BUILD_ROOT/%{_initrddir}/monitor
150 #install -D -m 644 monitor.cron $RPM_BUILD_ROOT/%{_sysconfdir}/cron.d/monitor
151 install -D -m 755 tools/timeout.pl $RPM_BUILD_ROOT/usr/bin/timeout.pl
152
153
154 #################### SERVER
155 install -d $RPM_BUILD_ROOT/usr/share/%{name}
156 install -d $RPM_BUILD_ROOT/data/var/lib/%{name}
157 install -d $RPM_BUILD_ROOT/data/var/lib/%{name}/archive-pdb
158 install -d $RPM_BUILD_ROOT/var/lib/%{name}
159 install -d $RPM_BUILD_ROOT/var/lib/%{name}/archive-pdb
160 install -d $RPM_BUILD_ROOT/var/www/html/monitorlog/
161 install -d $RPM_BUILD_ROOT/etc/httpd/conf.d/
162 install -d $RPM_BUILD_ROOT/%{python_sitearch}/monitor
163
164 # plc.d scripts
165 install -D -m 644 monitor.functions $RPM_BUILD_ROOT/%{_sysconfdir}/plc.d/monitor.functions
166 install -D -m 755 monitor-server.init $RPM_BUILD_ROOT/%{_sysconfdir}/plc.d/monitor
167 install -D -m 755 zabbix/monitor-zabbix.init $RPM_BUILD_ROOT/%{_sysconfdir}/plc.d/zabbix
168
169 install -D -m 755 nagios/monitor-nagios.init $RPM_BUILD_ROOT/%{_sysconfdir}/plc.d/monitor-nagios
170 install -D -m 644 nagios/monitor-nagios.cron $RPM_BUILD_ROOT/%{_sysconfdir}/cron.d/monitor-nagios.cron
171
172 # cron job for automated polling
173 install -D -m 644 monitor-server.cron $RPM_BUILD_ROOT/%{_sysconfdir}/cron.d/monitor-server.cron
174
175 # apache configuration
176 install -D -m 644 web/monitorweb-httpd.conf $RPM_BUILD_ROOT/etc/httpd/conf.d/
177
178 # we'll install monitor in site-packages install rest to
179 # /usr/share/monitor
180 rsync -a --exclude archive-pdb --exclude .cvsignore --exclude .svn --exclude CVS  \
181     --exclude monitor/ \
182     ./  $RPM_BUILD_ROOT/usr/share/%{name}/
183
184 # install monitor python package
185 rsync -a --exclude .svn  ./monitor/   $RPM_BUILD_ROOT/%{python_sitearch}/monitor/
186
187 install -D -m 644 monitor/wrapper/plc.py $RPM_BUILD_ROOT/usr/share/%{name}/nagios/
188 install -D -m 644 monitor/generic.py $RPM_BUILD_ROOT/usr/share/%{name}/nagios/
189
190 # install third-party module to site-packages
191 install -D -m 755 threadpool.py $RPM_BUILD_ROOT/%{python_sitearch}/threadpool.py
192
193 # TODO: 
194 #touch $RPM_BUILD_ROOT/var/www/cgi-bin/monitor/monitorconfig.php
195 #chmod 777 $RPM_BUILD_ROOT/var/www/cgi-bin/monitor/monitorconfig.php
196
197 #install -D -m 755 monitor-default.conf $RPM_BUILD_ROOT/etc/monitor.conf
198 #cp $RPM_BUILD_ROOT/usr/share/%{name}/monitorconfig-default.py $RPM_BUILD_ROOT/usr/share/%{name}/monitorconfig.py
199
200 #################### RunlevelAgent
201 install -D -m 755 RunlevelAgent.py $RPM_BUILD_ROOT/usr/bin/RunlevelAgent.py
202 install -D -m 755 monitor-runlevelagent.init $RPM_BUILD_ROOT/%{_initrddir}/monitor-runlevelagent
203
204 mkdir -p $RPM_BUILD_ROOT/var/log
205 touch $RPM_BUILD_ROOT/var/log/server-deps.log
206
207
208 %clean
209 rm -rf $RPM_BUILD_ROOT
210
211 %files server-deps
212 /var/log/server-deps.log
213
214 %files nagios
215 %defattr(-,root,root)
216 %{_sysconfdir}/plc.d/monitor-nagios
217 /usr/share/%{name}/nagios 
218 %{_sysconfdir}/cron.d/monitor-nagios.cron
219
220 %files server
221 %defattr(-,root,root)
222 #%config /usr/share/%{name}/monitorconfig.py
223 #%config /etc/monitor.conf
224 /var/lib/%{name}
225 /usr/share/%{name}/MANIFEST.in
226 /usr/share/%{name}/Makefile
227 /usr/share/%{name}/Monitor.spec
228 /usr/share/%{name}/README.txt
229 /usr/share/%{name}/RunlevelAgent.py*
230 /usr/share/%{name}/automate-default.sh
231 /usr/share/%{name}/monitor-default.conf
232 /usr/share/%{name}/monitor-runlevelagent.init
233 /usr/share/%{name}/monitor-server.cron
234 /usr/share/%{name}/monitor-server.init
235 /usr/share/%{name}/monitor.functions
236 /usr/share/%{name}/setup.py*
237 /usr/share/%{name}/threadpool.py*
238 /usr/share/%{name}/zabbix.spec
239
240 /usr/share/%{name}/bootcd
241 /usr/share/%{name}/commands
242 /usr/share/%{name}/config.d
243 /usr/share/%{name}/cron.d
244 /usr/share/%{name}/docs
245 /usr/share/%{name}/keys
246 /usr/share/%{name}/log
247 /usr/share/%{name}/statistics
248 /usr/share/%{name}/tests
249 /usr/share/%{name}/tools
250 /usr/share/%{name}/upgrade
251 /usr/share/%{name}/web
252 /usr/share/%{name}/zabbix
253
254 #/var/www/cgi-bin/monitor
255 %{_sysconfdir}/cron.d/monitor-server.cron
256 %{_sysconfdir}/plc.d/monitor
257 %{_sysconfdir}/plc.d/monitor.functions
258 %{_sysconfdir}/plc.d/zabbix
259 %{_sysconfdir}/httpd/conf.d
260 %{python_sitearch}
261
262
263 %files client
264 %defattr(-,root,root)
265 #%{_initrddir}/monitor
266 #%{_sysconfdir}/cron.d/monitor
267 /usr/bin/timeout.pl
268
269 %files runlevelagent
270 /usr/bin/RunlevelAgent.py*
271 /%{_initrddir}/monitor-runlevelagent
272
273
274 %post server-deps
275 #
276 # TODO: depend on distribution packages where feasible.
277 #
278 #  it would be better to be able to depend on the distribution's
279 # packages for these additional python modules, but packages provided
280 # by fedora 8 (our current deployment) doesn't match the version
281 # requirements.
282 export TMPDIR=/var/tmp/
283 #easy_install -UZ http://files.turbogears.org/eggs/TurboGears-1.0.7-py2.5.egg
284 #easy_install -UZ http://pypi.python.org/packages/source/S/SQLAlchemy/SQLAlchemy-0.5.3.tar.gz
285 #easy_install -UZ Elixir
286
287 # crazy openssl libs for racadm binary
288 ln -s /lib/libssl.so.0.9.8b /usr/lib/libssl.so.2
289 mkdir %{_datadir}/%{name}/.ssh
290 chmod 700 %{_datadir}/%{name}/.ssh
291
292 if grep 'pam_loginuid.so' /etc/pam.d/crond ; then
293     sed -i -e 's/^session    required   pam_loginuid.so/#session    required   pam_loginuid.so/g' /etc/pam.d/crond
294 fi
295
296 # NOTE: enable monitor by default, since we're installing it.
297 if ! plc-config --category plc_monitor --variable enabled ; then 
298         plc-config --category plc_monitor --variable enabled --value true \
299                         --save /etc/planetlab/configs/site.xml  /etc/planetlab/configs/site.xml 
300 fi
301 if ! plc-config --category plc_monitor --variable from_email ; then
302         plc-config --category plc_monitor --variable from_email --value monitor@localhost.localdomain \
303                         --save /etc/planetlab/configs/site.xml /etc/planetlab/configs/site.xml 
304 fi
305 if ! plc-config --category plc_monitor --variable cc_email ; then
306         plc-config --category plc_monitor --variable cc_email --value monitor@localhost.localdomain \
307                         --save /etc/planetlab/configs/site.xml /etc/planetlab/configs/site.xml 
308 fi
309 if ! plc-config --category plc_monitor --variable rt_queue ; then
310         plc-config --category plc_monitor --variable rt_queue --value support \
311                         --save /etc/planetlab/configs/site.xml /etc/planetlab/configs/site.xml 
312 fi
313
314 %post nagios
315 # TODO: do as much as possible to get the host setup and running.
316 #chkconfig --add monitor-nagios
317 #chkconfig monitor-nagios on
318 chkconfig mysqld on
319
320 %post server
321 # TODO: this will be nice when we have a web-based service running., such as
322 #               an API server or so on.
323 # TODO: create real monitorconfig.py from monitorconfig-default.py
324 # TODO: create symlink in /var/lib/monitor for chroot environments
325 # TODO: update the content of automate_pl03.sh 
326 # TODO: Use the installed version of bootcd to create custom boot images. ( or, use the api now).
327
328 # NOTE: generate the python defines from zabbix include files.
329 #php /usr/share/%{name}/zabbix/getdefines.php > %{python_sitearch}/monitor/database/zabbixapi/defines.py
330
331 # apply patches to zabbix
332 #patch -d /var/www/html/zabbix/ -p0 < /usr/share/%{name}/zabbix/zabbix-auto-login.diff
333
334 #chkconfig --add monitor-server
335 #chkconfig monitor-server on
336
337 %post client
338 chkconfig --add monitor
339 chkconfig monitor on
340
341 %post runlevelagent
342 if [ -f /etc/planetlab/node_id ] ; then
343     chkconfig --add monitor-runlevelagent
344     chkconfig monitor-runlevelagent on
345     if [ "$PL_BOOTCD" != "1" ] ; then
346         service monitor-runlevelagent restart
347     fi
348 fi
349
350
351 %changelog
352 * Fri May 06 2011 s s <soltesz@cs.princeton.edu> - monitor-3.1-1
353 - last tag before some more major changes
354
355 * Thu May 20 2010 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-35
356 - Add CSV link on Advanced query
357 - Preparing to branch
358
359 * Wed May 12 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - Monitor-3.0-34
360 - * copy selections to clipbord on Advanced Query page
361 - * RPM Pattern as regexp
362 - * scan ipmi port
363
364 * Tue Apr 27 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - Monitor-3.0-33
365 - handle hostname changes
366
367 * Tue Apr 20 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - Monitor-3.0-32
368 - from this version, suitable for 5.0
369 - requires bootcd with the new 5.0 naming style 3-part nodefamily
370
371 * Mon Apr 12 2010 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-31
372 - added fix for node delete/add causing conflicts in MyOps db.
373 - added statistics scripts
374
375 * Thu Jan 21 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - Monitor-3.0-30
376 - * fix paths for automate script
377
378 * Tue Dec 22 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - Monitor-3.0-29
379 - - separate pcucontrol as an svn module
380 - - restore easy_instal back into post install stage of server-deps
381 - - template imporovements for web interface
382
383 * Thu Dec 17 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - Monitor-3.0-28
384 - do not need buildrequires. a new tag to fix centos builds
385
386 * Thu Dec 17 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - Monitor-3.0-27
387 - fix rpm build issues
388
389 * Wed Dec 16 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - Monitor-3.0-26
390 - to many changes, but mostly moved stuff around. there are some small fixes here and there.
391
392 * Fri Nov 20 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-25
393 - add option for site status to include both node & pcu status
394 - improve ticket handling
395 - template gadget.xml for a site-specific google-gadget summary
396
397 * Thu Oct 22 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - Monitor-3.0-24
398 - - add install_date
399
400 * Mon Oct 19 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - Monitor-3.0-23
401 - - remove monitor-client.cron
402 - - remove unused monitor-client init script
403 - - fix UP/DOWN summary on nodes page.
404 - - make node page display all nodes by default
405 - - add boot_server field
406 - - add myops_ssh_key to the keychain
407 - - use ext_consortium_id to distinguish pending sites.
408
409 * Fri Oct 09 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - Monitor-3.0-22
410 - show/hide advance query form.
411
412 * Thu Sep 24 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-21
413 - fixed pause_penalty bug.
414 - fixed IPAL pcucontrol bug
415 - fixed bootman tunnel setup bug (occurred in rare cases)
416 - deprecated pcuview
417 - added BootmanSequenceRecords to separate config data from source code
418 - added get/setBootmanSequence(s) to xmlrpc API
419
420 * Fri Sep 04 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-20
421 - Major Features:
422 - added bm log collection and optional integration with BootManager's log Upload()
423 - added iptables_status
424 - expanded advanced query
425 - added differentiated bootmanager_restore actions so that actionsummary displays
426 - counts for each kind of bootmanager action
427 - added pcuerror notices (for mis-configurations) in addition to pcufailed notices
428 - added plain-text options for query page by adding tg_format=plain to URL
429 - fixed cross-module reference that prevented pcucontrol for working with RebootNodeWithPCU() api call.
430 - fixed a bug in determining whether comon's dir was running on a node
431
432 * Mon Aug 17 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-19
433 - Major increment -
434 - adds multiple features and web changes
435 - adds new fields to db
436 - improved layout
437 - general improvements otherwise
438
439 * Sun Jun 28 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-18
440 - bug fixes.
441 - improved templates and views
442 - cleaned controller code for web
443 - added IPMI requirement to pcucontrol package.
444
445 * Thu Jun 18 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-17
446 - added bootmanager log links
447 - addressed root cause of IntegrityErrors ; big deal
448 - adjusted templates to accomodate fix for IntegrityErrors
449 - added session.flush() to bootman.py to write out ActionsRecords
450 - fixed policy to either pause penalties or apply them ; not both.
451
452 -* Wed Jun 17 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-16
453 -- Added Rpyc from 1.0 branch.
454 -- add pcuhistory
455 -- add setup-agent for password protected keys.
456 -- other minor improvements.
457
458 * Wed Jun 17 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-15
459 - automate install
460 - auto-close tickets
461
462 * Fri Jun 12 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-14
463 - update web
464 - update policy
465 - added statistics dir
466
467 * Mon Jun 08 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-13
468 - remove plccache from controllers, all lookups from db.
469 - reformat emailTxt messags
470 - updated bootstates in bootman.py
471
472 * Tue Jun 02 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-12
473 - tag of latest changes.
474 - need to test end to end.
475
476 * Sat May 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - Monitor-3.0-11
477 - big merge from the 2.0 branch
478
479 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - Monitor-3.0-10
480 - minor improvements in rendering with sortable tables
481
482 * Tue May 19 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - Monitor-3.0-9
483
484 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - Monitor-3.0-8
485 - first draft with sortable tables + checkpoint
486
487 * Fri May 15 2009 Baris Metin <tmetin@sophia.inria.fr>
488 - use plekit tables from plewww.
489 - depend on plewww-plekit
490
491 * Tue May 12 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-7
492 - make docs a noop
493 - fix for package name dependency
494 - correct docs
495
496 * Mon May 04 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-6
497 - add improved docs to the latest build and tag.
498
499 * Mon May 04 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-5
500 - add documentation hooks for adding in-line docs like NM and PLCAPI
501
502 * Fri May 01 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-4
503 - Rough pass over monitor-3.0 to allow it to work with 4.3 API.
504 - replaced GetNodeNetworks, nodeinterface_ids and using new bootstates
505 - 'safeboot', 'failboot', 'reinstall', etc.
506
507 * Tue Apr 28 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-3
508 - same as 2.0-12 tag.
509
510 * Mon Apr 27 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-2
511 - merge from 2.0, remove more zabbix code, simplify install, etc.
512
513 * Thu Apr 16 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-1
514 - major merge from 2.0 branch.
515 - ready to be updated with 4.3 and web changes.
516
517 * Fri Feb 27 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-2.0-1
518 - preparing to make a 2.0 branch for monitor.
519
520 * Mon Jan 05 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-2.0-0
521 - new changes are significantly different, that I'm upping the number for clarity.
522
523 * Wed Sep 24 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-8
524 - These are all changes in the latest Monitor code.  I will branch this version
525 - next, before making additional large changes.
526
527 * Mon Sep 01 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - Monitor-1.0-7
528 - Checkpointing current version for 4.2-rc21 - many many changes
529
530 * Mon Aug 11 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-6
531 - This is a major tag of every thing.  probably needs a very different release
532 - number.
533
534 * Fri Jul 18 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-5
535 - Incremental improvements
536
537 * Mon May 19 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-4
538 - tagging everything for OneLab tech-transfer.
539
540
541 * Fri May 09 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-3
542
543
544 * Mon May 05 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-2
545
546
547 * Wed Apr 23 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-1
548 - This should be ready for 4.2rc2
549
550
551 * Mon Apr 07 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - monitor-1.0-0
552 - initial addition.
553
554 %define module_current_branch 3.0