comment out buildrequires
[monitor.git] / Monitor.spec
1 #
2 # $Id$
3
4
5 %define url $URL: svn+ssh://svn.planet-lab.org/svn/monitor/trunk/monitor.spec $
6
7 %define name monitor
8 # keep this version in sync with monitor/monitor_version.py
9 %define version 3.0
10 %define taglevel 27
11
12 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
13 %global python_sitearch %( python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)" )
14
15 Name: %{name}
16 Version: %{version}
17 Release: %{release}
18 Source0: %{name}-%{version}.tar.bz2
19 License: GPL
20 Group: Applications/System
21 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
22
23 Vendor: PlanetLab
24 Packager: PlanetLab Central <support@planet-lab.org>
25 Distribution: PlanetLab %{plrelease}
26 URL: %(echo %{url} | cut -d ' ' -f 2)
27
28 # this is only required for fedora and we have this in devel.pkgs for
29 # all fedora builds.
30 # BuildRequires: python-setuptools-devel
31
32
33 Summary: Monitor account initialization for the root image.
34 Group: Applications/System
35
36 %description
37 Monitor is a collection of secondary scripts for configuring the node polling
38 system, syncing the PLC db with the monitoring database, notifying users,
39 interacting with PCU hardware, applying penalties to sites that violate
40 acceptable use.
41
42 ######################################## CLIENT
43
44 %package client
45 Summary: Monitor hooks for a PLC node
46 Group: Applications/System
47 Requires: curl
48 Requires: coreutils
49
50 %description client
51 The client scripts handle account creation inside of a node.  This will
52 include configuration setup for the monitoring agent running on the node.  It
53 will also include any cron or init scripts needed to perform this kind of
54 maintenance.
55 ######################################## Server Deps
56 %package server-deps
57 Summary: Monitor hooks for the PLC server.
58 Group: Applications/System
59
60 Requires: python
61 Requires: python-peak-util-extremes
62
63 Requires: compat-libstdc++-296
64 Requires: openssh-clients
65 Requires: perl-libwww-perl
66 Requires: perl-IO-Socket-SSL 
67 Requires: MySQL-python
68 Requires: nmap
69 Requires: nc
70 Requires: rt3
71
72 Requires: plewww-plekit
73
74 #Requires: zabbix-client
75 #Requires: zabbix-gui
76 #Requires: zabbix-server
77
78 %description server-deps
79 The server side include all python modules and scripts needed to fully
80
81 ######################################## Server
82 %package server
83 Summary: Monitor hooks for the PLC server.
84 Group: Applications/System
85
86 Requires: python
87
88 Requires: monitor-server-deps
89 Requires: monitor-pcucontrol
90 Requires: PLCWWW >= 4.2
91 Requires: bootcd-%{pldistro}-%{_arch} >= 4.2
92
93 %description server
94 The server side include all python modules and scripts needed to fully
95 operation, track, and interact with any third-party monitoring software, such
96 as Zabbix DB.
97
98 ######################################## PCU Control
99
100 %package pcucontrol
101 summary: pcu controls for monitor and plcapi
102 group: applications/system
103 requires: python
104 requires: OpenIPMI-tools
105
106 %description pcucontrol
107 both monitor and the plcapi use a set of common commands to reboot machines
108 using their external or internal pcus.  this package is a library of several
109 supported models.
110
111 ####################################### RunlevelAgent
112 %package runlevelagent
113 summary: the RunlevelAgent that reports node runlevels
114 group: applications/system
115 requires: python
116
117 %description runlevelagent
118 The RunlevelAgent starts as early as possible during boot-up and production
119 mode to actively report the observed runlevel to PLC and update the
120 'last_contact' field.
121
122 %prep
123 %setup -q
124
125 %build
126 # NOTE: the build uses g++ cmdamt/
127 # NOTE: TMPDIR is needed here b/c the tmpfs of the build vserver is too small.
128 cd pcucontrol/models/intelamt
129 export TMPDIR=$PWD/tmp
130 make
131 cd ..
132
133 %install
134 rm -rf $RPM_BUILD_ROOT
135 #################### CLIENT 
136 #install -D -m 755 monitor-client.init $RPM_BUILD_ROOT/%{_initrddir}/monitor
137 #install -D -m 644 monitor.cron $RPM_BUILD_ROOT/%{_sysconfdir}/cron.d/monitor
138 install -D -m 755 tools/timeout.pl $RPM_BUILD_ROOT/usr/bin/timeout.pl
139
140
141 #################### SERVER
142 install -d $RPM_BUILD_ROOT/usr/share/%{name}
143 install -d $RPM_BUILD_ROOT/data/var/lib/%{name}
144 install -d $RPM_BUILD_ROOT/data/var/lib/%{name}/archive-pdb
145 install -d $RPM_BUILD_ROOT/var/lib/%{name}
146 install -d $RPM_BUILD_ROOT/var/lib/%{name}/archive-pdb
147 install -d $RPM_BUILD_ROOT/var/www/html/monitorlog/
148 install -d $RPM_BUILD_ROOT/etc/httpd/conf.d/
149 install -d $RPM_BUILD_ROOT/%{python_sitearch}/monitor
150
151 # pack monitor's dependencies in RPM to make it easier to deploy.
152 export TMPDIR=/var/tmp/
153 export PYTHONPATH=$PYTHONPATH:$RPM_BUILD_ROOT/%{python_sitearch}/
154 easy_install -d $RPM_BUILD_ROOT/%{python_sitearch}/ -UZ http://files.turbogears.org/eggs/TurboGears-1.0.7-py2.5.egg
155 easy_install -d $RPM_BUILD_ROOT/%{python_sitearch}/ -UZ http://pypi.python.org/packages/source/S/SQLAlchemy/SQLAlchemy-0.5.3.tar.gz
156 easy_install -d $RPM_BUILD_ROOT/%{python_sitearch}/ -UZ Elixir
157 rm -rf $RPM_BUILD_ROOT/%{python_sitearch}/site.py*
158
159 # plc.d scripts
160 install -D -m 644 monitor.functions $RPM_BUILD_ROOT/%{_sysconfdir}/plc.d/monitor.functions
161 install -D -m 755 monitor-server.init $RPM_BUILD_ROOT/%{_sysconfdir}/plc.d/monitor
162 install -D -m 755 zabbix/monitor-zabbix.init $RPM_BUILD_ROOT/%{_sysconfdir}/plc.d/zabbix
163
164 # cron job for automated polling
165 install -D -m 644 monitor-server.cron $RPM_BUILD_ROOT/%{_sysconfdir}/cron.d/monitor-server.cron
166
167 # apache configuration
168 install -D -m 644 web/monitorweb-httpd.conf $RPM_BUILD_ROOT/etc/httpd/conf.d/
169
170 # we'll install monitor and pcucontrol in site-packages
171 # install rest to /usr/share/monitor
172 rsync -a --exclude archive-pdb --exclude .svn --exclude CVS  \
173     --exclude monitor/ \
174     --exclude pcucontol/ \
175     ./  $RPM_BUILD_ROOT/usr/share/%{name}/
176
177 # install monitor python package
178 rsync -a --exclude .svn  ./monitor/   $RPM_BUILD_ROOT/%{python_sitearch}/monitor/
179
180 # and pcucontrol
181 rsync -a --exclude .svn  ./pcucontrol/    $RPM_BUILD_ROOT/%{python_sitearch}/pcucontrol/
182
183 # install third-party module to site-packages
184 install -D -m 755 threadpool.py $RPM_BUILD_ROOT/%{python_sitearch}/threadpool.py
185
186 # TODO: 
187 echo " * TODO: Setting up Monitor account in local MyPLC"
188
189 #touch $RPM_BUILD_ROOT/var/www/cgi-bin/monitor/monitorconfig.php
190 #chmod 777 $RPM_BUILD_ROOT/var/www/cgi-bin/monitor/monitorconfig.php
191
192 #install -D -m 755 monitor-default.conf $RPM_BUILD_ROOT/etc/monitor.conf
193 #cp $RPM_BUILD_ROOT/usr/share/%{name}/monitorconfig-default.py $RPM_BUILD_ROOT/usr/share/%{name}/monitorconfig.py
194
195 #################### RunlevelAgent
196 install -D -m 755 RunlevelAgent.py $RPM_BUILD_ROOT/usr/bin/RunlevelAgent.py
197 install -D -m 755 monitor-runlevelagent.init $RPM_BUILD_ROOT/%{_initrddir}/monitor-runlevelagent
198
199 mkdir -p $RPM_BUILD_ROOT/var/log
200 touch $RPM_BUILD_ROOT/var/log/server-deps.log
201
202
203 %clean
204 rm -rf $RPM_BUILD_ROOT
205
206 %files server-deps
207 /var/log/server-deps.log
208
209 %files server
210 %defattr(-,root,root)
211 #%config /usr/share/%{name}/monitorconfig.py
212 #%config /etc/monitor.conf
213 /usr/share/%{name}
214 /var/lib/%{name}
215 #/var/www/cgi-bin/monitor
216 %{_sysconfdir}/cron.d/monitor-server.cron
217 %{python_sitearch}/threadpool.py*
218 %{python_sitearch}/monitor
219 %{python_sitearch}/*.egg/
220 %{python_sitearch}/easy-install.pth
221 %{python_sitearch}/tg-admin
222 %{_sysconfdir}/plc.d/monitor
223 %{_sysconfdir}/plc.d/monitor.functions
224 %{_sysconfdir}/plc.d/zabbix
225 %{_sysconfdir}/httpd/conf.d
226
227 %files client
228 %defattr(-,root,root)
229 #%{_initrddir}/monitor
230 #%{_sysconfdir}/cron.d/monitor
231 /usr/bin/timeout.pl
232
233 %files pcucontrol
234 %{python_sitearch}/pcucontrol
235
236 %files runlevelagent
237 /usr/bin/RunlevelAgent.py
238 /usr/bin/RunlevelAgent.pyo
239 /usr/bin/RunlevelAgent.pyc
240 /%{_initrddir}/monitor-runlevelagent
241
242 %post server-deps
243
244 # crazy openssl libs for racadm binary
245 ln -s /lib/libssl.so.0.9.8b /usr/lib/libssl.so.2
246 mkdir %{_datadir}/%{name}/.ssh
247 chmod 700 %{_datadir}/%{name}/.ssh
248
249 if grep 'pam_loginuid.so' /etc/pam.d/crond ; then
250     sed -i -e 's/^session    required   pam_loginuid.so/#session    required   pam_loginuid.so/g' /etc/pam.d/crond
251 fi
252
253 # NOTE: enable monitor by default, since we're installing it.
254 if ! plc-config --category plc_monitor --variable enabled ; then 
255         plc-config --category plc_monitor --variable enabled --value true \
256                         --save /etc/planetlab/configs/site.xml  /etc/planetlab/configs/site.xml 
257 fi
258 if ! plc-config --category plc_monitor --variable from_email ; then
259         plc-config --category plc_monitor --variable from_email --value monitor@localhost.localdomain \
260                         --save /etc/planetlab/configs/site.xml /etc/planetlab/configs/site.xml 
261 fi
262 if ! plc-config --category plc_monitor --variable cc_email ; then
263         plc-config --category plc_monitor --variable cc_email --value monitor@localhost.localdomain \
264                         --save /etc/planetlab/configs/site.xml /etc/planetlab/configs/site.xml 
265 fi
266 if ! plc-config --category plc_monitor --variable rt_queue ; then
267         plc-config --category plc_monitor --variable rt_queue --value support \
268                         --save /etc/planetlab/configs/site.xml /etc/planetlab/configs/site.xml 
269 fi
270
271 # zabbix:
272 if ! plc-config --category plc_zabbix --variable enabled ; then
273         plc-config --category plc_zabbix --variable enabled --value false \
274                         --save /etc/planetlab/configs/site.xml /etc/planetlab/configs/site.xml 
275 fi
276 if ! plc-config --category plc_zabbix --variable host ; then
277         plc-config --category plc_zabbix --variable host --value localhost.localdomain \
278                         --save /etc/planetlab/configs/site.xml /etc/planetlab/configs/site.xml 
279 fi
280 if ! plc-config --category plc_zabbix --variable ip ; then
281         plc-config --category plc_zabbix --variable ip --value "" \ 
282                         --save /etc/planetlab/configs/site.xml /etc/planetlab/configs/site.xml 
283 fi
284
285 %post server
286 # TODO: this will be nice when we have a web-based service running., such as
287 #               an API server or so on.
288 # TODO: create real monitorconfig.py from monitorconfig-default.py
289 # TODO: create symlink in /var/lib/monitor for chroot environments
290 # TODO: update the content of automate_pl03.sh 
291 # TODO: Use the installed version of bootcd to create custom boot images. ( or, use the api now).
292
293 # NOTE: generate the python defines from zabbix include files.
294 #php /usr/share/%{name}/zabbix/getdefines.php > %{python_sitearch}/monitor/database/zabbixapi/defines.py
295
296 # apply patches to zabbix
297 #patch -d /var/www/html/zabbix/ -p0 < /usr/share/%{name}/zabbix/zabbix-auto-login.diff
298
299 #chkconfig --add monitor-server
300 #chkconfig monitor-server on
301
302 %post client
303 chkconfig --add monitor
304 chkconfig monitor on
305
306 %post runlevelagent
307 chkconfig --add monitor-runlevelagent
308 chkconfig monitor-runlevelagent on
309 if [ "$PL_BOOTCD" != "1" ] ; then
310         service monitor-runlevelagent restart
311 fi
312
313
314 %changelog
315 * Thu Dec 17 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - Monitor-3.0-27
316 - fix rpm build issues
317
318 * Wed Dec 16 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - Monitor-3.0-26
319 - to many changes, but mostly moved stuff around. there are some small fixes here and there.
320
321 * Fri Nov 20 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-25
322 - add option for site status to include both node & pcu status
323 - improve ticket handling
324 - template gadget.xml for a site-specific google-gadget summary
325
326 * Thu Oct 22 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - Monitor-3.0-24
327 - - add install_date
328
329 * Mon Oct 19 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - Monitor-3.0-23
330 - - remove monitor-client.cron
331 - - remove unused monitor-client init script
332 - - fix UP/DOWN summary on nodes page.
333 - - make node page display all nodes by default
334 - - add boot_server field
335 - - add myops_ssh_key to the keychain
336 - - use ext_consortium_id to distinguish pending sites.
337
338 * Fri Oct 09 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - Monitor-3.0-22
339 - show/hide advance query form.
340
341 * Thu Sep 24 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-21
342 - fixed pause_penalty bug.
343 - fixed IPAL pcucontrol bug
344 - fixed bootman tunnel setup bug (occurred in rare cases)
345 - deprecated pcuview
346 - added BootmanSequenceRecords to separate config data from source code
347 - added get/setBootmanSequence(s) to xmlrpc API
348
349 * Fri Sep 04 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-20
350 - Major Features:
351 - added bm log collection and optional integration with BootManager's log Upload()
352 - added iptables_status
353 - expanded advanced query
354 - added differentiated bootmanager_restore actions so that actionsummary displays
355 - counts for each kind of bootmanager action
356 - added pcuerror notices (for mis-configurations) in addition to pcufailed notices
357 - added plain-text options for query page by adding tg_format=plain to URL
358 - fixed cross-module reference that prevented pcucontrol for working with RebootNodeWithPCU() api call.
359 - fixed a bug in determining whether comon's dir was running on a node
360
361 * Mon Aug 17 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-19
362 - Major increment -
363 - adds multiple features and web changes
364 - adds new fields to db
365 - improved layout
366 - general improvements otherwise
367
368 * Sun Jun 28 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-18
369 - bug fixes.
370 - improved templates and views
371 - cleaned controller code for web
372 - added IPMI requirement to pcucontrol package.
373
374 * Thu Jun 18 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-17
375 - added bootmanager log links
376 - addressed root cause of IntegrityErrors ; big deal
377 - adjusted templates to accomodate fix for IntegrityErrors
378 - added session.flush() to bootman.py to write out ActionsRecords
379 - fixed policy to either pause penalties or apply them ; not both.
380
381 -* Wed Jun 17 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-16
382 -- Added Rpyc from 1.0 branch.
383 -- add pcuhistory
384 -- add setup-agent for password protected keys.
385 -- other minor improvements.
386
387 * Wed Jun 17 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-15
388 - automate install
389 - auto-close tickets
390
391 * Fri Jun 12 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-14
392 - update web
393 - update policy
394 - added statistics dir
395
396 * Mon Jun 08 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-13
397 - remove plccache from controllers, all lookups from db.
398 - reformat emailTxt messags
399 - updated bootstates in bootman.py
400
401 * Tue Jun 02 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-12
402 - tag of latest changes.
403 - need to test end to end.
404
405 * Sat May 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - Monitor-3.0-11
406 - big merge from the 2.0 branch
407
408 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - Monitor-3.0-10
409 - minor improvements in rendering with sortable tables
410
411 * Tue May 19 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - Monitor-3.0-9
412
413 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - Monitor-3.0-8
414 - first draft with sortable tables + checkpoint
415
416 * Fri May 15 2009 Baris Metin <tmetin@sophia.inria.fr>
417 - use plekit tables from plewww.
418 - depend on plewww-plekit
419
420 * Tue May 12 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-7
421 - make docs a noop
422 - fix for package name dependency
423 - correct docs
424
425 * Mon May 04 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-6
426 - add improved docs to the latest build and tag.
427
428 * Mon May 04 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-5
429 - add documentation hooks for adding in-line docs like NM and PLCAPI
430
431 * Fri May 01 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-4
432 - Rough pass over monitor-3.0 to allow it to work with 4.3 API.
433 - replaced GetNodeNetworks, nodeinterface_ids and using new bootstates
434 - 'safeboot', 'failboot', 'reinstall', etc.
435
436 * Tue Apr 28 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-3
437 - same as 2.0-12 tag.
438
439 * Mon Apr 27 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-2
440 - merge from 2.0, remove more zabbix code, simplify install, etc.
441
442 * Thu Apr 16 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-1
443 - major merge from 2.0 branch.
444 - ready to be updated with 4.3 and web changes.
445
446 * Fri Feb 27 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-2.0-1
447 - preparing to make a 2.0 branch for monitor.
448
449 * Mon Jan 05 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-2.0-0
450 - new changes are significantly different, that I'm upping the number for clarity.
451
452 * Wed Sep 24 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-8
453 - These are all changes in the latest Monitor code.  I will branch this version
454 - next, before making additional large changes.
455
456 * Mon Sep 01 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - Monitor-1.0-7
457 - Checkpointing current version for 4.2-rc21 - many many changes
458
459 * Mon Aug 11 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-6
460 - This is a major tag of every thing.  probably needs a very different release
461 - number.
462
463 * Fri Jul 18 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-5
464 - Incremental improvements
465
466 * Mon May 19 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-4
467 - tagging everything for OneLab tech-transfer.
468
469
470 * Fri May 09 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-3
471
472
473 * Mon May 05 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-2
474
475
476 * Wed Apr 23 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-1
477 - This should be ready for 4.2rc2
478
479
480 * Mon Apr 07 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - monitor-1.0-0
481 - initial addition.
482
483 %define module_current_branch 2.0