Tagging module Monitor - Monitor-3.0-16
[monitor.git] / Monitor.spec
1 #
2 # $Id$
3
4
5 %define url $URL: svn+ssh://svn.planet-lab.org/svn/monitor/trunk/monitor.spec $
6
7 %define name monitor
8 %define version 3.0
9 %define taglevel 16
10
11 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
12 %global python_sitearch %( python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)" )
13
14 Name: %{name}
15 Version: %{version}
16 Release: %{release}
17 Source0: %{name}-%{version}.tar.bz2
18 License: GPL
19 Group: Applications/System
20 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
21
22 Vendor: PlanetLab
23 Packager: PlanetLab Central <support@planet-lab.org>
24 Distribution: PlanetLab %{plrelease}
25 URL: %(echo %{url} | cut -d ' ' -f 2)
26
27 Summary: Monitor account initialization for the root image.
28 Group: Applications/System
29
30 %description
31 Monitor is a collection of secondary scripts for configuring the node polling
32 system, syncing the PLC db with the monitoring database, notifying users,
33 interacting with PCU hardware, applying penalties to sites that violate
34 acceptable use.
35
36 ######################################## CLIENT
37
38 %package client
39 Summary: Monitor hooks for a PLC node
40 Group: Applications/System
41 Requires: curl
42 Requires: coreutils
43
44 %description client
45 The client scripts handle account creation inside of a node.  This will
46 include configuration setup for the monitoring agent running on the node.  It
47 will also include any cron or init scripts needed to perform this kind of
48 maintenance.
49 ######################################## Server Deps
50 %package server-deps
51 Summary: Monitor hooks for the PLC server.
52 Group: Applications/System
53
54 Requires: python
55 Requires: python-setuptools-devel
56 Requires: python-peak-util-extremes
57 Requires: TurboGears
58
59 Requires: compat-libstdc++-296
60 Requires: openssh-clients
61 Requires: perl-libwww-perl
62 Requires: perl-IO-Socket-SSL 
63 Requires: MySQL-python
64 Requires: nmap
65 Requires: rt3
66
67 Requires: plewww-plekit
68
69 #Requires: zabbix-client
70 #Requires: zabbix-gui
71 #Requires: zabbix-server
72
73 %description server-deps
74 The server side include all python modules and scripts needed to fully
75
76 ######################################## Server
77 %package server
78 Summary: Monitor hooks for the PLC server.
79 Group: Applications/System
80
81 Requires: python
82
83 Requires: monitor-server-deps
84 Requires: monitor-pcucontrol
85 Requires: PLCWWW >= 4.2
86 Requires: bootcd-%{pldistro}-%{_arch} >= 4.2
87
88 %description server
89 The server side include all python modules and scripts needed to fully
90 operation, track, and interact with any third-party monitoring software, such
91 as Zabbix DB.
92
93 ######################################## PCU Control
94
95 %package pcucontrol
96 summary: pcu controls for monitor and plcapi
97 group: applications/system
98 requires: python
99
100 %description pcucontrol
101 both monitor and the plcapi use a set of common commands to reboot machines
102 using their external or internal pcus.  this package is a library of several
103 supported models.
104
105 ####################################### RunlevelAgent
106 %package runlevelagent
107 summary: the RunlevelAgent that reports node runlevels
108 group: applications/system
109 requires: python
110
111 %description runlevelagent
112 The RunlevelAgent starts as early as possible during boot-up and production
113 mode to actively report the observed runlevel to PLC and update the
114 'last_contact' field.
115
116 %prep
117 %setup -q
118
119 %build
120 # NOTE: the build uses g++ cmdamt/
121 # NOTE: TMPDIR is needed here b/c the tmpfs of the build vserver is too small.
122 cd pcucontrol/models/intelamt
123 export TMPDIR=$PWD/tmp
124 make
125 cd ..
126
127 %install
128 rm -rf $RPM_BUILD_ROOT
129 #################### CLIENT 
130 install -D -m 755 monitor-client.init $RPM_BUILD_ROOT/%{_initrddir}/monitor
131 install -D -m 644 monitor.cron $RPM_BUILD_ROOT/%{_sysconfdir}/cron.d/monitor
132
133 #################### SERVER
134 install -d $RPM_BUILD_ROOT/usr/share/%{name}
135 install -d $RPM_BUILD_ROOT/data/var/lib/%{name}
136 install -d $RPM_BUILD_ROOT/data/var/lib/%{name}/archive-pdb
137 install -d $RPM_BUILD_ROOT/var/lib/%{name}
138 install -d $RPM_BUILD_ROOT/var/lib/%{name}/archive-pdb
139 install -d $RPM_BUILD_ROOT/var/www/cgi-bin/monitor/
140
141 install -D -m 755 monitor-server.init $RPM_BUILD_ROOT/%{_sysconfdir}/plc.d/monitor
142
143 echo " * Installing core scripts"
144 rsync -a --exclude www --exclude archive-pdb --exclude .svn --exclude CVS \
145           ./ $RPM_BUILD_ROOT/usr/share/%{name}/
146
147 echo " * Installing web pages"
148 rsync -a www/ $RPM_BUILD_ROOT/var/www/cgi-bin/monitor/
149
150 echo " * Installing cron job for automated polling"
151 install -D -m 644 monitor-server.cron $RPM_BUILD_ROOT/%{_sysconfdir}/cron.d/monitor-server.cron
152 echo " * TODO: Setting up Monitor account in local MyPLC"
153 # TODO: 
154
155 install -d $RPM_BUILD_ROOT/%{python_sitearch}/monitor
156 install -d -D -m 755 monitor $RPM_BUILD_ROOT/%{python_sitearch}/monitor
157 # TODO: need a much better way to do this.
158 rsync -a monitor/ $RPM_BUILD_ROOT/%{python_sitearch}/monitor/
159 #for file in __init__.py database.py config.py ; do 
160 #       install -D -m 644 monitor/$file $RPM_BUILD_ROOT/%{python_sitearch}/monitor/$file
161 #done
162 rsync -a pcucontrol/ $RPM_BUILD_ROOT/%{python_sitearch}/pcucontrol/
163 install -D -m 755 threadpool.py $RPM_BUILD_ROOT/%{python_sitearch}/threadpool.py
164
165 touch $RPM_BUILD_ROOT/var/www/cgi-bin/monitor/monitorconfig.php
166 chmod 777 $RPM_BUILD_ROOT/var/www/cgi-bin/monitor/monitorconfig.php
167
168 #install -D -m 755 monitor-default.conf $RPM_BUILD_ROOT/etc/monitor.conf
169 #cp $RPM_BUILD_ROOT/usr/share/%{name}/monitorconfig-default.py $RPM_BUILD_ROOT/usr/share/%{name}/monitorconfig.py
170
171 #################### RunlevelAgent
172 install -D -m 755 RunlevelAgent.py $RPM_BUILD_ROOT/usr/bin/RunlevelAgent.py
173 install -D -m 755 monitor-runlevelagent.init $RPM_BUILD_ROOT/%{_initrddir}/monitor-runlevelagent
174
175 mkdir -p $RPM_BUILD_ROOT/var/log
176 touch $RPM_BUILD_ROOT/var/log/server-deps.log
177
178
179 %clean
180 rm -rf $RPM_BUILD_ROOT
181
182 %files server-deps
183 /var/log/server-deps.log
184
185 %files server
186 %defattr(-,root,root)
187 #%config /usr/share/%{name}/monitorconfig.py
188 #%config /etc/monitor.conf
189 /usr/share/%{name}
190 /var/lib/%{name}
191 /var/www/cgi-bin/monitor
192 %{_sysconfdir}/cron.d/monitor-server.cron
193 %{python_sitearch}/threadpool.py
194 %{python_sitearch}/threadpool.pyc
195 %{python_sitearch}/threadpool.pyo
196 %{python_sitearch}/monitor
197 %{_sysconfdir}/plc.d/monitor
198
199 %files client
200 %defattr(-,root,root)
201 %{_initrddir}/monitor
202 %{_sysconfdir}/cron.d/monitor
203
204 %files pcucontrol
205 %{python_sitearch}/pcucontrol
206
207 %files runlevelagent
208 /usr/bin/RunlevelAgent.py
209 /usr/bin/RunlevelAgent.pyo
210 /usr/bin/RunlevelAgent.pyc
211 /%{_initrddir}/monitor-runlevelagent
212
213 %post server-deps
214 #easy_install --build-directory /var/tmp -UZ ElementTree
215 ##easy_install --build-directory /var/tmp -UZ http://pypi.python.org/packages/2.5/E/Extremes/Extremes-1.1-py2.5.egg
216
217 # NOTE: enable monitor by default, since we're installing it.
218 plc-config --save /etc/planetlab/default_config.xml \
219                         --category plc_monitor --variable enabled --value true
220
221 ## TODO: something is bad wrong with this approach.
222 easy_install --build-directory /var/tmp -UZ http://files.turbogears.org/eggs/TurboGears-1.0.7-py2.5.egg
223 easy_install --build-directory /var/tmp -UZ http://pypi.python.org/packages/source/S/SQLAlchemy/SQLAlchemy-0.5.3.tar.gz
224 easy_install --build-directory /var/tmp -UZ Elixir
225
226 # crazy openssl libs for racadm binary
227 ln -s /lib/libssl.so.0.9.8b /usr/lib/libssl.so.2
228
229 if grep 'pam_loginuid.so' /etc/pam.d/crond ; then
230     sed -i -e 's/^session    required   pam_loginuid.so/#session    required   pam_loginuid.so/g' /etc/pam.d/crond
231 fi
232 # NOTE: add the default xml stuff if it's not already in the default xml config.
233 if ! grep '<category id="plc_monitor">' /etc/planetlab/default_config.xml ; then 
234     sed -i 's|<category id="plc_net">| <category id="plc_monitor">\n <name>Monitor Service Configuration</name>\n <description>Monitor</description>\n <variablelist>\n <variable id="enabled" type="boolean">\n <name>Enabled</name>\n <value>true</value>\n <description>Enable on this machine.</description>\n </variable>\n <variable id="email">\n <value></value>\n </variable>\n <variable id="dbpassword">\n <value></value>\n </variable>\n <variable id="host" type="hostname">\n <name>Hostname</name>\n <value>pl-virtual-06.cs.princeton.edu</value>\n <description>The fully qualified hostname.</description>\n </variable>\n <variable id="ip" type="ip">\n <name>IP Address</name>\n <value/>\n <description>The IP address of the monitor server.</description>\n </variable>\n </variablelist>\n </category>\n <category id="plc_net">|' /etc/planetlab/default_config.xml
235 fi
236
237
238 %post server
239 # TODO: this will be nice when we have a web-based service running., such as
240 #               an API server or so on.
241 # TODO: create real monitorconfig.py from monitorconfig-default.py
242 # TODO: create monitorconfig.php using phpconfig.py 
243 # TODO: create symlink in /var/lib/monitor for chroot environments
244 # TODO: update the content of automate_pl03.sh 
245 # TODO: Use the installed version of bootcd to create custom boot images. ( or, use the api now).
246
247 # NOTE: generate the python defines from zabbix include files.
248 #php /usr/share/%{name}/zabbix/getdefines.php > %{python_sitearch}/monitor/database/zabbixapi/defines.py
249
250 # apply patches to zabbix
251 #patch -d /var/www/html/zabbix/ -p0 < /usr/share/%{name}/zabbix/zabbix-auto-login.diff
252
253 #chkconfig --add monitor-server
254 #chkconfig monitor-server on
255
256 %post client
257 chkconfig --add monitor
258 chkconfig monitor on
259
260 %post runlevelagent
261 chkconfig --add monitor-runlevelagent
262 chkconfig monitor-runlevelagent on
263
264 %changelog
265 * Wed Jun 17 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-16
266 - Added Rpyc from 1.0 branch.
267 - add pcuhistory
268 - add setup-agent for password protected keys.
269 - other minor improvements.
270
271 * Wed Jun 17 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-15
272 - automate install
273 - auto-close tickets
274
275 * Fri Jun 12 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-14
276 - update web
277 - update policy
278 - added statistics dir
279
280 * Mon Jun 08 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-13
281 - remove plccache from controllers, all lookups from db.
282 - reformat emailTxt messags
283 - updated bootstates in bootman.py
284
285 * Tue Jun 02 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-12
286 - tag of latest changes.
287 - need to test end to end.
288
289 * Sat May 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - Monitor-3.0-11
290 - big merge from the 2.0 branch
291
292 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - Monitor-3.0-10
293 - minor improvements in rendering with sortable tables
294
295 * Tue May 19 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - Monitor-3.0-9
296
297 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - Monitor-3.0-8
298 - first draft with sortable tables + checkpoint
299
300 * Fri May 15 2009 Baris Metin <tmetin@sophia.inria.fr>
301 - use plekit tables from plewww.
302 - depend on plewww-plekit
303
304 * Tue May 12 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-7
305 - make docs a noop
306 - fix for package name dependency
307 - correct docs
308
309 * Mon May 04 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-6
310 - add improved docs to the latest build and tag.
311
312 * Mon May 04 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-5
313 - add documentation hooks for adding in-line docs like NM and PLCAPI
314
315 * Fri May 01 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-4
316 - Rough pass over monitor-3.0 to allow it to work with 4.3 API.
317 - replaced GetNodeNetworks, nodeinterface_ids and using new bootstates
318 - 'safeboot', 'failboot', 'reinstall', etc.
319
320 * Tue Apr 28 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-3
321 - same as 2.0-12 tag.
322
323 * Mon Apr 27 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-2
324 - merge from 2.0, remove more zabbix code, simplify install, etc.
325
326 * Thu Apr 16 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-1
327 - major merge from 2.0 branch.
328 - ready to be updated with 4.3 and web changes.
329
330 * Fri Feb 27 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-2.0-1
331 - preparing to make a 2.0 branch for monitor.
332
333 * Mon Jan 05 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-2.0-0
334 - new changes are significantly different, that I'm upping the number for clarity.
335
336 * Wed Sep 24 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-8
337 - These are all changes in the latest Monitor code.  I will branch this version
338 - next, before making additional large changes.
339
340 * Mon Sep 01 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - Monitor-1.0-7
341 - Checkpointing current version for 4.2-rc21 - many many changes
342
343 * Mon Aug 11 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-6
344 - This is a major tag of every thing.  probably needs a very different release
345 - number.
346
347 * Fri Jul 18 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-5
348 - Incremental improvements
349
350 * Mon May 19 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-4
351 - tagging everything for OneLab tech-transfer.
352
353
354 * Fri May 09 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-3
355
356
357 * Mon May 05 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-2
358
359
360 * Wed Apr 23 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-1
361 - This should be ready for 4.2rc2
362
363
364 * Mon Apr 07 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - monitor-1.0-0
365 - initial addition.
366
367 %define module_current_branch 2.0