cleaned and improved monitor-rt3.init
[monitor.git] / Monitor.spec
1 #
2 # $Id$
3
4
5 %define url $URL: svn+ssh://svn.planet-lab.org/svn/monitor/trunk/monitor.spec $
6
7 %define name monitor
8 %define version 3.0
9 %define taglevel 17
10
11 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
12 %global python_sitearch %( python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)" )
13
14 Name: %{name}
15 Version: %{version}
16 Release: %{release}
17 Source0: %{name}-%{version}.tar.bz2
18 License: GPL
19 Group: Applications/System
20 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
21
22 Vendor: PlanetLab
23 Packager: PlanetLab Central <support@planet-lab.org>
24 Distribution: PlanetLab %{plrelease}
25 URL: %(echo %{url} | cut -d ' ' -f 2)
26
27 Summary: Monitor account initialization for the root image.
28 Group: Applications/System
29
30 %description
31 Monitor is a collection of secondary scripts for configuring the node polling
32 system, syncing the PLC db with the monitoring database, notifying users,
33 interacting with PCU hardware, applying penalties to sites that violate
34 acceptable use.
35
36 ######################################## CLIENT
37
38 %package client
39 Summary: Monitor hooks for a PLC node
40 Group: Applications/System
41 Requires: curl
42 Requires: coreutils
43
44 %description client
45 The client scripts handle account creation inside of a node.  This will
46 include configuration setup for the monitoring agent running on the node.  It
47 will also include any cron or init scripts needed to perform this kind of
48 maintenance.
49 ######################################## Server Deps
50 %package server-deps
51 Summary: Monitor hooks for the PLC server.
52 Group: Applications/System
53
54 Requires: python
55 Requires: python-setuptools-devel
56 Requires: python-peak-util-extremes
57 Requires: TurboGears
58
59 Requires: compat-libstdc++-296
60 Requires: openssh-clients
61 Requires: perl-libwww-perl
62 Requires: perl-IO-Socket-SSL 
63 Requires: MySQL-python
64 Requires: nmap
65 Requires: rt3
66
67 Requires: plewww-plekit
68
69 #Requires: zabbix-client
70 #Requires: zabbix-gui
71 #Requires: zabbix-server
72
73 %description server-deps
74 The server side include all python modules and scripts needed to fully
75
76 ######################################## Server
77 %package server
78 Summary: Monitor hooks for the PLC server.
79 Group: Applications/System
80
81 Requires: python
82
83 Requires: monitor-server-deps
84 Requires: monitor-pcucontrol
85 Requires: PLCWWW >= 4.2
86 Requires: bootcd-%{pldistro}-%{_arch} >= 4.2
87
88 %description server
89 The server side include all python modules and scripts needed to fully
90 operation, track, and interact with any third-party monitoring software, such
91 as Zabbix DB.
92
93 ######################################## RT setup
94
95 %package rt
96 summary: Dependencies and default configuration for RT3
97 group: applications/system
98 Requires: monitor-server
99 Requires: rt3
100 Requires: rt3-mailgate
101
102 %description rt
103 RT3 is a ticket tracking system.  This RPM integrates RT into the MyOps
104 framework, and MyPLC in general.
105
106 ######################################## PCU Control
107
108 %package pcucontrol
109 summary: pcu controls for monitor and plcapi
110 group: applications/system
111 requires: python
112
113 %description pcucontrol
114 both monitor and the plcapi use a set of common commands to reboot machines
115 using their external or internal pcus.  this package is a library of several
116 supported models.
117
118 ####################################### RunlevelAgent
119 %package runlevelagent
120 summary: the RunlevelAgent that reports node runlevels
121 group: applications/system
122 requires: python
123
124 %description runlevelagent
125 The RunlevelAgent starts as early as possible during boot-up and production
126 mode to actively report the observed runlevel to PLC and update the
127 'last_contact' field.
128
129 %prep
130 %setup -q
131
132 %build
133 # NOTE: the build uses g++ cmdamt/
134 # NOTE: TMPDIR is needed here b/c the tmpfs of the build vserver is too small.
135 cd pcucontrol/models/intelamt
136 export TMPDIR=$PWD/tmp
137 make
138 cd ..
139
140 %install
141 rm -rf $RPM_BUILD_ROOT
142 #################### CLIENT 
143 install -D -m 755 monitor-client.init $RPM_BUILD_ROOT/%{_initrddir}/monitor
144 install -D -m 644 monitor.cron $RPM_BUILD_ROOT/%{_sysconfdir}/cron.d/monitor
145
146 #################### SERVER
147 install -d $RPM_BUILD_ROOT/usr/share/%{name}
148 install -d $RPM_BUILD_ROOT/data/var/lib/%{name}
149 install -d $RPM_BUILD_ROOT/data/var/lib/%{name}/archive-pdb
150 install -d $RPM_BUILD_ROOT/var/lib/%{name}
151 install -d $RPM_BUILD_ROOT/var/lib/%{name}/archive-pdb
152 install -d $RPM_BUILD_ROOT/var/www/cgi-bin/monitor/
153 install -d $RPM_BUILD_ROOT/var/www/html/monitorlog/
154
155 install -D -m 644 monitor.functions $RPM_BUILD_ROOT/%{_sysconfdir}/plc.d/monitor.functions
156 install -D -m 755 monitor-server.init $RPM_BUILD_ROOT/%{_sysconfdir}/plc.d/monitor
157 install -D -m 755 zabbix/monitor-zabbix.init $RPM_BUILD_ROOT/%{_sysconfdir}/plc.d/zabbix
158 install -D -m 755 rt3/monitor-rt3.init $RPM_BUILD_ROOT/%{_sysconfdir}/plc.d/rt3
159
160 echo " * Installing core scripts"
161 rsync -a --exclude www --exclude archive-pdb --exclude .svn --exclude CVS \
162           ./ $RPM_BUILD_ROOT/usr/share/%{name}/
163
164 echo " * Installing web pages"
165 rsync -a www/ $RPM_BUILD_ROOT/var/www/cgi-bin/monitor/
166 rsync -a log/ $RPM_BUILD_ROOT/var/www/html/monitorlog/
167
168 echo " * Installing cron job for automated polling"
169 install -D -m 644 monitor-server.cron $RPM_BUILD_ROOT/%{_sysconfdir}/cron.d/monitor-server.cron
170 echo " * TODO: Setting up Monitor account in local MyPLC"
171 # TODO: 
172
173 install -d $RPM_BUILD_ROOT/%{python_sitearch}/monitor
174 install -d -D -m 755 monitor $RPM_BUILD_ROOT/%{python_sitearch}/monitor
175 # TODO: need a much better way to do this.
176 rsync -a monitor/ $RPM_BUILD_ROOT/%{python_sitearch}/monitor/
177 #for file in __init__.py database.py config.py ; do 
178 #       install -D -m 644 monitor/$file $RPM_BUILD_ROOT/%{python_sitearch}/monitor/$file
179 #done
180 rsync -a pcucontrol/ $RPM_BUILD_ROOT/%{python_sitearch}/pcucontrol/
181 install -D -m 755 threadpool.py $RPM_BUILD_ROOT/%{python_sitearch}/threadpool.py
182
183 touch $RPM_BUILD_ROOT/var/www/cgi-bin/monitor/monitorconfig.php
184 chmod 777 $RPM_BUILD_ROOT/var/www/cgi-bin/monitor/monitorconfig.php
185
186 #install -D -m 755 monitor-default.conf $RPM_BUILD_ROOT/etc/monitor.conf
187 #cp $RPM_BUILD_ROOT/usr/share/%{name}/monitorconfig-default.py $RPM_BUILD_ROOT/usr/share/%{name}/monitorconfig.py
188
189 #################### RunlevelAgent
190 install -D -m 755 RunlevelAgent.py $RPM_BUILD_ROOT/usr/bin/RunlevelAgent.py
191 install -D -m 755 monitor-runlevelagent.init $RPM_BUILD_ROOT/%{_initrddir}/monitor-runlevelagent
192
193 mkdir -p $RPM_BUILD_ROOT/var/log
194 touch $RPM_BUILD_ROOT/var/log/server-deps.log
195
196
197 %clean
198 rm -rf $RPM_BUILD_ROOT
199
200 %files server-deps
201 /var/log/server-deps.log
202
203 %files server
204 %defattr(-,root,root)
205 #%config /usr/share/%{name}/monitorconfig.py
206 #%config /etc/monitor.conf
207 /usr/share/%{name}
208 /var/lib/%{name}
209 /var/www/cgi-bin/monitor
210 %{_sysconfdir}/cron.d/monitor-server.cron
211 %{python_sitearch}/threadpool.py
212 %{python_sitearch}/threadpool.pyc
213 %{python_sitearch}/threadpool.pyo
214 %{python_sitearch}/monitor
215 %{_sysconfdir}/plc.d/monitor
216 %{_sysconfdir}/plc.d/monitor.functions
217 %{_sysconfdir}/plc.d/zabbix
218
219 %files client
220 %defattr(-,root,root)
221 %{_initrddir}/monitor
222 %{_sysconfdir}/cron.d/monitor
223
224 %files rt 
225 %defattr(-,root,root)
226 /usr/share/%{name}/rt3
227 %{_sysconfdir}/plc.d/rt3
228
229 %files pcucontrol
230 %{python_sitearch}/pcucontrol
231
232 %files runlevelagent
233 /usr/bin/RunlevelAgent.py
234 /usr/bin/RunlevelAgent.pyo
235 /usr/bin/RunlevelAgent.pyc
236 /%{_initrddir}/monitor-runlevelagent
237
238 %post server-deps
239 #easy_install --build-directory /var/tmp -UZ ElementTree
240 ##easy_install --build-directory /var/tmp -UZ http://pypi.python.org/packages/2.5/E/Extremes/Extremes-1.1-py2.5.egg
241
242
243 ## TODO: something is bad wrong with this approach.
244 easy_install --build-directory /var/tmp -UZ http://files.turbogears.org/eggs/TurboGears-1.0.7-py2.5.egg
245 easy_install --build-directory /var/tmp -UZ http://pypi.python.org/packages/source/S/SQLAlchemy/SQLAlchemy-0.5.3.tar.gz
246 easy_install --build-directory /var/tmp -UZ Elixir
247
248 # crazy openssl libs for racadm binary
249 ln -s /lib/libssl.so.0.9.8b /usr/lib/libssl.so.2
250 mkdir /usr/share/monitor/.ssh
251 chmod 700 /usr/share/monitor/.ssh
252
253 if grep 'pam_loginuid.so' /etc/pam.d/crond ; then
254     sed -i -e 's/^session    required   pam_loginuid.so/#session    required   pam_loginuid.so/g' /etc/pam.d/crond
255 fi
256 # NOTE: add the default xml stuff if it's not already in the default xml config.
257 if ! grep '<category id="plc_monitor">' /etc/planetlab/default_config.xml ; then 
258     sed -i 's|<category id="plc_net">| <category id="plc_monitor">\n <name>Monitor Service Configuration</name>\n <description>Monitor</description>\n <variablelist>\n <variable id="enabled" type="boolean">\n <name>Enabled</name>\n <value>true</value>\n <description>Enable on this machine.</description>\n </variable>\n <variable id="email">\n <value></value>\n </variable>\n <variable id="dbpassword">\n <value></value>\n </variable>\n <variable id="host" type="hostname">\n <name>Hostname</name>\n <value>pl-virtual-06.cs.princeton.edu</value>\n <description>The fully qualified hostname.</description>\n </variable>\n <variable id="ip" type="ip">\n <name>IP Address</name>\n <value/>\n <description>The IP address of the monitor server.</description>\n </variable>\n </variablelist>\n </category>\n <category id="plc_net">|' /etc/planetlab/default_config.xml
259 fi
260 if ! grep '<category id="plc_rt">' /etc/planetlab/default_config.xml ; then 
261     sed -i 's|<category id="plc_net">| <category id="plc_rt">\n <name>RT Configuration</name>\n <description>RT</description>\n <variablelist>\n <variable id="enabled" type="boolean">\n <name>Enabled</name>\n <value>false</value>\n <description>Enable on this machine.</description>\n </variable>\n <variable id="host" type="hostname">\n <name>Hostname</name>\n <value>localhost.localdomain</value>\n <description>The fully qualified hostname.</description>\n </variable>\n <variable id="ip" type="ip">\n <name>IP Address</name>\n <value/>\n <description>The IP address of the RT server.</description>\n </variable>\n </variablelist>\n </category>\n <category id="plc_net">|' /etc/planetlab/default_config.xml
262 fi
263 if ! grep '<category id="plc_zabbix">' /etc/planetlab/default_config.xml ; then 
264     sed -i 's|<category id="plc_net">| <category id="plc_zabbix">\n <name>Zabbix Configuration</name>\n <description>Zabbix</description>\n <variablelist>\n <variable id="enabled" type="boolean">\n <name>Enabled</name>\n <value>false</value>\n <description>Enable on this machine.</description>\n </variable>\n <variable id="host" type="hostname">\n <name>Hostname</name>\n <value>localhost.localdomain</value>\n <description>The fully qualified hostname.</description>\n </variable>\n <variable id="ip" type="ip">\n <name>IP Address</name>\n <value/>\n <description>The IP address of the Zabbix server.</description>\n </variable>\n </variablelist>\n </category>\n <category id="plc_net">|' /etc/planetlab/default_config.xml
265 fi
266
267 # NOTE: enable monitor by default, since we're installing it.
268 plc-config --save /etc/planetlab/default_config.xml \
269                         --category plc_monitor --variable enabled --value true
270
271 %post rt
272 plc-config --save /etc/planetlab/default_config.xml \
273                         --category plc_rt --variable enabled --value true
274
275 %post server
276 # TODO: this will be nice when we have a web-based service running., such as
277 #               an API server or so on.
278 # TODO: create real monitorconfig.py from monitorconfig-default.py
279 # TODO: create monitorconfig.php using phpconfig.py 
280 # TODO: create symlink in /var/lib/monitor for chroot environments
281 # TODO: update the content of automate_pl03.sh 
282 # TODO: Use the installed version of bootcd to create custom boot images. ( or, use the api now).
283
284 # NOTE: generate the python defines from zabbix include files.
285 #php /usr/share/%{name}/zabbix/getdefines.php > %{python_sitearch}/monitor/database/zabbixapi/defines.py
286
287 # apply patches to zabbix
288 #patch -d /var/www/html/zabbix/ -p0 < /usr/share/%{name}/zabbix/zabbix-auto-login.diff
289
290 #chkconfig --add monitor-server
291 #chkconfig monitor-server on
292
293 %post client
294 chkconfig --add monitor
295 chkconfig monitor on
296
297 %post runlevelagent
298 chkconfig --add monitor-runlevelagent
299 chkconfig monitor-runlevelagent on
300
301 %changelog
302 * Thu Jun 18 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-17
303 - added bootmanager log links
304 - addressed root cause of IntegrityErrors ; big deal
305 - adjusted templates to accomodate fix for IntegrityErrors
306 - added session.flush() to bootman.py to write out ActionsRecords
307 - fixed policy to either pause penalties or apply them ; not both.
308
309 -* Wed Jun 17 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-16
310 -- Added Rpyc from 1.0 branch.
311 -- add pcuhistory
312 -- add setup-agent for password protected keys.
313 -- other minor improvements.
314
315 * Wed Jun 17 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-15
316 - automate install
317 - auto-close tickets
318
319 * Fri Jun 12 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-14
320 - update web
321 - update policy
322 - added statistics dir
323
324 * Mon Jun 08 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-13
325 - remove plccache from controllers, all lookups from db.
326 - reformat emailTxt messags
327 - updated bootstates in bootman.py
328
329 * Tue Jun 02 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-12
330 - tag of latest changes.
331 - need to test end to end.
332
333 * Sat May 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - Monitor-3.0-11
334 - big merge from the 2.0 branch
335
336 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - Monitor-3.0-10
337 - minor improvements in rendering with sortable tables
338
339 * Tue May 19 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - Monitor-3.0-9
340
341 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - Monitor-3.0-8
342 - first draft with sortable tables + checkpoint
343
344 * Fri May 15 2009 Baris Metin <tmetin@sophia.inria.fr>
345 - use plekit tables from plewww.
346 - depend on plewww-plekit
347
348 * Tue May 12 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-7
349 - make docs a noop
350 - fix for package name dependency
351 - correct docs
352
353 * Mon May 04 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-6
354 - add improved docs to the latest build and tag.
355
356 * Mon May 04 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-5
357 - add documentation hooks for adding in-line docs like NM and PLCAPI
358
359 * Fri May 01 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-4
360 - Rough pass over monitor-3.0 to allow it to work with 4.3 API.
361 - replaced GetNodeNetworks, nodeinterface_ids and using new bootstates
362 - 'safeboot', 'failboot', 'reinstall', etc.
363
364 * Tue Apr 28 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-3
365 - same as 2.0-12 tag.
366
367 * Mon Apr 27 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-2
368 - merge from 2.0, remove more zabbix code, simplify install, etc.
369
370 * Thu Apr 16 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-1
371 - major merge from 2.0 branch.
372 - ready to be updated with 4.3 and web changes.
373
374 * Fri Feb 27 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-2.0-1
375 - preparing to make a 2.0 branch for monitor.
376
377 * Mon Jan 05 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-2.0-0
378 - new changes are significantly different, that I'm upping the number for clarity.
379
380 * Wed Sep 24 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-8
381 - These are all changes in the latest Monitor code.  I will branch this version
382 - next, before making additional large changes.
383
384 * Mon Sep 01 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - Monitor-1.0-7
385 - Checkpointing current version for 4.2-rc21 - many many changes
386
387 * Mon Aug 11 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-6
388 - This is a major tag of every thing.  probably needs a very different release
389 - number.
390
391 * Fri Jul 18 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-5
392 - Incremental improvements
393
394 * Mon May 19 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-4
395 - tagging everything for OneLab tech-transfer.
396
397
398 * Fri May 09 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-3
399
400
401 * Mon May 05 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-2
402
403
404 * Wed Apr 23 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-1
405 - This should be ready for 4.2rc2
406
407
408 * Mon Apr 07 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - monitor-1.0-0
409 - initial addition.
410
411 %define module_current_branch 2.0