Tagging module Monitor - Monitor-3.0-13
[monitor.git] / Monitor.spec
1 #
2 # $Id$
3
4
5 %define url $URL: svn+ssh://svn.planet-lab.org/svn/monitor/trunk/monitor.spec $
6
7 %define name monitor
8 %define version 3.0
9 %define taglevel 13
10
11 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
12 %global python_sitearch %( python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)" )
13
14 Name: %{name}
15 Version: %{version}
16 Release: %{release}
17 Source0: %{name}-%{version}.tar.bz2
18 License: GPL
19 Group: Applications/System
20 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
21
22 Vendor: PlanetLab
23 Packager: PlanetLab Central <support@planet-lab.org>
24 Distribution: PlanetLab %{plrelease}
25 URL: %(echo %{url} | cut -d ' ' -f 2)
26
27 Summary: Monitor account initialization for the root image.
28 Group: Applications/System
29
30 %description
31 Monitor is a collection of secondary scripts for configuring the node polling
32 system, syncing the PLC db with the monitoring database, notifying users,
33 interacting with PCU hardware, applying penalties to sites that violate
34 acceptable use.
35
36 ######################################## CLIENT
37
38 %package client
39 Summary: Monitor hooks for a PLC node
40 Group: Applications/System
41 Requires: curl
42 Requires: coreutils
43
44 %description client
45 The client scripts handle account creation inside of a node.  This will
46 include configuration setup for the monitoring agent running on the node.  It
47 will also include any cron or init scripts needed to perform this kind of
48 maintenance.
49 ######################################## Server Deps
50 %package server-deps
51 Summary: Monitor hooks for the PLC server.
52 Group: Applications/System
53
54 Requires: python
55 Requires: python-setuptools-devel
56
57 Requires: openssh-clients
58 Requires: perl-libwww-perl
59 Requires: perl-IO-Socket-SSL 
60 Requires: MySQL-python
61 Requires: nmap
62 Requires: rt3
63
64 Requires: plewww-plekit
65 #Requires: python-sqlalchemy
66 #Requires: python-elixir
67 #Requires: zabbix-client
68 #Requires: zabbix-gui
69 #Requires: zabbix-server
70
71 %description server-deps
72 The server side include all python modules and scripts needed to fully
73
74 ######################################## Server
75 %package server
76 Summary: Monitor hooks for the PLC server.
77 Group: Applications/System
78
79 Requires: python
80
81 Requires: monitor-server-deps
82 Requires: monitor-pcucontrol
83 Requires: PLCWWW >= 4.2
84 Requires: bootcd-%{pldistro}-%{_arch} >= 4.2
85
86 %description server
87 The server side include all python modules and scripts needed to fully
88 operation, track, and interact with any third-party monitoring software, such
89 as Zabbix DB.
90
91 ######################################## PCU Control
92
93 %package pcucontrol
94 summary: pcu controls for monitor and plcapi
95 group: applications/system
96 requires: python
97
98 %description pcucontrol
99 both monitor and the plcapi use a set of common commands to reboot machines
100 using their external or internal pcus.  this package is a library of several
101 supported models.
102
103 ####################################### RunlevelAgent
104 %package runlevelagent
105 summary: the RunlevelAgent that reports node runlevels
106 group: applications/system
107 requires: python
108
109 %description runlevelagent
110 The RunlevelAgent starts as early as possible during boot-up and production
111 mode to actively report the observed runlevel to PLC and update the
112 'last_contact' field.
113
114 %prep
115 %setup -q
116
117 %build
118 # NOTE: the build uses g++ cmdamt/
119 # NOTE: TMPDIR is needed here b/c the tmpfs of the build vserver is too small.
120 cd pcucontrol/models/intelamt
121 export TMPDIR=$PWD/tmp
122 make
123 cd ..
124
125 %install
126 rm -rf $RPM_BUILD_ROOT
127 #################### CLIENT 
128 install -D -m 755 monitor-client.init $RPM_BUILD_ROOT/%{_initrddir}/monitor
129 install -D -m 644 monitor.cron $RPM_BUILD_ROOT/%{_sysconfdir}/cron.d/monitor
130
131 #################### SERVER
132 install -d $RPM_BUILD_ROOT/usr/share/%{name}
133 install -d $RPM_BUILD_ROOT/data/var/lib/%{name}
134 install -d $RPM_BUILD_ROOT/data/var/lib/%{name}/archive-pdb
135 install -d $RPM_BUILD_ROOT/var/lib/%{name}
136 install -d $RPM_BUILD_ROOT/var/lib/%{name}/archive-pdb
137 install -d $RPM_BUILD_ROOT/var/www/cgi-bin/monitor/
138
139 install -D -m 755 monitor-server.init $RPM_BUILD_ROOT/%{_sysconfdir}/plc.d/monitor
140
141 echo " * Installing core scripts"
142 rsync -a --exclude www --exclude archive-pdb --exclude .svn --exclude CVS \
143           ./ $RPM_BUILD_ROOT/usr/share/%{name}/
144
145 echo " * Installing web pages"
146 rsync -a www/ $RPM_BUILD_ROOT/var/www/cgi-bin/monitor/
147
148 echo " * Installing cron job for automated polling"
149 install -D -m 644 monitor-server.cron $RPM_BUILD_ROOT/%{_sysconfdir}/cron.d/monitor-server.cron
150 echo " * TODO: Setting up Monitor account in local MyPLC"
151 # TODO: 
152
153 install -d $RPM_BUILD_ROOT/%{python_sitearch}/monitor
154 install -d -D -m 755 monitor $RPM_BUILD_ROOT/%{python_sitearch}/monitor
155 # TODO: need a much better way to do this.
156 rsync -a monitor/ $RPM_BUILD_ROOT/%{python_sitearch}/monitor/
157 #for file in __init__.py database.py config.py ; do 
158 #       install -D -m 644 monitor/$file $RPM_BUILD_ROOT/%{python_sitearch}/monitor/$file
159 #done
160 rsync -a pcucontrol/ $RPM_BUILD_ROOT/%{python_sitearch}/pcucontrol/
161 install -D -m 755 threadpool.py $RPM_BUILD_ROOT/%{python_sitearch}/threadpool.py
162
163 touch $RPM_BUILD_ROOT/var/www/cgi-bin/monitor/monitorconfig.php
164 chmod 777 $RPM_BUILD_ROOT/var/www/cgi-bin/monitor/monitorconfig.php
165
166 #install -D -m 755 monitor-default.conf $RPM_BUILD_ROOT/etc/monitor.conf
167 #cp $RPM_BUILD_ROOT/usr/share/%{name}/monitorconfig-default.py $RPM_BUILD_ROOT/usr/share/%{name}/monitorconfig.py
168
169 #################### RunlevelAgent
170 install -D -m 755 RunlevelAgent.py $RPM_BUILD_ROOT/usr/bin/RunlevelAgent.py
171 install -D -m 755 monitor-runlevelagent.init $RPM_BUILD_ROOT/%{_initrddir}/monitor-runlevelagent
172
173 mkdir -p $RPM_BUILD_ROOT/var/log
174 touch $RPM_BUILD_ROOT/var/log/server-deps.log
175
176
177 %clean
178 rm -rf $RPM_BUILD_ROOT
179
180 %files server-deps
181 /var/log/server-deps.log
182
183 %files server
184 %defattr(-,root,root)
185 #%config /usr/share/%{name}/monitorconfig.py
186 #%config /etc/monitor.conf
187 /usr/share/%{name}
188 /var/lib/%{name}
189 /var/www/cgi-bin/monitor
190 %{_sysconfdir}/cron.d/monitor-server.cron
191 %{python_sitearch}/threadpool.py
192 %{python_sitearch}/threadpool.pyc
193 %{python_sitearch}/threadpool.pyo
194 %{python_sitearch}/monitor
195 %{_sysconfdir}/plc.d/monitor
196
197 %files client
198 %defattr(-,root,root)
199 %{_initrddir}/monitor
200 %{_sysconfdir}/cron.d/monitor
201
202 %files pcucontrol
203 %{python_sitearch}/pcucontrol
204
205 %files runlevelagent
206 /usr/bin/RunlevelAgent.py
207 /usr/bin/RunlevelAgent.pyo
208 /usr/bin/RunlevelAgent.pyc
209 /%{_initrddir}/monitor-runlevelagent
210
211 %post server-deps
212 easy_install --build-directory /var/tmp -UZ Elixir
213 easy_install --build-directory /var/tmp -UZ ElementTree
214 # TODO: something is bad wrong with this approach.
215 #easy_install --build-directory /var/tmp -UZ http://pypi.python.org/packages/2.5/E/Extremes/Extremes-1.1-py2.5.egg
216 #easy_install --build-directory /var/tmp -UZ "Paste==1.5.1"
217 #easy_install --build-directory /var/tmp -UZ "PasteDeploy==1.3.1"
218
219 easy_install --build-directory /var/tmp -UZ http://pypi.python.org/packages/source/S/SQLAlchemy/SQLAlchemy-0.5.3.tar.gz
220 easy_install --build-directory /var/tmp -UZ http://files.turbogears.org/eggs/TurboGears-1.0.7-py2.5.egg
221
222 # NOTE: add the default xml stuff if it's not already in the default xml config.
223 if ! grep '<category id="plc_monitor">' /etc/planetlab/default_config.xml ; then 
224     sed -i 's|<category id="plc_net">| <category id="plc_monitor">\n <name>Monitor Service Configuration</name>\n <description>Monitor</description>\n <variablelist>\n <variable id="enabled" type="boolean">\n <name>Enabled</name>\n <value>true</value>\n <description>Enable on this machine.</description>\n </variable>\n <variable id="email">\n <value></value>\n </variable>\n <variable id="dbpassword">\n <value></value>\n </variable>\n <variable id="host" type="hostname">\n <name>Hostname</name>\n <value>pl-virtual-06.cs.princeton.edu</value>\n <description>The fully qualified hostname.</description>\n </variable>\n <variable id="ip" type="ip">\n <name>IP Address</name>\n <value/>\n <description>The IP address of the monitor server.</description>\n </variable>\n </variablelist>\n </category>\n <category id="plc_net">|' /etc/planetlab/default_config.xml
225 fi
226
227
228 %post server
229 # TODO: this will be nice when we have a web-based service running., such as
230 #               an API server or so on.
231 # TODO: create real monitorconfig.py from monitorconfig-default.py
232 # TODO: create monitorconfig.php using phpconfig.py 
233 # TODO: create symlink in /var/lib/monitor for chroot environments
234 # TODO: update the content of automate_pl03.sh 
235 # TODO: Use the installed version of bootcd to create custom boot images. ( or, use the api now).
236
237 # NOTE: generate the python defines from zabbix include files.
238 #php /usr/share/%{name}/zabbix/getdefines.php > %{python_sitearch}/monitor/database/zabbixapi/defines.py
239
240 # apply patches to zabbix
241 #patch -d /var/www/html/zabbix/ -p0 < /usr/share/%{name}/zabbix/zabbix-auto-login.diff
242
243 #chkconfig --add monitor-server
244 #chkconfig monitor-server on
245
246 %post client
247 chkconfig --add monitor
248 chkconfig monitor on
249
250 %post runlevelagent
251 chkconfig --add monitor-runlevelagent
252 chkconfig monitor-runlevelagent on
253
254 %changelog
255 * Mon Jun 08 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-13
256 - remove plccache from controllers, all lookups from db.
257 - reformat emailTxt messags
258 - updated bootstates in bootman.py
259
260 * Tue Jun 02 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-12
261 - tag of latest changes.
262 - need to test end to end.
263
264 * Sat May 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - Monitor-3.0-11
265 - big merge from the 2.0 branch
266
267 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - Monitor-3.0-10
268 - minor improvements in rendering with sortable tables
269
270 * Tue May 19 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - Monitor-3.0-9
271
272 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - Monitor-3.0-8
273 - first draft with sortable tables + checkpoint
274
275 * Fri May 15 2009 Baris Metin <tmetin@sophia.inria.fr>
276 - use plekit tables from plewww.
277 - depend on plewww-plekit
278
279 * Tue May 12 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-7
280 - make docs a noop
281 - fix for package name dependency
282 - correct docs
283
284 * Mon May 04 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-6
285 - add improved docs to the latest build and tag.
286
287 * Mon May 04 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-5
288 - add documentation hooks for adding in-line docs like NM and PLCAPI
289
290 * Fri May 01 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-4
291 - Rough pass over monitor-3.0 to allow it to work with 4.3 API.
292 - replaced GetNodeNetworks, nodeinterface_ids and using new bootstates
293 - 'safeboot', 'failboot', 'reinstall', etc.
294
295 * Tue Apr 28 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-3
296 - same as 2.0-12 tag.
297
298 * Mon Apr 27 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-2
299 - merge from 2.0, remove more zabbix code, simplify install, etc.
300
301 * Thu Apr 16 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-1
302 - major merge from 2.0 branch.
303 - ready to be updated with 4.3 and web changes.
304
305 * Fri Feb 27 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-2.0-1
306 - preparing to make a 2.0 branch for monitor.
307
308 * Mon Jan 05 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-2.0-0
309 - new changes are significantly different, that I'm upping the number for clarity.
310
311 * Wed Sep 24 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-8
312 - These are all changes in the latest Monitor code.  I will branch this version
313 - next, before making additional large changes.
314
315 * Mon Sep 01 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - Monitor-1.0-7
316 - Checkpointing current version for 4.2-rc21 - many many changes
317
318 * Mon Aug 11 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-6
319 - This is a major tag of every thing.  probably needs a very different release
320 - number.
321
322 * Fri Jul 18 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-5
323 - Incremental improvements
324
325 * Mon May 19 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-4
326 - tagging everything for OneLab tech-transfer.
327
328
329 * Fri May 09 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-3
330
331
332 * Mon May 05 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-2
333
334
335 * Wed Apr 23 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-1
336 - This should be ready for 4.2rc2
337
338
339 * Mon Apr 07 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - monitor-1.0-0
340 - initial addition.
341
342 %define module_current_branch 2.0