typo
[monitor.git] / Monitor.spec
1 #
2 # $Id$
3
4
5 %define url $URL: svn+ssh://svn.planet-lab.org/svn/monitor/trunk/monitor.spec $
6
7 %define name monitor
8 %define version 3.0
9 %define taglevel 17
10
11 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
12 %global python_sitearch %( python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)" )
13
14 Name: %{name}
15 Version: %{version}
16 Release: %{release}
17 Source0: %{name}-%{version}.tar.bz2
18 License: GPL
19 Group: Applications/System
20 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
21
22 Vendor: PlanetLab
23 Packager: PlanetLab Central <support@planet-lab.org>
24 Distribution: PlanetLab %{plrelease}
25 URL: %(echo %{url} | cut -d ' ' -f 2)
26
27 Summary: Monitor account initialization for the root image.
28 Group: Applications/System
29
30 %description
31 Monitor is a collection of secondary scripts for configuring the node polling
32 system, syncing the PLC db with the monitoring database, notifying users,
33 interacting with PCU hardware, applying penalties to sites that violate
34 acceptable use.
35
36 ######################################## CLIENT
37
38 %package client
39 Summary: Monitor hooks for a PLC node
40 Group: Applications/System
41 Requires: curl
42 Requires: coreutils
43
44 %description client
45 The client scripts handle account creation inside of a node.  This will
46 include configuration setup for the monitoring agent running on the node.  It
47 will also include any cron or init scripts needed to perform this kind of
48 maintenance.
49 ######################################## Server Deps
50 %package server-deps
51 Summary: Monitor hooks for the PLC server.
52 Group: Applications/System
53
54 Requires: python
55 Requires: python-setuptools-devel
56 Requires: python-peak-util-extremes
57 Requires: TurboGears
58
59 Requires: compat-libstdc++-296
60 Requires: openssh-clients
61 Requires: perl-libwww-perl
62 Requires: perl-IO-Socket-SSL 
63 Requires: MySQL-python
64 Requires: nmap
65 Requires: rt3
66
67 Requires: plewww-plekit
68
69 #Requires: zabbix-client
70 #Requires: zabbix-gui
71 #Requires: zabbix-server
72
73 %description server-deps
74 The server side include all python modules and scripts needed to fully
75
76 ######################################## Server
77 %package server
78 Summary: Monitor hooks for the PLC server.
79 Group: Applications/System
80
81 Requires: python
82
83 Requires: monitor-server-deps
84 Requires: monitor-pcucontrol
85 Requires: PLCWWW >= 4.2
86 Requires: bootcd-%{pldistro}-%{_arch} >= 4.2
87
88 %description server
89 The server side include all python modules and scripts needed to fully
90 operation, track, and interact with any third-party monitoring software, such
91 as Zabbix DB.
92
93 ######################################## RT setup
94
95 %package rt
96 summary: Dependencies and default configuration for RT3
97 group: applications/system
98 Requires: monitor-server
99 Requires: rt3
100 Requires: rt3-mailgate
101
102 %description rt
103 RT3 is a ticket tracking system.  This RPM integrates RT into the MyOps
104 framework, and MyPLC in general.
105
106 ######################################## PCU Control
107
108 %package pcucontrol
109 summary: pcu controls for monitor and plcapi
110 group: applications/system
111 requires: python
112
113 %description pcucontrol
114 both monitor and the plcapi use a set of common commands to reboot machines
115 using their external or internal pcus.  this package is a library of several
116 supported models.
117
118 ####################################### RunlevelAgent
119 %package runlevelagent
120 summary: the RunlevelAgent that reports node runlevels
121 group: applications/system
122 requires: python
123
124 %description runlevelagent
125 The RunlevelAgent starts as early as possible during boot-up and production
126 mode to actively report the observed runlevel to PLC and update the
127 'last_contact' field.
128
129 %prep
130 %setup -q
131
132 %build
133 # NOTE: the build uses g++ cmdamt/
134 # NOTE: TMPDIR is needed here b/c the tmpfs of the build vserver is too small.
135 cd pcucontrol/models/intelamt
136 export TMPDIR=$PWD/tmp
137 make
138 cd ..
139
140 %install
141 rm -rf $RPM_BUILD_ROOT
142 #################### CLIENT 
143 install -D -m 755 monitor-client.init $RPM_BUILD_ROOT/%{_initrddir}/monitor
144 install -D -m 644 monitor.cron $RPM_BUILD_ROOT/%{_sysconfdir}/cron.d/monitor
145
146 #################### SERVER
147 install -d $RPM_BUILD_ROOT/usr/share/%{name}
148 install -d $RPM_BUILD_ROOT/data/var/lib/%{name}
149 install -d $RPM_BUILD_ROOT/data/var/lib/%{name}/archive-pdb
150 install -d $RPM_BUILD_ROOT/var/lib/%{name}
151 install -d $RPM_BUILD_ROOT/var/lib/%{name}/archive-pdb
152 install -d $RPM_BUILD_ROOT/var/www/cgi-bin/monitor/
153 install -d $RPM_BUILD_ROOT/var/www/html/monitorlog/
154
155 install -D -m 644 monitor.functions $RPM_BUILD_ROOT/%{_sysconfdir}/plc.d/monitor.functions
156 install -D -m 755 monitor-server.init $RPM_BUILD_ROOT/%{_sysconfdir}/plc.d/monitor
157 install -D -m 755 zabbix/monitor-zabbix.init $RPM_BUILD_ROOT/%{_sysconfdir}/plc.d/zabbix
158 install -D -m 755 rt3/monitor-rt3.init $RPM_BUILD_ROOT/%{_sysconfdir}/plc.d/rt3
159
160 echo " * Installing core scripts"
161 rsync -a --exclude www --exclude archive-pdb --exclude .svn --exclude CVS \
162           ./ $RPM_BUILD_ROOT/usr/share/%{name}/
163
164 echo " * Installing web pages"
165 rsync -a www/ $RPM_BUILD_ROOT/var/www/cgi-bin/monitor/
166 rsync -a log/ $RPM_BUILD_ROOT/var/www/html/monitorlog/
167
168 echo " * Installing cron job for automated polling"
169 install -D -m 644 monitor-server.cron $RPM_BUILD_ROOT/%{_sysconfdir}/cron.d/monitor-server.cron
170 echo " * TODO: Setting up Monitor account in local MyPLC"
171 # TODO: 
172
173 install -d $RPM_BUILD_ROOT/%{python_sitearch}/monitor
174 install -d -D -m 755 monitor $RPM_BUILD_ROOT/%{python_sitearch}/monitor
175 # TODO: need a much better way to do this.
176 rsync -a monitor/ $RPM_BUILD_ROOT/%{python_sitearch}/monitor/
177 #for file in __init__.py database.py config.py ; do 
178 #       install -D -m 644 monitor/$file $RPM_BUILD_ROOT/%{python_sitearch}/monitor/$file
179 #done
180 rsync -a pcucontrol/ $RPM_BUILD_ROOT/%{python_sitearch}/pcucontrol/
181 install -D -m 755 threadpool.py $RPM_BUILD_ROOT/%{python_sitearch}/threadpool.py
182
183 touch $RPM_BUILD_ROOT/var/www/cgi-bin/monitor/monitorconfig.php
184 chmod 777 $RPM_BUILD_ROOT/var/www/cgi-bin/monitor/monitorconfig.php
185
186 #install -D -m 755 monitor-default.conf $RPM_BUILD_ROOT/etc/monitor.conf
187 #cp $RPM_BUILD_ROOT/usr/share/%{name}/monitorconfig-default.py $RPM_BUILD_ROOT/usr/share/%{name}/monitorconfig.py
188
189 #################### RunlevelAgent
190 install -D -m 755 RunlevelAgent.py $RPM_BUILD_ROOT/usr/bin/RunlevelAgent.py
191 install -D -m 755 monitor-runlevelagent.init $RPM_BUILD_ROOT/%{_initrddir}/monitor-runlevelagent
192
193 mkdir -p $RPM_BUILD_ROOT/var/log
194 touch $RPM_BUILD_ROOT/var/log/server-deps.log
195
196
197 %clean
198 rm -rf $RPM_BUILD_ROOT
199
200 %files server-deps
201 /var/log/server-deps.log
202
203 %files server
204 %defattr(-,root,root)
205 #%config /usr/share/%{name}/monitorconfig.py
206 #%config /etc/monitor.conf
207 /usr/share/%{name}
208 /var/lib/%{name}
209 /var/www/cgi-bin/monitor
210 %{_sysconfdir}/cron.d/monitor-server.cron
211 %{python_sitearch}/threadpool.py
212 %{python_sitearch}/threadpool.pyc
213 %{python_sitearch}/threadpool.pyo
214 %{python_sitearch}/monitor
215 %{_sysconfdir}/plc.d/monitor
216
217 %files client
218 %defattr(-,root,root)
219 %{_initrddir}/monitor
220 %{_sysconfdir}/cron.d/monitor
221
222 %files rt 
223 %defattr(-,root,root)
224 /usr/share/%{name}/rt3
225
226 %files pcucontrol
227 %{python_sitearch}/pcucontrol
228
229 %files runlevelagent
230 /usr/bin/RunlevelAgent.py
231 /usr/bin/RunlevelAgent.pyo
232 /usr/bin/RunlevelAgent.pyc
233 /%{_initrddir}/monitor-runlevelagent
234
235 %post server-deps
236 #easy_install --build-directory /var/tmp -UZ ElementTree
237 ##easy_install --build-directory /var/tmp -UZ http://pypi.python.org/packages/2.5/E/Extremes/Extremes-1.1-py2.5.egg
238
239
240 ## TODO: something is bad wrong with this approach.
241 easy_install --build-directory /var/tmp -UZ http://files.turbogears.org/eggs/TurboGears-1.0.7-py2.5.egg
242 easy_install --build-directory /var/tmp -UZ http://pypi.python.org/packages/source/S/SQLAlchemy/SQLAlchemy-0.5.3.tar.gz
243 easy_install --build-directory /var/tmp -UZ Elixir
244
245 # crazy openssl libs for racadm binary
246 ln -s /lib/libssl.so.0.9.8b /usr/lib/libssl.so.2
247 mkdir /usr/share/monitor/.ssh
248 chmod 700 /usr/share/monitor/.ssh
249
250 if grep 'pam_loginuid.so' /etc/pam.d/crond ; then
251     sed -i -e 's/^session    required   pam_loginuid.so/#session    required   pam_loginuid.so/g' /etc/pam.d/crond
252 fi
253 # NOTE: add the default xml stuff if it's not already in the default xml config.
254 if ! grep '<category id="plc_monitor">' /etc/planetlab/default_config.xml ; then 
255     sed -i 's|<category id="plc_net">| <category id="plc_monitor">\n <name>Monitor Service Configuration</name>\n <description>Monitor</description>\n <variablelist>\n <variable id="enabled" type="boolean">\n <name>Enabled</name>\n <value>true</value>\n <description>Enable on this machine.</description>\n </variable>\n <variable id="email">\n <value></value>\n </variable>\n <variable id="dbpassword">\n <value></value>\n </variable>\n <variable id="host" type="hostname">\n <name>Hostname</name>\n <value>pl-virtual-06.cs.princeton.edu</value>\n <description>The fully qualified hostname.</description>\n </variable>\n <variable id="ip" type="ip">\n <name>IP Address</name>\n <value/>\n <description>The IP address of the monitor server.</description>\n </variable>\n </variablelist>\n </category>\n <category id="plc_net">|' /etc/planetlab/default_config.xml
256 fi
257
258 # NOTE: enable monitor by default, since we're installing it.
259 plc-config --save /etc/planetlab/default_config.xml \
260                         --category plc_monitor --variable enabled --value true
261
262 %post rt
263 plc-config --save /etc/planetlab/default_config.xml \
264                         --category plc_rt --variable enabled --value true
265
266 %post server
267 # TODO: this will be nice when we have a web-based service running., such as
268 #               an API server or so on.
269 # TODO: create real monitorconfig.py from monitorconfig-default.py
270 # TODO: create monitorconfig.php using phpconfig.py 
271 # TODO: create symlink in /var/lib/monitor for chroot environments
272 # TODO: update the content of automate_pl03.sh 
273 # TODO: Use the installed version of bootcd to create custom boot images. ( or, use the api now).
274
275 # NOTE: generate the python defines from zabbix include files.
276 #php /usr/share/%{name}/zabbix/getdefines.php > %{python_sitearch}/monitor/database/zabbixapi/defines.py
277
278 # apply patches to zabbix
279 #patch -d /var/www/html/zabbix/ -p0 < /usr/share/%{name}/zabbix/zabbix-auto-login.diff
280
281 #chkconfig --add monitor-server
282 #chkconfig monitor-server on
283
284 %post client
285 chkconfig --add monitor
286 chkconfig monitor on
287
288 %post runlevelagent
289 chkconfig --add monitor-runlevelagent
290 chkconfig monitor-runlevelagent on
291
292 %changelog
293 * Thu Jun 18 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-17
294 - added bootmanager log links
295 - addressed root cause of IntegrityErrors ; big deal
296 - adjusted templates to accomodate fix for IntegrityErrors
297 - added session.flush() to bootman.py to write out ActionsRecords
298 - fixed policy to either pause penalties or apply them ; not both.
299
300 -* Wed Jun 17 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-16
301 -- Added Rpyc from 1.0 branch.
302 -- add pcuhistory
303 -- add setup-agent for password protected keys.
304 -- other minor improvements.
305
306 * Wed Jun 17 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-15
307 - automate install
308 - auto-close tickets
309
310 * Fri Jun 12 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-14
311 - update web
312 - update policy
313 - added statistics dir
314
315 * Mon Jun 08 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-13
316 - remove plccache from controllers, all lookups from db.
317 - reformat emailTxt messags
318 - updated bootstates in bootman.py
319
320 * Tue Jun 02 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-12
321 - tag of latest changes.
322 - need to test end to end.
323
324 * Sat May 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - Monitor-3.0-11
325 - big merge from the 2.0 branch
326
327 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - Monitor-3.0-10
328 - minor improvements in rendering with sortable tables
329
330 * Tue May 19 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - Monitor-3.0-9
331
332 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - Monitor-3.0-8
333 - first draft with sortable tables + checkpoint
334
335 * Fri May 15 2009 Baris Metin <tmetin@sophia.inria.fr>
336 - use plekit tables from plewww.
337 - depend on plewww-plekit
338
339 * Tue May 12 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-7
340 - make docs a noop
341 - fix for package name dependency
342 - correct docs
343
344 * Mon May 04 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-6
345 - add improved docs to the latest build and tag.
346
347 * Mon May 04 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-5
348 - add documentation hooks for adding in-line docs like NM and PLCAPI
349
350 * Fri May 01 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-4
351 - Rough pass over monitor-3.0 to allow it to work with 4.3 API.
352 - replaced GetNodeNetworks, nodeinterface_ids and using new bootstates
353 - 'safeboot', 'failboot', 'reinstall', etc.
354
355 * Tue Apr 28 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-3
356 - same as 2.0-12 tag.
357
358 * Mon Apr 27 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-2
359 - merge from 2.0, remove more zabbix code, simplify install, etc.
360
361 * Thu Apr 16 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-1
362 - major merge from 2.0 branch.
363 - ready to be updated with 4.3 and web changes.
364
365 * Fri Feb 27 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-2.0-1
366 - preparing to make a 2.0 branch for monitor.
367
368 * Mon Jan 05 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-2.0-0
369 - new changes are significantly different, that I'm upping the number for clarity.
370
371 * Wed Sep 24 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-8
372 - These are all changes in the latest Monitor code.  I will branch this version
373 - next, before making additional large changes.
374
375 * Mon Sep 01 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - Monitor-1.0-7
376 - Checkpointing current version for 4.2-rc21 - many many changes
377
378 * Mon Aug 11 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-6
379 - This is a major tag of every thing.  probably needs a very different release
380 - number.
381
382 * Fri Jul 18 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-5
383 - Incremental improvements
384
385 * Mon May 19 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-4
386 - tagging everything for OneLab tech-transfer.
387
388
389 * Fri May 09 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-3
390
391
392 * Mon May 05 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-2
393
394
395 * Wed Apr 23 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-1
396 - This should be ready for 4.2rc2
397
398
399 * Mon Apr 07 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - monitor-1.0-0
400 - initial addition.
401
402 %define module_current_branch 2.0