add check to see if mysqld is running in init script
[monitor.git] / Monitor.spec
1 #
2 # $Id$
3
4
5 %define url $URL: svn+ssh://svn.planet-lab.org/svn/monitor/trunk/monitor.spec $
6
7 %define name monitor
8 # keep this version in sync with monitor/monitor_version.py
9 %define version 3.1
10 %define taglevel 0
11
12 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
13 %global python_sitearch %( python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)" )
14
15 Name: %{name}
16 Version: %{version}
17 Release: %{release}
18 Source0: %{name}-%{version}.tar.bz2
19 License: GPL
20 Group: Applications/System
21 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
22
23 Vendor: PlanetLab
24 Packager: PlanetLab Central <support@planet-lab.org>
25 Distribution: PlanetLab %{plrelease}
26 URL: %(echo %{url} | cut -d ' ' -f 2)
27
28
29 Summary: Monitor account initialization for the root image.
30 Group: Applications/System
31
32 %description
33 Monitor is a collection of secondary scripts for configuring the node polling
34 system, syncing the PLC db with the monitoring database, notifying users,
35 interacting with PCU hardware, applying penalties to sites that violate
36 acceptable use.
37
38 ######################################## NAGIOS
39
40 %package nagios
41 Summary: Monitor integration with Nagios
42 Group: Applications/System
43
44 Requires: coreutils
45 Requires: passwd
46 Requires: gd
47 Requires: gd-devel
48 Requires: mysql
49 Requires: mysql-server
50 Requires: mysql-devel
51 Requires: mysql-libs
52 Requires: mailx
53
54 Requires: nagios
55 Requires: nagios-common
56 Requires: nagios-devel
57 Requires: nagios-plugins-all
58 Requires: ndoutils
59 Requires: ndoutils-mysql
60
61
62 %description nagios
63 Scripts and setup necessary to integrate and monitor PLC with Nagios.
64 Best suited to F12 or above.
65
66 ######################################## CLIENT
67
68 %package client
69 Summary: Monitor hooks for a PLC node
70 Group: Applications/System
71 Requires: curl
72 Requires: coreutils
73
74 %description client
75 The client scripts handle account creation inside of a node.  This will
76 include configuration setup for the monitoring agent running on the node.  It
77 will also include any cron or init scripts needed to perform this kind of
78 maintenance.
79 ######################################## Server Deps
80 %package server-deps
81 Summary: Monitor hooks for the PLC server.
82 Group: Applications/System
83
84 Requires: python
85 Requires: python-setuptools-devel
86 Requires: python-peak-util-extremes
87
88 Requires: compat-libstdc++-296
89 Requires: openssh-clients
90 Requires: perl-libwww-perl
91 Requires: perl-IO-Socket-SSL 
92 Requires: MySQL-python
93 Requires: nmap
94 Requires: nc
95 Requires: rt3
96
97 Requires: plewww-plekit
98
99 #Requires: zabbix-client
100 #Requires: zabbix-gui
101 #Requires: zabbix-server
102
103 %description server-deps
104 The server side include all python modules and scripts needed to fully
105
106 ######################################## Server
107 %package server
108 Summary: Monitor hooks for the PLC server.
109 Group: Applications/System
110
111 Requires: python
112
113 Requires: monitor-server-deps
114 Requires: PLCWWW >= 4.2
115 Requires: bootcd-%{pldistro}-%{distroname}-%{_arch} >= 5.0
116 Requires: pcucontrol
117
118 %description server
119 The server side include all python modules and scripts needed to fully
120 operation, track, and interact with any third-party monitoring software, such
121 as Zabbix DB.
122
123 ####################################### RunlevelAgent
124 %package runlevelagent
125 summary: the RunlevelAgent that reports node runlevels
126 group: applications/system
127 requires: python
128
129 %description runlevelagent
130 The RunlevelAgent starts as early as possible during boot-up and production
131 mode to actively report the observed runlevel to PLC and update the
132 'last_contact' field.
133
134 %prep
135 %setup -q
136
137 %install
138 rm -rf $RPM_BUILD_ROOT
139 #################### CLIENT 
140 #install -D -m 755 monitor-client.init $RPM_BUILD_ROOT/%{_initrddir}/monitor
141 #install -D -m 644 monitor.cron $RPM_BUILD_ROOT/%{_sysconfdir}/cron.d/monitor
142 install -D -m 755 tools/timeout.pl $RPM_BUILD_ROOT/usr/bin/timeout.pl
143
144
145 #################### SERVER
146 install -d $RPM_BUILD_ROOT/usr/share/%{name}
147 install -d $RPM_BUILD_ROOT/data/var/lib/%{name}
148 install -d $RPM_BUILD_ROOT/data/var/lib/%{name}/archive-pdb
149 install -d $RPM_BUILD_ROOT/var/lib/%{name}
150 install -d $RPM_BUILD_ROOT/var/lib/%{name}/archive-pdb
151 install -d $RPM_BUILD_ROOT/var/www/html/monitorlog/
152 install -d $RPM_BUILD_ROOT/etc/httpd/conf.d/
153 install -d $RPM_BUILD_ROOT/%{python_sitearch}/monitor
154
155 # plc.d scripts
156 install -D -m 644 monitor.functions $RPM_BUILD_ROOT/%{_sysconfdir}/plc.d/monitor.functions
157 install -D -m 755 monitor-server.init $RPM_BUILD_ROOT/%{_sysconfdir}/plc.d/monitor
158 install -D -m 755 zabbix/monitor-zabbix.init $RPM_BUILD_ROOT/%{_sysconfdir}/plc.d/zabbix
159 install -D -m 755 nagios/monitor-nagios.init $RPM_BUILD_ROOT/%{_sysconfdir}/plc.d/monitor-nagios
160
161 # cron job for automated polling
162 install -D -m 644 monitor-server.cron $RPM_BUILD_ROOT/%{_sysconfdir}/cron.d/monitor-server.cron
163
164 # apache configuration
165 install -D -m 644 web/monitorweb-httpd.conf $RPM_BUILD_ROOT/etc/httpd/conf.d/
166
167 # we'll install monitor in site-packages install rest to
168 # /usr/share/monitor
169 rsync -a --exclude archive-pdb --exclude .cvsignore --exclude .svn --exclude CVS  \
170     --exclude monitor/ \
171     ./  $RPM_BUILD_ROOT/usr/share/%{name}/
172
173 # install monitor python package
174 rsync -a --exclude .svn  ./monitor/   $RPM_BUILD_ROOT/%{python_sitearch}/monitor/
175
176 # install third-party module to site-packages
177 install -D -m 755 threadpool.py $RPM_BUILD_ROOT/%{python_sitearch}/threadpool.py
178
179 # TODO: 
180 #touch $RPM_BUILD_ROOT/var/www/cgi-bin/monitor/monitorconfig.php
181 #chmod 777 $RPM_BUILD_ROOT/var/www/cgi-bin/monitor/monitorconfig.php
182
183 #install -D -m 755 monitor-default.conf $RPM_BUILD_ROOT/etc/monitor.conf
184 #cp $RPM_BUILD_ROOT/usr/share/%{name}/monitorconfig-default.py $RPM_BUILD_ROOT/usr/share/%{name}/monitorconfig.py
185
186 #################### RunlevelAgent
187 install -D -m 755 RunlevelAgent.py $RPM_BUILD_ROOT/usr/bin/RunlevelAgent.py
188 install -D -m 755 monitor-runlevelagent.init $RPM_BUILD_ROOT/%{_initrddir}/monitor-runlevelagent
189
190 mkdir -p $RPM_BUILD_ROOT/var/log
191 touch $RPM_BUILD_ROOT/var/log/server-deps.log
192
193
194 %clean
195 rm -rf $RPM_BUILD_ROOT
196
197 %files server-deps
198 /var/log/server-deps.log
199
200 %files nagios
201 %defattr(-,root,root)
202 %{_sysconfdir}/plc.d/monitor-nagios
203 /usr/share/%{name}/nagios 
204
205 %files server
206 %defattr(-,root,root)
207 #%config /usr/share/%{name}/monitorconfig.py
208 #%config /etc/monitor.conf
209 /var/lib/%{name}
210 /usr/share/%{name}/MANIFEST.in
211 /usr/share/%{name}/Makefile
212 /usr/share/%{name}/Monitor.spec
213 /usr/share/%{name}/README.txt
214 /usr/share/%{name}/RunlevelAgent.py*
215 /usr/share/%{name}/automate-default.sh
216 /usr/share/%{name}/monitor-default.conf
217 /usr/share/%{name}/monitor-runlevelagent.init
218 /usr/share/%{name}/monitor-server.cron
219 /usr/share/%{name}/monitor-server.init
220 /usr/share/%{name}/monitor.functions
221 /usr/share/%{name}/setup.py*
222 /usr/share/%{name}/threadpool.py*
223 /usr/share/%{name}/zabbix.spec
224
225 /usr/share/%{name}/bootcd
226 /usr/share/%{name}/commands
227 /usr/share/%{name}/config.d
228 /usr/share/%{name}/cron.d
229 /usr/share/%{name}/docs
230 /usr/share/%{name}/keys
231 /usr/share/%{name}/log
232 /usr/share/%{name}/statistics
233 /usr/share/%{name}/tests
234 /usr/share/%{name}/tools
235 /usr/share/%{name}/upgrade
236 /usr/share/%{name}/web
237 /usr/share/%{name}/zabbix
238
239 #/var/www/cgi-bin/monitor
240 %{_sysconfdir}/cron.d/monitor-server.cron
241 %{_sysconfdir}/plc.d/monitor
242 %{_sysconfdir}/plc.d/monitor.functions
243 %{_sysconfdir}/plc.d/zabbix
244 %{_sysconfdir}/httpd/conf.d
245 %{python_sitearch}
246
247
248 %files client
249 %defattr(-,root,root)
250 #%{_initrddir}/monitor
251 #%{_sysconfdir}/cron.d/monitor
252 /usr/bin/timeout.pl
253
254 %files runlevelagent
255 /usr/bin/RunlevelAgent.py*
256 /%{_initrddir}/monitor-runlevelagent
257
258
259 %post server-deps
260 #
261 # TODO: depend on distribution packages where feasible.
262 #
263 #  it would be better to be able to depend on the distribution's
264 # packages for these additional python modules, but packages provided
265 # by fedora 8 (our current deployment) doesn't match the version
266 # requirements.
267 export TMPDIR=/var/tmp/
268 easy_install -UZ http://files.turbogears.org/eggs/TurboGears-1.0.7-py2.5.egg
269 easy_install -UZ http://pypi.python.org/packages/source/S/SQLAlchemy/SQLAlchemy-0.5.3.tar.gz
270 easy_install -UZ Elixir
271
272 # crazy openssl libs for racadm binary
273 ln -s /lib/libssl.so.0.9.8b /usr/lib/libssl.so.2
274 mkdir %{_datadir}/%{name}/.ssh
275 chmod 700 %{_datadir}/%{name}/.ssh
276
277 if grep 'pam_loginuid.so' /etc/pam.d/crond ; then
278     sed -i -e 's/^session    required   pam_loginuid.so/#session    required   pam_loginuid.so/g' /etc/pam.d/crond
279 fi
280
281 # NOTE: enable monitor by default, since we're installing it.
282 if ! plc-config --category plc_monitor --variable enabled ; then 
283         plc-config --category plc_monitor --variable enabled --value true \
284                         --save /etc/planetlab/configs/site.xml  /etc/planetlab/configs/site.xml 
285 fi
286 if ! plc-config --category plc_monitor --variable from_email ; then
287         plc-config --category plc_monitor --variable from_email --value monitor@localhost.localdomain \
288                         --save /etc/planetlab/configs/site.xml /etc/planetlab/configs/site.xml 
289 fi
290 if ! plc-config --category plc_monitor --variable cc_email ; then
291         plc-config --category plc_monitor --variable cc_email --value monitor@localhost.localdomain \
292                         --save /etc/planetlab/configs/site.xml /etc/planetlab/configs/site.xml 
293 fi
294 if ! plc-config --category plc_monitor --variable rt_queue ; then
295         plc-config --category plc_monitor --variable rt_queue --value support \
296                         --save /etc/planetlab/configs/site.xml /etc/planetlab/configs/site.xml 
297 fi
298
299 # zabbix:
300 if ! plc-config --category plc_zabbix --variable enabled ; then
301         plc-config --category plc_zabbix --variable enabled --value false \
302                         --save /etc/planetlab/configs/site.xml /etc/planetlab/configs/site.xml 
303 fi
304 if ! plc-config --category plc_zabbix --variable host ; then
305         plc-config --category plc_zabbix --variable host --value localhost.localdomain \
306                         --save /etc/planetlab/configs/site.xml /etc/planetlab/configs/site.xml 
307 fi
308 if ! plc-config --category plc_zabbix --variable ip ; then
309         plc-config --category plc_zabbix --variable ip --value "" \ 
310                         --save /etc/planetlab/configs/site.xml /etc/planetlab/configs/site.xml 
311 fi
312
313 %post nagios
314 # TODO: do as much as possible to get the host setup and running.
315 #chkconfig --add monitor-nagios
316 #chkconfig monitor-nagios on
317 chkconfig mysqld on
318
319 %post server
320 # TODO: this will be nice when we have a web-based service running., such as
321 #               an API server or so on.
322 # TODO: create real monitorconfig.py from monitorconfig-default.py
323 # TODO: create symlink in /var/lib/monitor for chroot environments
324 # TODO: update the content of automate_pl03.sh 
325 # TODO: Use the installed version of bootcd to create custom boot images. ( or, use the api now).
326
327 # NOTE: generate the python defines from zabbix include files.
328 #php /usr/share/%{name}/zabbix/getdefines.php > %{python_sitearch}/monitor/database/zabbixapi/defines.py
329
330 # apply patches to zabbix
331 #patch -d /var/www/html/zabbix/ -p0 < /usr/share/%{name}/zabbix/zabbix-auto-login.diff
332
333 #chkconfig --add monitor-server
334 #chkconfig monitor-server on
335
336 %post client
337 chkconfig --add monitor
338 chkconfig monitor on
339
340 %post runlevelagent
341 chkconfig --add monitor-runlevelagent
342 chkconfig monitor-runlevelagent on
343 if [ "$PL_BOOTCD" != "1" ] ; then
344         service monitor-runlevelagent restart
345 fi
346
347
348 %changelog
349 * Thu May 20 2010 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-35
350 - Add CSV link on Advanced query
351 - Preparing to branch
352
353 * Wed May 12 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - Monitor-3.0-34
354 - * copy selections to clipbord on Advanced Query page
355 - * RPM Pattern as regexp
356 - * scan ipmi port
357
358 * Tue Apr 27 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - Monitor-3.0-33
359 - handle hostname changes
360
361 * Tue Apr 20 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - Monitor-3.0-32
362 - from this version, suitable for 5.0
363 - requires bootcd with the new 5.0 naming style 3-part nodefamily
364
365 * Mon Apr 12 2010 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-31
366 - added fix for node delete/add causing conflicts in MyOps db.
367 - added statistics scripts
368
369 * Thu Jan 21 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - Monitor-3.0-30
370 - * fix paths for automate script
371
372 * Tue Dec 22 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - Monitor-3.0-29
373 - - separate pcucontrol as an svn module
374 - - restore easy_instal back into post install stage of server-deps
375 - - template imporovements for web interface
376
377 * Thu Dec 17 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - Monitor-3.0-28
378 - do not need buildrequires. a new tag to fix centos builds
379
380 * Thu Dec 17 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - Monitor-3.0-27
381 - fix rpm build issues
382
383 * Wed Dec 16 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - Monitor-3.0-26
384 - to many changes, but mostly moved stuff around. there are some small fixes here and there.
385
386 * Fri Nov 20 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-25
387 - add option for site status to include both node & pcu status
388 - improve ticket handling
389 - template gadget.xml for a site-specific google-gadget summary
390
391 * Thu Oct 22 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - Monitor-3.0-24
392 - - add install_date
393
394 * Mon Oct 19 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - Monitor-3.0-23
395 - - remove monitor-client.cron
396 - - remove unused monitor-client init script
397 - - fix UP/DOWN summary on nodes page.
398 - - make node page display all nodes by default
399 - - add boot_server field
400 - - add myops_ssh_key to the keychain
401 - - use ext_consortium_id to distinguish pending sites.
402
403 * Fri Oct 09 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - Monitor-3.0-22
404 - show/hide advance query form.
405
406 * Thu Sep 24 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-21
407 - fixed pause_penalty bug.
408 - fixed IPAL pcucontrol bug
409 - fixed bootman tunnel setup bug (occurred in rare cases)
410 - deprecated pcuview
411 - added BootmanSequenceRecords to separate config data from source code
412 - added get/setBootmanSequence(s) to xmlrpc API
413
414 * Fri Sep 04 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-20
415 - Major Features:
416 - added bm log collection and optional integration with BootManager's log Upload()
417 - added iptables_status
418 - expanded advanced query
419 - added differentiated bootmanager_restore actions so that actionsummary displays
420 - counts for each kind of bootmanager action
421 - added pcuerror notices (for mis-configurations) in addition to pcufailed notices
422 - added plain-text options for query page by adding tg_format=plain to URL
423 - fixed cross-module reference that prevented pcucontrol for working with RebootNodeWithPCU() api call.
424 - fixed a bug in determining whether comon's dir was running on a node
425
426 * Mon Aug 17 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-19
427 - Major increment -
428 - adds multiple features and web changes
429 - adds new fields to db
430 - improved layout
431 - general improvements otherwise
432
433 * Sun Jun 28 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-18
434 - bug fixes.
435 - improved templates and views
436 - cleaned controller code for web
437 - added IPMI requirement to pcucontrol package.
438
439 * Thu Jun 18 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-17
440 - added bootmanager log links
441 - addressed root cause of IntegrityErrors ; big deal
442 - adjusted templates to accomodate fix for IntegrityErrors
443 - added session.flush() to bootman.py to write out ActionsRecords
444 - fixed policy to either pause penalties or apply them ; not both.
445
446 -* Wed Jun 17 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-16
447 -- Added Rpyc from 1.0 branch.
448 -- add pcuhistory
449 -- add setup-agent for password protected keys.
450 -- other minor improvements.
451
452 * Wed Jun 17 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-15
453 - automate install
454 - auto-close tickets
455
456 * Fri Jun 12 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-14
457 - update web
458 - update policy
459 - added statistics dir
460
461 * Mon Jun 08 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-13
462 - remove plccache from controllers, all lookups from db.
463 - reformat emailTxt messags
464 - updated bootstates in bootman.py
465
466 * Tue Jun 02 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-12
467 - tag of latest changes.
468 - need to test end to end.
469
470 * Sat May 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - Monitor-3.0-11
471 - big merge from the 2.0 branch
472
473 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - Monitor-3.0-10
474 - minor improvements in rendering with sortable tables
475
476 * Tue May 19 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - Monitor-3.0-9
477
478 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - Monitor-3.0-8
479 - first draft with sortable tables + checkpoint
480
481 * Fri May 15 2009 Baris Metin <tmetin@sophia.inria.fr>
482 - use plekit tables from plewww.
483 - depend on plewww-plekit
484
485 * Tue May 12 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-7
486 - make docs a noop
487 - fix for package name dependency
488 - correct docs
489
490 * Mon May 04 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-6
491 - add improved docs to the latest build and tag.
492
493 * Mon May 04 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-5
494 - add documentation hooks for adding in-line docs like NM and PLCAPI
495
496 * Fri May 01 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-4
497 - Rough pass over monitor-3.0 to allow it to work with 4.3 API.
498 - replaced GetNodeNetworks, nodeinterface_ids and using new bootstates
499 - 'safeboot', 'failboot', 'reinstall', etc.
500
501 * Tue Apr 28 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-3
502 - same as 2.0-12 tag.
503
504 * Mon Apr 27 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-2
505 - merge from 2.0, remove more zabbix code, simplify install, etc.
506
507 * Thu Apr 16 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-1
508 - major merge from 2.0 branch.
509 - ready to be updated with 4.3 and web changes.
510
511 * Fri Feb 27 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-2.0-1
512 - preparing to make a 2.0 branch for monitor.
513
514 * Mon Jan 05 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-2.0-0
515 - new changes are significantly different, that I'm upping the number for clarity.
516
517 * Wed Sep 24 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-8
518 - These are all changes in the latest Monitor code.  I will branch this version
519 - next, before making additional large changes.
520
521 * Mon Sep 01 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - Monitor-1.0-7
522 - Checkpointing current version for 4.2-rc21 - many many changes
523
524 * Mon Aug 11 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-6
525 - This is a major tag of every thing.  probably needs a very different release
526 - number.
527
528 * Fri Jul 18 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-5
529 - Incremental improvements
530
531 * Mon May 19 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-4
532 - tagging everything for OneLab tech-transfer.
533
534
535 * Fri May 09 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-3
536
537
538 * Mon May 05 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-2
539
540
541 * Wed Apr 23 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-1
542 - This should be ready for 4.2rc2
543
544
545 * Mon Apr 07 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - monitor-1.0-0
546 - initial addition.
547
548 %define module_current_branch 3.0