Merge branch 'master' of ssh://git.planet-lab.org/git/monitor
[monitor.git] / Monitor.spec
1 #
2 # $Id$
3
4
5 %define url $URL: svn+ssh://svn.planet-lab.org/svn/monitor/trunk/monitor.spec $
6
7 %define name monitor
8 # keep this version in sync with monitor/monitor_version.py
9 %define version 3.1
10 %define taglevel 6
11
12 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
13 %global python_sitearch %( python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)" )
14
15 Name: %{name}
16 Version: %{version}
17 Release: %{release}
18 Source0: %{name}-%{version}.tar.bz2
19 License: GPL
20 Group: Applications/System
21 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
22
23 Vendor: PlanetLab
24 Packager: PlanetLab Central <support@planet-lab.org>
25 Distribution: PlanetLab %{plrelease}
26 URL: %(echo %{url} | cut -d ' ' -f 2)
27
28
29 Summary: Monitor account initialization for the root image.
30 Group: Applications/System
31
32 %description
33 Monitor is a collection of secondary scripts for configuring the node polling
34 system, syncing the PLC db with the monitoring database, notifying users,
35 interacting with PCU hardware, applying penalties to sites that violate
36 acceptable use.
37
38 ######################################## NAGIOS
39
40 %package nagios
41 Summary: Monitor integration with Nagios
42 Group: Applications/System
43
44 Requires: coreutils
45 Requires: passwd
46 Requires: gd
47 Requires: gd-devel
48 Requires: mysql
49 Requires: mysql-server
50 Requires: mysql-devel
51 Requires: mysql-libs
52 Requires: mailx
53 Requires: sendmail
54 Requires: php
55 Requires: httpd
56
57 Requires: cronie
58 Requires: nagios
59 Requires: nagios-common
60 Requires: nagios-devel
61 Requires: nagios-plugins-all
62 Requires: ndoutils
63 Requires: ndoutils-mysql
64
65 Requires: rt3
66
67
68 %description nagios
69 Scripts and setup necessary to integrate and monitor PLC with Nagios.
70 Best suited to F12 or above.
71
72 ######################################## CLIENT
73
74 %package client
75 Summary: Monitor hooks for a PLC node
76 Group: Applications/System
77 Requires: curl
78 Requires: coreutils
79
80 %description client
81 The client scripts handle account creation inside of a node.  This will
82 include configuration setup for the monitoring agent running on the node.  It
83 will also include any cron or init scripts needed to perform this kind of
84 maintenance.
85 ######################################## Server Deps
86 %package server-deps
87 Summary: Monitor hooks for the PLC server.
88 Group: Applications/System
89
90 Requires: python
91 Requires: python-setuptools-devel
92 Requires: python-peak-util-extremes
93
94 Requires: compat-libstdc++-296
95 Requires: openssh-clients
96 Requires: perl-libwww-perl
97 Requires: perl-IO-Socket-SSL 
98 Requires: MySQL-python
99 Requires: perl-DBD-mysql
100 Requires: nmap
101 Requires: mailx
102 Requires: nc
103 Requires: rt3
104 Requires: traceroute
105 Requires: sendmail
106 # 5.0-18 is when the extra monitor plc-config values were added to myplc default_config.xml
107 Requires: myplc >= 5.0-18
108
109 Requires: plewww-plekit
110 Requires: pcucontrol
111 Requires: TurboGears
112
113 #Requires: zabbix-client
114 #Requires: zabbix-gui
115 #Requires: zabbix-server
116
117 %description server-deps
118 The server side include all python modules and scripts needed to fully
119
120 ######################################## Server
121 %package server
122 Summary: Monitor hooks for the PLC server.
123 Group: Applications/System
124
125 Requires: python
126 Requires: monitor-server-deps
127
128 # NOTE: removed b/c 'distroname' gets corrupted during build process.
129 # Requires: bootcd-%{pldistro}-%{distroname}-%{_arch} >= 5.0
130
131 %description server
132 The server side include all python modules and scripts needed to fully
133 operation, track, and interact with any third-party monitoring software, such
134 as Zabbix DB.
135
136 ######################################## RunlevelAgent
137 %package runlevelagent
138 summary: the RunlevelAgent that reports node runlevels
139 group: applications/system
140 requires: python
141
142 %description runlevelagent
143 The RunlevelAgent starts as early as possible during boot-up and production
144 mode to actively report the observed runlevel to PLC and update the
145 'last_contact' field.
146
147 %prep
148 %setup -q
149
150 %install
151 rm -rf $RPM_BUILD_ROOT
152 #################### CLIENT 
153 #install -D -m 755 monitor-client.init $RPM_BUILD_ROOT/%{_initrddir}/monitor
154 #install -D -m 644 monitor.cron $RPM_BUILD_ROOT/%{_sysconfdir}/cron.d/monitor
155 install -D -m 755 tools/timeout.pl $RPM_BUILD_ROOT/usr/bin/timeout.pl
156
157
158 #################### SERVER
159 install -d $RPM_BUILD_ROOT/usr/share/%{name}
160 install -d $RPM_BUILD_ROOT/data/var/lib/%{name}
161 install -d $RPM_BUILD_ROOT/data/var/lib/%{name}/archive-pdb
162 install -d $RPM_BUILD_ROOT/var/lib/%{name}
163 install -d $RPM_BUILD_ROOT/var/lib/%{name}/archive-pdb
164 install -d $RPM_BUILD_ROOT/var/www/html/monitorlog/
165 install -d $RPM_BUILD_ROOT/etc/httpd/conf.d/
166 install -d $RPM_BUILD_ROOT/%{python_sitearch}/monitor
167
168 # plc.d scripts
169 install -D -m 644 monitor.functions $RPM_BUILD_ROOT/%{_sysconfdir}/plc.d/monitor.functions
170 install -D -m 755 monitor-server.init $RPM_BUILD_ROOT/%{_sysconfdir}/plc.d/monitor
171 #install -D -m 755 zabbix/monitor-zabbix.init $RPM_BUILD_ROOT/%{_sysconfdir}/plc.d/zabbix
172
173 install -D -m 755 nagios/monitor-nagios.init $RPM_BUILD_ROOT/%{_sysconfdir}/plc.d/monitor-nagios
174 install -D -m 644 nagios/monitor-nagios.cron $RPM_BUILD_ROOT/%{_sysconfdir}/cron.d/monitor-nagios.cron
175
176 # cron job for automated polling
177 install -D -m 644 monitor-server.cron $RPM_BUILD_ROOT/%{_sysconfdir}/cron.d/monitor-server.cron
178
179 # apache configuration
180 install -D -m 644 web/monitorweb.conf $RPM_BUILD_ROOT/etc/httpd/conf.d/
181
182 # we'll install monitor in site-packages install rest to
183 # /usr/share/monitor
184 rsync -a --exclude archive-pdb --exclude .cvsignore --exclude .svn --exclude CVS  \
185     --exclude monitor/ \
186     ./  $RPM_BUILD_ROOT/usr/share/%{name}/
187
188 #rm -f $RPM_BUILD_ROOT/usr/share/%{name}/zabbix.spec
189
190 # install monitor python package
191 rsync -a --exclude .svn  ./monitor/   $RPM_BUILD_ROOT/%{python_sitearch}/monitor/
192
193 install -D -m 644 monitor/wrapper/plc.py $RPM_BUILD_ROOT/usr/share/%{name}/nagios/
194 install -D -m 644 monitor/generic.py $RPM_BUILD_ROOT/usr/share/%{name}/nagios/
195
196 # install third-party module to site-packages
197 install -D -m 755 threadpool.py $RPM_BUILD_ROOT/%{python_sitearch}/threadpool.py
198
199 # TODO: 
200 #touch $RPM_BUILD_ROOT/var/www/cgi-bin/monitor/monitorconfig.php
201 #chmod 777 $RPM_BUILD_ROOT/var/www/cgi-bin/monitor/monitorconfig.php
202
203 #install -D -m 755 monitor-default.conf $RPM_BUILD_ROOT/etc/monitor.conf
204 #cp $RPM_BUILD_ROOT/usr/share/%{name}/monitorconfig-default.py $RPM_BUILD_ROOT/usr/share/%{name}/monitorconfig.py
205
206 #################### RunlevelAgent
207 install -D -m 755 RunlevelAgent.py $RPM_BUILD_ROOT/usr/bin/RunlevelAgent.py
208 install -D -m 755 monitor-runlevelagent.init $RPM_BUILD_ROOT/%{_initrddir}/monitor-runlevelagent
209
210 mkdir -p $RPM_BUILD_ROOT/var/log
211 touch $RPM_BUILD_ROOT/var/log/server-deps.log
212
213
214 %clean
215 rm -rf $RPM_BUILD_ROOT
216
217 %files server-deps
218 /var/log/server-deps.log
219
220 %files nagios
221 %defattr(-,root,root)
222 %{_sysconfdir}/plc.d/monitor-nagios
223 /usr/share/%{name}/nagios 
224 %{_sysconfdir}/cron.d/monitor-nagios.cron
225
226 %files server
227 %defattr(-,root,root)
228 #%config /usr/share/%{name}/monitorconfig.py
229 #%config /etc/monitor.conf
230 /var/lib/%{name}
231 /usr/share/%{name}/MANIFEST.in
232 /usr/share/%{name}/Makefile
233 /usr/share/%{name}/Monitor.spec
234 /usr/share/%{name}/README.txt
235 /usr/share/%{name}/RunlevelAgent.py*
236 /usr/share/%{name}/automate-default.sh
237 /usr/share/%{name}/monitor-default.conf
238 /usr/share/%{name}/monitor-runlevelagent.init
239 /usr/share/%{name}/monitor-server.cron
240 /usr/share/%{name}/monitor-server.init
241 /usr/share/%{name}/monitor.functions
242 /usr/share/%{name}/setup.py*
243 /usr/share/%{name}/threadpool.py*
244 /usr/share/%{name}/zabbix.spec
245
246 /usr/share/%{name}/bootcd
247 /usr/share/%{name}/commands
248 /usr/share/%{name}/config.d
249 #/usr/share/%{name}/cron.d
250 /usr/share/%{name}/docs
251 /usr/share/%{name}/histlog
252 /usr/share/%{name}/keys
253 #/usr/share/%{name}/log
254 /usr/share/%{name}/statistics
255 /usr/share/%{name}/tests
256 /usr/share/%{name}/tools
257 /usr/share/%{name}/upgrade
258 /usr/share/%{name}/web
259 /usr/share/%{name}/zabbix
260
261 #/var/www/cgi-bin/monitor
262 %{_sysconfdir}/cron.d/monitor-server.cron
263 %{_sysconfdir}/plc.d/monitor
264 %{_sysconfdir}/plc.d/monitor.functions
265 #%{_sysconfdir}/plc.d/zabbix
266 %{_sysconfdir}/httpd/conf.d
267 %{python_sitearch}
268
269
270 %files client
271 %defattr(-,root,root)
272 #%{_initrddir}/monitor
273 #%{_sysconfdir}/cron.d/monitor
274 /usr/bin/timeout.pl
275
276 %files runlevelagent
277 /usr/bin/RunlevelAgent.py*
278 /%{_initrddir}/monitor-runlevelagent
279
280 %post server-deps
281 #
282 # TODO: depend on distribution packages where feasible.
283 #
284 #  it would be better to be able to depend on the distribution's
285 # packages for these additional python modules, but packages provided
286 # by fedora 8 (our current deployment) doesn't match the version
287 # requirements.
288 export TMPDIR=/var/tmp/
289 #easy_install -UZ http://files.turbogears.org/eggs/TurboGears-1.0.7-py2.5.egg
290 #easy_install -UZ http://pypi.python.org/packages/source/S/SQLAlchemy/SQLAlchemy-0.5.3.tar.gz
291 #easy_install -UZ Elixir
292 chkconfig sendmail on
293 chkconfig crond on
294
295 # crazy openssl libs for racadm binary
296 ln -s /lib/libssl.so.0.9.8b /usr/lib/libssl.so.2
297 mkdir %{_datadir}/%{name}/.ssh
298 chmod 700 %{_datadir}/%{name}/.ssh
299
300 if grep 'pam_loginuid.so' /etc/pam.d/crond ; then
301     sed -i -e 's/^session    required   pam_loginuid.so/#session    required   pam_loginuid.so/g' /etc/pam.d/crond
302 fi
303
304 # NOTE: enable monitor by default, since we're installing it.
305 if ! plc-config --category plc_monitor --variable enabled ; then 
306         plc-config --category plc_monitor --variable enabled --value true \
307                         --save /etc/planetlab/configs/site.xml  /etc/planetlab/configs/site.xml 
308 fi
309 if ! plc-config --category plc_monitor --variable from_email ; then
310         plc-config --category plc_monitor --variable from_email --value monitor@localhost.localdomain \
311                         --save /etc/planetlab/configs/site.xml /etc/planetlab/configs/site.xml 
312 fi
313 if ! plc-config --category plc_monitor --variable cc_email ; then
314         plc-config --category plc_monitor --variable cc_email --value monitor@localhost.localdomain \
315                         --save /etc/planetlab/configs/site.xml /etc/planetlab/configs/site.xml 
316 fi
317 if ! plc-config --category plc_monitor --variable rt_queue ; then
318         plc-config --category plc_monitor --variable rt_queue --value support \
319                         --save /etc/planetlab/configs/site.xml /etc/planetlab/configs/site.xml 
320 fi
321
322 %post nagios
323 # TODO: do as much as possible to get the host setup and running.
324 #chkconfig --add monitor-nagios
325 #chkconfig monitor-nagios on
326 chkconfig mysqld on
327
328 %post server
329 # TODO: this will be nice when we have a web-based service running., such as
330 #               an API server or so on.
331 # TODO: create real monitorconfig.py from monitorconfig-default.py
332 # TODO: create symlink in /var/lib/monitor for chroot environments
333 # TODO: update the content of automate_pl03.sh 
334 # TODO: Use the installed version of bootcd to create custom boot images. ( or, use the api now).
335
336 # NOTE: generate the python defines from zabbix include files.
337 #php /usr/share/%{name}/zabbix/getdefines.php > %{python_sitearch}/monitor/database/zabbixapi/defines.py
338
339 # apply patches to zabbix
340 #patch -d /var/www/html/zabbix/ -p0 < /usr/share/%{name}/zabbix/zabbix-auto-login.diff
341
342 #chkconfig --add monitor-server
343 #chkconfig monitor-server on
344
345 %post client
346 chkconfig --add monitor
347 chkconfig monitor on
348
349 %post runlevelagent
350 if [ -f /etc/planetlab/node_id ] ; then
351     chkconfig --add monitor-runlevelagent
352     chkconfig monitor-runlevelagent on
353     if [ "$PL_BOOTCD" != "1" ] ; then
354         service monitor-runlevelagent restart
355     fi
356 fi
357
358
359 %changelog
360 * Wed Aug 31 2011 Stephen Soltesz <soltesz@cs.princeton.edu> - monitor-3.1-6
361 - Minor updates to work with pcucontrol.
362 - Added action for some fprobe no-space errors.
363
364 * Wed Aug 31 2011 Stephen Soltesz <soltesz@cs.princeton.edu> - monitor-3.1-5
365 - account for new ok status type in PCUs
366 - include a percentage of nodes up as well as raw node-count
367
368 * Fri May 27 2011 s s <soltesz@cs.princeton.edu> - monitor-3.1-4
369 - Fixes to spec file for monitor building
370
371 * Fri May 27 2011 s s <soltesz@cs.princeton.edu> - monitor-3.1-3
372 - fixing syntax errors
373
374 * Fri May 27 2011 s s <soltesz@cs.princeton.edu> - monitor-3.1-2
375 - Add better requirements list, work with TurboGears packaged by fedora,
376 - Remove some zabbix files
377 - Add a controllers_local.py for custom extensions
378
379 * Fri May 06 2011 s s <soltesz@cs.princeton.edu> - monitor-3.1-1
380 - last tag before some more major changes
381
382 * Thu May 20 2010 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-35
383 - Add CSV link on Advanced query
384 - Preparing to branch
385
386 * Wed May 12 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - Monitor-3.0-34
387 - * copy selections to clipbord on Advanced Query page
388 - * RPM Pattern as regexp
389 - * scan ipmi port
390
391 * Tue Apr 27 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - Monitor-3.0-33
392 - handle hostname changes
393
394 * Tue Apr 20 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - Monitor-3.0-32
395 - from this version, suitable for 5.0
396 - requires bootcd with the new 5.0 naming style 3-part nodefamily
397
398 * Mon Apr 12 2010 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-31
399 - added fix for node delete/add causing conflicts in MyOps db.
400 - added statistics scripts
401
402 * Thu Jan 21 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - Monitor-3.0-30
403 - * fix paths for automate script
404
405 * Tue Dec 22 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - Monitor-3.0-29
406 - - separate pcucontrol as an svn module
407 - - restore easy_instal back into post install stage of server-deps
408 - - template imporovements for web interface
409
410 * Thu Dec 17 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - Monitor-3.0-28
411 - do not need buildrequires. a new tag to fix centos builds
412
413 * Thu Dec 17 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - Monitor-3.0-27
414 - fix rpm build issues
415
416 * Wed Dec 16 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - Monitor-3.0-26
417 - to many changes, but mostly moved stuff around. there are some small fixes here and there.
418
419 * Fri Nov 20 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-25
420 - add option for site status to include both node & pcu status
421 - improve ticket handling
422 - template gadget.xml for a site-specific google-gadget summary
423
424 * Thu Oct 22 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - Monitor-3.0-24
425 - - add install_date
426
427 * Mon Oct 19 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - Monitor-3.0-23
428 - - remove monitor-client.cron
429 - - remove unused monitor-client init script
430 - - fix UP/DOWN summary on nodes page.
431 - - make node page display all nodes by default
432 - - add boot_server field
433 - - add myops_ssh_key to the keychain
434 - - use ext_consortium_id to distinguish pending sites.
435
436 * Fri Oct 09 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - Monitor-3.0-22
437 - show/hide advance query form.
438
439 * Thu Sep 24 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-21
440 - fixed pause_penalty bug.
441 - fixed IPAL pcucontrol bug
442 - fixed bootman tunnel setup bug (occurred in rare cases)
443 - deprecated pcuview
444 - added BootmanSequenceRecords to separate config data from source code
445 - added get/setBootmanSequence(s) to xmlrpc API
446
447 * Fri Sep 04 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-20
448 - Major Features:
449 - added bm log collection and optional integration with BootManager's log Upload()
450 - added iptables_status
451 - expanded advanced query
452 - added differentiated bootmanager_restore actions so that actionsummary displays
453 - counts for each kind of bootmanager action
454 - added pcuerror notices (for mis-configurations) in addition to pcufailed notices
455 - added plain-text options for query page by adding tg_format=plain to URL
456 - fixed cross-module reference that prevented pcucontrol for working with RebootNodeWithPCU() api call.
457 - fixed a bug in determining whether comon's dir was running on a node
458
459 * Mon Aug 17 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-19
460 - Major increment -
461 - adds multiple features and web changes
462 - adds new fields to db
463 - improved layout
464 - general improvements otherwise
465
466 * Sun Jun 28 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-18
467 - bug fixes.
468 - improved templates and views
469 - cleaned controller code for web
470 - added IPMI requirement to pcucontrol package.
471
472 * Thu Jun 18 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-17
473 - added bootmanager log links
474 - addressed root cause of IntegrityErrors ; big deal
475 - adjusted templates to accomodate fix for IntegrityErrors
476 - added session.flush() to bootman.py to write out ActionsRecords
477 - fixed policy to either pause penalties or apply them ; not both.
478
479 -* Wed Jun 17 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-16
480 -- Added Rpyc from 1.0 branch.
481 -- add pcuhistory
482 -- add setup-agent for password protected keys.
483 -- other minor improvements.
484
485 * Wed Jun 17 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-15
486 - automate install
487 - auto-close tickets
488
489 * Fri Jun 12 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-14
490 - update web
491 - update policy
492 - added statistics dir
493
494 * Mon Jun 08 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-13
495 - remove plccache from controllers, all lookups from db.
496 - reformat emailTxt messags
497 - updated bootstates in bootman.py
498
499 * Tue Jun 02 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-12
500 - tag of latest changes.
501 - need to test end to end.
502
503 * Sat May 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - Monitor-3.0-11
504 - big merge from the 2.0 branch
505
506 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - Monitor-3.0-10
507 - minor improvements in rendering with sortable tables
508
509 * Tue May 19 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - Monitor-3.0-9
510
511 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - Monitor-3.0-8
512 - first draft with sortable tables + checkpoint
513
514 * Fri May 15 2009 Baris Metin <tmetin@sophia.inria.fr>
515 - use plekit tables from plewww.
516 - depend on plewww-plekit
517
518 * Tue May 12 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-7
519 - make docs a noop
520 - fix for package name dependency
521 - correct docs
522
523 * Mon May 04 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-6
524 - add improved docs to the latest build and tag.
525
526 * Mon May 04 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-5
527 - add documentation hooks for adding in-line docs like NM and PLCAPI
528
529 * Fri May 01 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-4
530 - Rough pass over monitor-3.0 to allow it to work with 4.3 API.
531 - replaced GetNodeNetworks, nodeinterface_ids and using new bootstates
532 - 'safeboot', 'failboot', 'reinstall', etc.
533
534 * Tue Apr 28 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-3
535 - same as 2.0-12 tag.
536
537 * Mon Apr 27 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-2
538 - merge from 2.0, remove more zabbix code, simplify install, etc.
539
540 * Thu Apr 16 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-1
541 - major merge from 2.0 branch.
542 - ready to be updated with 4.3 and web changes.
543
544 * Fri Feb 27 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-2.0-1
545 - preparing to make a 2.0 branch for monitor.
546
547 * Mon Jan 05 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-2.0-0
548 - new changes are significantly different, that I'm upping the number for clarity.
549
550 * Wed Sep 24 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-8
551 - These are all changes in the latest Monitor code.  I will branch this version
552 - next, before making additional large changes.
553
554 * Mon Sep 01 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - Monitor-1.0-7
555 - Checkpointing current version for 4.2-rc21 - many many changes
556
557 * Mon Aug 11 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-6
558 - This is a major tag of every thing.  probably needs a very different release
559 - number.
560
561 * Fri Jul 18 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-5
562 - Incremental improvements
563
564 * Mon May 19 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-4
565 - tagging everything for OneLab tech-transfer.
566
567
568 * Fri May 09 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-3
569
570
571 * Mon May 05 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-2
572
573
574 * Wed Apr 23 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-1
575 - This should be ready for 4.2rc2
576
577
578 * Mon Apr 07 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - monitor-1.0-0
579 - initial addition.
580
581 %define module_current_branch 3.0