Many small updates and fixes:
[monitor.git] / Monitor.spec
index 511a50d..32ecb44 100644 (file)
@@ -62,6 +62,8 @@ Requires: nagios-plugins-all
 Requires: ndoutils
 Requires: ndoutils-mysql
 
+Requires: rt3
+
 
 %description nagios
 Scripts and setup necessary to integrate and monitor PLC with Nagios.
@@ -348,10 +350,12 @@ chkconfig --add monitor
 chkconfig monitor on
 
 %post runlevelagent
-chkconfig --add monitor-runlevelagent
-chkconfig monitor-runlevelagent on
-if [ "$PL_BOOTCD" != "1" ] ; then
-       service monitor-runlevelagent restart
+if [ -f /etc/planetlab/node_id ] ; then
+    chkconfig --add monitor-runlevelagent
+    chkconfig monitor-runlevelagent on
+    if [ "$PL_BOOTCD" != "1" ] ; then
+        service monitor-runlevelagent restart
+    fi
 fi