merged pcucontrol into monitor-server. although monitor-pcucontrol may
[monitor.git] / Monitor.spec
index 694a701..61a2ca7 100644 (file)
@@ -7,7 +7,7 @@
 %define name monitor
 # keep this version in sync with monitor/monitor_version.py
 %define version 3.0
-%define taglevel 26
+%define taglevel 28
 
 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
 %global python_sitearch        %( python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)" )
@@ -25,7 +25,9 @@ Packager: PlanetLab Central <support@planet-lab.org>
 Distribution: PlanetLab %{plrelease}
 URL: %(echo %{url} | cut -d ' ' -f 2)
 
-BuildRequires: python-setuptools-devel
+# this is only required for fedora and we have this in devel.pkgs for
+# all fedora builds.
+# BuildRequires: python-setuptools-devel
 
 
 Summary: Monitor account initialization for the root image.
@@ -84,7 +86,6 @@ Group: Applications/System
 Requires: python
 
 Requires: monitor-server-deps
-Requires: monitor-pcucontrol
 Requires: PLCWWW >= 4.2
 Requires: bootcd-%{pldistro}-%{_arch} >= 4.2
 
@@ -93,19 +94,6 @@ The server side include all python modules and scripts needed to fully
 operation, track, and interact with any third-party monitoring software, such
 as Zabbix DB.
 
-######################################## PCU Control
-
-%package pcucontrol
-summary: pcu controls for monitor and plcapi
-group: applications/system
-requires: python
-requires: OpenIPMI-tools
-
-%description pcucontrol
-both monitor and the plcapi use a set of common commands to reboot machines
-using their external or internal pcus.  this package is a library of several
-supported models.
-
 ####################################### RunlevelAgent
 %package runlevelagent
 summary: the RunlevelAgent that reports node runlevels
@@ -147,10 +135,11 @@ install -d $RPM_BUILD_ROOT/etc/httpd/conf.d/
 install -d $RPM_BUILD_ROOT/%{python_sitearch}/monitor
 
 # pack monitor's dependencies in RPM to make it easier to deploy.
+export TMPDIR=/var/tmp/
 export PYTHONPATH=$PYTHONPATH:$RPM_BUILD_ROOT/%{python_sitearch}/
-easy_install --build-directory /var/tmp -d $RPM_BUILD_ROOT/%{python_sitearch}/ -UZ http://files.turbogears.org/eggs/TurboGears-1.0.7-py2.5.egg
-easy_install --build-directory /var/tmp -d $RPM_BUILD_ROOT/%{python_sitearch}/ -UZ http://pypi.python.org/packages/source/S/SQLAlchemy/SQLAlchemy-0.5.3.tar.gz
-easy_install --build-directory /var/tmp -d $RPM_BUILD_ROOT/%{python_sitearch}/ -UZ Elixir
+easy_install -d $RPM_BUILD_ROOT/%{python_sitearch}/ -UZ http://files.turbogears.org/eggs/TurboGears-1.0.7-py2.5.egg
+easy_install -d $RPM_BUILD_ROOT/%{python_sitearch}/ -UZ http://pypi.python.org/packages/source/S/SQLAlchemy/SQLAlchemy-0.5.3.tar.gz
+easy_install -d $RPM_BUILD_ROOT/%{python_sitearch}/ -UZ Elixir
 rm -rf $RPM_BUILD_ROOT/%{python_sitearch}/site.py*
 
 # plc.d scripts
@@ -211,19 +200,11 @@ rm -rf $RPM_BUILD_ROOT
 /var/lib/%{name}
 #/var/www/cgi-bin/monitor
 %{_sysconfdir}/cron.d/monitor-server.cron
-%{python_sitearch}/threadpool.py
-%{python_sitearch}/threadpool.pyc
-%{python_sitearch}/threadpool.pyo
-%{python_sitearch}/monitor
-%{python_sitearch}/Turbo*
-%{python_sitearch}/SQLAlchemy*
-%{python_sitearch}/Elixir*
-%{python_sitearch}/easy-install.pth
-%{python_sitearch}/tg-admin
 %{_sysconfdir}/plc.d/monitor
 %{_sysconfdir}/plc.d/monitor.functions
 %{_sysconfdir}/plc.d/zabbix
 %{_sysconfdir}/httpd/conf.d
+%{python_sitearch}
 
 %files client
 %defattr(-,root,root)
@@ -231,13 +212,8 @@ rm -rf $RPM_BUILD_ROOT
 #%{_sysconfdir}/cron.d/monitor
 /usr/bin/timeout.pl
 
-%files pcucontrol
-%{python_sitearch}/pcucontrol
-
 %files runlevelagent
-/usr/bin/RunlevelAgent.py
-/usr/bin/RunlevelAgent.pyo
-/usr/bin/RunlevelAgent.pyc
+/usr/bin/RunlevelAgent.py*
 /%{_initrddir}/monitor-runlevelagent
 
 %post server-deps
@@ -313,6 +289,12 @@ fi
 
 
 %changelog
+* Thu Dec 17 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - Monitor-3.0-28
+- do not need buildrequires. a new tag to fix centos builds
+
+* Thu Dec 17 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - Monitor-3.0-27
+- fix rpm build issues
+
 * Wed Dec 16 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - Monitor-3.0-26
 - to many changes, but mostly moved stuff around. there are some small fixes here and there.