clearer names for actions, and infer actions better
[monitor.git] / Monitor.spec
index 01415ad..64a9211 100644 (file)
@@ -7,7 +7,7 @@
 %define name monitor
 # keep this version in sync with monitor/monitor_version.py
 %define version 3.1
-%define taglevel 3
+%define taglevel 6
 
 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
 %global python_sitearch        %( python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)" )
@@ -185,6 +185,8 @@ rsync -a --exclude archive-pdb --exclude .cvsignore --exclude .svn --exclude CVS
     --exclude monitor/ \
     ./  $RPM_BUILD_ROOT/usr/share/%{name}/
 
+#rm -f $RPM_BUILD_ROOT/usr/share/%{name}/zabbix.spec
+
 # install monitor python package
 rsync -a --exclude .svn  ./monitor/   $RPM_BUILD_ROOT/%{python_sitearch}/monitor/
 
@@ -233,20 +235,22 @@ rm -rf $RPM_BUILD_ROOT
 /usr/share/%{name}/RunlevelAgent.py*
 /usr/share/%{name}/automate-default.sh
 /usr/share/%{name}/monitor-default.conf
+/usr/share/%{name}/monitor-runlevelagent.init
 /usr/share/%{name}/monitor-server.cron
 /usr/share/%{name}/monitor-server.init
 /usr/share/%{name}/monitor.functions
 /usr/share/%{name}/setup.py*
 /usr/share/%{name}/threadpool.py*
-#/usr/share/%{name}/zabbix.spec
+/usr/share/%{name}/zabbix.spec
 
 /usr/share/%{name}/bootcd
 /usr/share/%{name}/commands
 /usr/share/%{name}/config.d
-/usr/share/%{name}/cron.d
+#/usr/share/%{name}/cron.d
 /usr/share/%{name}/docs
+/usr/share/%{name}/histlog
 /usr/share/%{name}/keys
-/usr/share/%{name}/log
+#/usr/share/%{name}/log
 /usr/share/%{name}/statistics
 /usr/share/%{name}/tests
 /usr/share/%{name}/tools
@@ -273,7 +277,6 @@ rm -rf $RPM_BUILD_ROOT
 /usr/bin/RunlevelAgent.py*
 /%{_initrddir}/monitor-runlevelagent
 
-
 %post server-deps
 #
 # TODO: depend on distribution packages where feasible.
@@ -354,6 +357,17 @@ fi
 
 
 %changelog
+* Wed Aug 31 2011 Stephen Soltesz <soltesz@cs.princeton.edu> - monitor-3.1-6
+- Minor updates to work with pcucontrol.
+- Added action for some fprobe no-space errors.
+
+* Wed Aug 31 2011 Stephen Soltesz <soltesz@cs.princeton.edu> - monitor-3.1-5
+- account for new ok status type in PCUs
+- include a percentage of nodes up as well as raw node-count
+
+* Fri May 27 2011 s s <soltesz@cs.princeton.edu> - monitor-3.1-4
+- Fixes to spec file for monitor building
+
 * Fri May 27 2011 s s <soltesz@cs.princeton.edu> - monitor-3.1-3
 - fixing syntax errors