show/hide advance query form.
[monitor.git] / Monitor.spec
index f8986d9..cc90984 100644 (file)
@@ -6,7 +6,7 @@
 
 %define name monitor
 %define version 3.0
-%define taglevel 18
+%define taglevel 22
 
 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
 %global python_sitearch        %( python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)" )
@@ -62,6 +62,7 @@ Requires: perl-libwww-perl
 Requires: perl-IO-Socket-SSL 
 Requires: MySQL-python
 Requires: nmap
+Requires: nc
 Requires: rt3
 
 Requires: plewww-plekit
@@ -240,34 +241,36 @@ if grep 'pam_loginuid.so' /etc/pam.d/crond ; then
 fi
 
 # NOTE: enable monitor by default, since we're installing it.
-plc-config --save /etc/planetlab/configs/site.xml \
-                       --category plc_monitor --variable enabled --value true
-plc-config --save /etc/planetlab/configs/site.xml \
-                       --category plc_monitor --variable from_email --value monitor@localhost.localdomain
-plc-config --save /etc/planetlab/configs/site.xml \
-                       --category plc_monitor --variable cc_email --value monitor@localhost.localdomain
-plc-config --save /etc/planetlab/configs/site.xml \
-                       --category plc_monitor --variable rt_queue --value support
-
-# NOTE: setup default values until myplc includes them by default.
-plc-config --save /etc/planetlab/configs/site.xml \
-                       --category plc_rt --variable enabled --value false
-plc-config --save /etc/planetlab/configs/site.xml \
-                       --category plc_rt --variable host --value localhost.localdomain
-plc-config --save /etc/planetlab/configs/site.xml \
-                       --category plc_rt --variable ip --value ""
-plc-config --save /etc/planetlab/configs/site.xml \
-                       --category plc_rt --variable web_user --value root
-plc-config --save /etc/planetlab/configs/site.xml \
-                       --category plc_rt --variable web_password --value password
+if ! plc-config --category plc_monitor --variable enabled ; then 
+       plc-config --category plc_monitor --variable enabled --value true \
+                       --save /etc/planetlab/configs/site.xml  /etc/planetlab/configs/site.xml 
+fi
+if ! plc-config --category plc_monitor --variable from_email ; then
+       plc-config --category plc_monitor --variable from_email --value monitor@localhost.localdomain \
+                       --save /etc/planetlab/configs/site.xml /etc/planetlab/configs/site.xml 
+fi
+if ! plc-config --category plc_monitor --variable cc_email ; then
+       plc-config --category plc_monitor --variable cc_email --value monitor@localhost.localdomain \
+                       --save /etc/planetlab/configs/site.xml /etc/planetlab/configs/site.xml 
+fi
+if ! plc-config --category plc_monitor --variable rt_queue ; then
+       plc-config --category plc_monitor --variable rt_queue --value support \
+                       --save /etc/planetlab/configs/site.xml /etc/planetlab/configs/site.xml 
+fi
 
 # zabbix:
-plc-config --save /etc/planetlab/configs/site.xml \
-                       --category plc_zabbix --variable enabled --value false
-plc-config --save /etc/planetlab/configs/site.xml \
-                       --category plc_zabbix --variable host --value localhost.localdomain
-plc-config --save /etc/planetlab/configs/site.xml \
-                       --category plc_zabbix --variable ip --value ""
+if ! plc-config --category plc_zabbix --variable enabled ; then
+       plc-config --category plc_zabbix --variable enabled --value false \
+                       --save /etc/planetlab/configs/site.xml /etc/planetlab/configs/site.xml 
+fi
+if ! plc-config --category plc_zabbix --variable host ; then
+       plc-config --category plc_zabbix --variable host --value localhost.localdomain \
+                       --save /etc/planetlab/configs/site.xml /etc/planetlab/configs/site.xml 
+fi
+if ! plc-config --category plc_zabbix --variable ip ; then
+       plc-config --category plc_zabbix --variable ip --value "" \ 
+                       --save /etc/planetlab/configs/site.xml /etc/planetlab/configs/site.xml 
+fi
 
 %post server
 # TODO: this will be nice when we have a web-based service running., such as
@@ -300,6 +303,36 @@ fi
 
 
 %changelog
+* Fri Oct 09 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - Monitor-3.0-22
+- show/hide advance query form.
+
+* Thu Sep 24 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-21
+- fixed pause_penalty bug.
+- fixed IPAL pcucontrol bug
+- fixed bootman tunnel setup bug (occurred in rare cases)
+- deprecated pcuview
+- added BootmanSequenceRecords to separate config data from source code
+- added get/setBootmanSequence(s) to xmlrpc API
+
+* Fri Sep 04 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-20
+- Major Features:
+- added bm log collection and optional integration with BootManager's log Upload()
+- added iptables_status
+- expanded advanced query
+- added differentiated bootmanager_restore actions so that actionsummary displays
+- counts for each kind of bootmanager action
+- added pcuerror notices (for mis-configurations) in addition to pcufailed notices
+- added plain-text options for query page by adding tg_format=plain to URL
+- fixed cross-module reference that prevented pcucontrol for working with RebootNodeWithPCU() api call.
+- fixed a bug in determining whether comon's dir was running on a node
+
+* Mon Aug 17 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-19
+- Major increment -
+- adds multiple features and web changes
+- adds new fields to db
+- improved layout
+- general improvements otherwise
+
 * Sun Jun 28 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-18
 - bug fixes.
 - improved templates and views