setuptools don't really care about --build-directory.
[monitor.git] / Monitor.spec
index 4a75f72..f9068c4 100644 (file)
@@ -7,7 +7,7 @@
 %define name monitor
 # keep this version in sync with monitor/monitor_version.py
 %define version 3.0
-%define taglevel 25
+%define taglevel 26
 
 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
 %global python_sitearch        %( python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)" )
@@ -147,10 +147,11 @@ install -d $RPM_BUILD_ROOT/etc/httpd/conf.d/
 install -d $RPM_BUILD_ROOT/%{python_sitearch}/monitor
 
 # pack monitor's dependencies in RPM to make it easier to deploy.
+export TMPDIR=/var/tmp/
 export PYTHONPATH=$PYTHONPATH:$RPM_BUILD_ROOT/%{python_sitearch}/
-easy_install --build-directory /var/tmp -d $RPM_BUILD_ROOT/%{python_sitearch}/ -UZ http://files.turbogears.org/eggs/TurboGears-1.0.7-py2.5.egg
-easy_install --build-directory /var/tmp -d $RPM_BUILD_ROOT/%{python_sitearch}/ -UZ http://pypi.python.org/packages/source/S/SQLAlchemy/SQLAlchemy-0.5.3.tar.gz
-easy_install --build-directory /var/tmp -d $RPM_BUILD_ROOT/%{python_sitearch}/ -UZ Elixir
+easy_install -d $RPM_BUILD_ROOT/%{python_sitearch}/ -UZ http://files.turbogears.org/eggs/TurboGears-1.0.7-py2.5.egg
+easy_install -d $RPM_BUILD_ROOT/%{python_sitearch}/ -UZ http://pypi.python.org/packages/source/S/SQLAlchemy/SQLAlchemy-0.5.3.tar.gz
+easy_install -d $RPM_BUILD_ROOT/%{python_sitearch}/ -UZ Elixir
 rm -rf $RPM_BUILD_ROOT/%{python_sitearch}/site.py*
 
 # plc.d scripts
@@ -211,13 +212,9 @@ rm -rf $RPM_BUILD_ROOT
 /var/lib/%{name}
 #/var/www/cgi-bin/monitor
 %{_sysconfdir}/cron.d/monitor-server.cron
-%{python_sitearch}/threadpool.py
-%{python_sitearch}/threadpool.pyc
-%{python_sitearch}/threadpool.pyo
+%{python_sitearch}/threadpool.py*
 %{python_sitearch}/monitor
-%{python_sitearch}/Turbo*
-%{python_sitearch}/SQLAlchemy*
-%{python_sitearch}/Elixir*
+%{python_sitearch}/*.egg/
 %{python_sitearch}/easy-install.pth
 %{python_sitearch}/tg-admin
 %{_sysconfdir}/plc.d/monitor
@@ -313,6 +310,9 @@ fi
 
 
 %changelog
+* Wed Dec 16 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - Monitor-3.0-26
+- to many changes, but mostly moved stuff around. there are some small fixes here and there.
+
 * Fri Nov 20 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-3.0-25
 - add option for site status to include both node & pcu status
 - improve ticket handling