changes for 3.0
[monitor.git] / monitor-server.spec
index 8316ffd..757715b 100644 (file)
@@ -2,11 +2,11 @@
 # $Id$
 # 
 
-%define url $URL: svn+ssh://svn.planet-lab.org/svn/Monitor/trunk/Monitor-server.spec $
+%define url $URL: svn+ssh://svn.planet-lab.org/svn/Monitor/trunk/monitor-server.spec $
 
 %define name monitor-server
 %define version 1.0
-%define taglevel 6
+%define taglevel 16
 
 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
 %global python_sitearch        %( python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)" )
@@ -30,6 +30,7 @@ Requires: curl
 Requires: coreutils
 Requires: openssh-clients
 Requires: perl-libwww-perl
+Requires: perl-IO-Socket-SSL 
 Requires: MySQL-python
 Requires: rt3 == 3.4.1
 Requires: nmap
@@ -55,6 +56,8 @@ cd ..
 
 rm -rf $RPM_BUILD_ROOT
 mkdir -p $RPM_BUILD_ROOT/usr/share/%{name}
+mkdir -p $RPM_BUILD_ROOT/data/var/lib/%{name}
+mkdir -p $RPM_BUILD_ROOT/data/var/lib/%{name}/archive-pdb
 mkdir -p $RPM_BUILD_ROOT/var/lib/%{name}
 mkdir -p $RPM_BUILD_ROOT/var/lib/%{name}/archive-pdb
 mkdir -p $RPM_BUILD_ROOT/var/www/cgi-bin/monitor/
@@ -67,7 +70,7 @@ echo " * Installing web pages"
 rsync -a www/ $RPM_BUILD_ROOT/var/www/cgi-bin/monitor/
 
 echo " * Installing cron job for automated polling"
-install -D -m 755 %{name}.cron $RPM_BUILD_ROOT/%{_sysconfdir}/cron.d/%{name}.cron
+install -D -m 644 %{name}.cron $RPM_BUILD_ROOT/%{_sysconfdir}/cron.d/%{name}.cron
 echo " * TODO: Setting up Monitor account in local MyPLC"
 # TODO: 
 
@@ -115,6 +118,44 @@ echo "Post processing"
 #chkconfig monitor-server on
 
 %changelog
+* Mon Apr 13 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-16
+- add email exceptions.
+- add better timeouts for commands even once ssh has opened a connection
+
+* Thu Feb 26 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-15
+- fixed bug that prevented penalties from escalating and PIs from getting
+- emails.
+
+* Fri Feb 20 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-14
+- updated printbadnodes.py to include diff_time()
+- changed eamils to use literal addresses not tech-* and pi-* aliases
+- updates to automation script to prevent false errors.
+
+* Tue Nov 04 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-13
+- Fixed for email change in unified_model.py tweaks in others.
+
+* Wed Oct 29 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-12
+- Improvements in web pages, and default installation options, and RT queue
+- setup.
+- Send direct emails rather than using tech- & pi- aliases
+
+* Tue Oct 21 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-11
+- send direct email, not to tech-* and pi-* aliases.
+
+* Tue Oct 14 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-10
+- an update to the latest tag.  looks like I actually needed to update the tags
+- file more than this.
+
+* Thu Sep 25 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-9
+- includes all removals of 'monitorconfig'
+
+* Wed Sep 24 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-8
+- These are all changes in the latest Monitor code.  I will branch this version
+- next, before making additional large changes.
+
+* Mon Sep 01 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - Monitor-1.0-7
+- Checkpointing current version for 4.2-rc21 - many many changes
+
 * Mon Aug 11 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-1.0-6
 - This is a major tag of every thing.  probably needs a very different release
 - number.