www/printbadnodes.py
[monitor.git] / monitor-server.spec
index 8669e71..e6b5fac 100644 (file)
@@ -9,6 +9,8 @@
 %define taglevel 6
 
 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
+%global python_sitearch        %( python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)" )
+
 
 Summary: Monitor backend scripts for server
 Name: %{name}
@@ -27,9 +29,12 @@ URL: %(echo %{url} | cut -d ' ' -f 2)
 Requires: curl
 Requires: coreutils
 Requires: openssh-clients
+Requires: perl-libwww-perl
+Requires: MySQL-python
+Requires: rt3 == 3.4.1
+
 Requires: PLCWWW >= 4.2
 Requires: BootCD >= 4.2
-Requires: MySQL-python
 
 %description
 Scripts for polling PLC, the node, and PCU status.  Also a collection of
@@ -40,7 +45,10 @@ command-line utilities for querying the status database.
 
 %build
 # TODO: note that we should build the cmdamt/ with g++
-echo "There is no build stage.  Simply copy files."
+cd cmdamt
+export TMPDIR=$PWD/tmp
+make
+cd ..
 
 %install
 
@@ -62,6 +70,11 @@ install -D -m 755 %{name}.cron $RPM_BUILD_ROOT/%{_sysconfdir}/cron.d/%{name}.cro
 echo " * TODO: Setting up Monitor account in local MyPLC"
 # TODO: 
 
+mkdir -p $RPM_BUILD_ROOT/%{python_sitearch}/%{name}
+install -D -m 755 monitor $RPM_BUILD_ROOT/%{python_sitearch}/%{name}
+install -D -m 755 threadpool.py $RPM_BUILD_ROOT/%{python_sitearch}/threadpool.py
+
+install -D -m 755 monitor-default.conf $RPM_BUILD_ROOT/etc/monitor.conf
 cp $RPM_BUILD_ROOT/usr/share/%{name}/monitorconfig-default.py $RPM_BUILD_ROOT/usr/share/%{name}/monitorconfig.py
 
 %clean
@@ -74,6 +87,8 @@ rm -rf $RPM_BUILD_ROOT
 /var/lib/%{name}
 /var/www/cgi-bin/monitor
 %{_sysconfdir}/cron.d/%{name}.cron
+%{python_sitearch}/threadpool.py
+%{python_sitearch}/%{name}
 
 %post
 echo "Post processing"