work around the lack of libm.a on f12
[monitor.git] / zabbix.spec
index 20c6532..f99d40e 100644 (file)
@@ -78,7 +78,12 @@ mkdir server
 cp -r client/* server
 
 pushd client
+# quick and dirty fix for f12; loader would fail b/c of the lack of /lib/libm.a
+%if "%{distro}" == "Fedora" && %{distrorelease} >= 12
+./configure --enable-agent
+%else
 ./configure --enable-static --enable-agent
+%endif
 make
 popd