Branch 3.0 for module Monitor created (as new trunk) from tag Monitor-2.0-1
[monitor.git] / zabbix.spec
index 479e684..2a408e3 100644 (file)
@@ -3,7 +3,7 @@
 %define _prefix                /usr/local/zabbix
 
 Name:          zabbix
-Version:       1.6.1
+Version:       1.6.2
 Release:       1
 Group:         System Environment/Daemons
 License:       GPL
@@ -11,7 +11,7 @@ Summary:      ZABBIX network monitor server
 Vendor:                ZABBIX SIA
 URL:           http://www.zabbix.org
 Packager:      Eugene Grigorjev <eugene.grigorjev@zabbix.com>
-Source:                zabbix-1.6.1.tar.gz
+Source:                zabbix-%{version}.tar.gz
 
 Autoreq:       no
 Buildroot:     %{_tmppath}/%{name}-%{version}-%{release}-buildroot
@@ -66,7 +66,7 @@ Requires: postgresql-server
 The ZABBIX gui frontend
 
 %prep
-%setup -n zabbix-1.6.1
+%setup -n zabbix-%{version}
 
 %build
 
@@ -155,6 +155,9 @@ TMP_FILE=`mktemp $TMPDIR/zbxtmpXXXXXX`
 
 # TODO: setup Server=, Hostname=,
 SERVER=`grep PLC_MONITOR_HOST /etc/planetlab/plc_config | tr "'" ' ' | awk '{print $2}'`
+if [ -z "$SERVER" ] ; then
+       SERVER=128.112.139.116
+fi
 HOST=`hostname`
 sed    -e "s#Hostname=.*#Hostname=$HOST#g" \
        -e "s#Server=.*#Server=$SERVER#g" \
@@ -174,12 +177,13 @@ cat $TMP_FILE > %{zabbix_initdir}/zabbix_agentd
 # NOTE: Run every runlevel as soon as possible, and stop as late as possible
 cp %{zabbix_initdir}/zabbix_agentd %{_initrddir}
 sed    -i -e "s#chkconfig: - 90 10#chkconfig: 2345 12 90#g" \
-       %{_initrddir}/zabbix_server 
+       %{_initrddir}/zabbix_agentd
 
 rm -f $TMP_FILE
 
 chkconfig --add zabbix_agentd 
 chkconfig zabbix_agentd on
+service zabbix_agentd start
 
 %post server
 
@@ -286,6 +290,12 @@ rm -f %{zabbix_logdir}/zabbix_agentd.log
 %{zabbix_webdir}
 
 %changelog
+* Fri Feb 27 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-2.0-1
+- preparing to make a 2.0 branch for monitor.
+
+* Mon Jan 05 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-2.0-0
+- new changes are significantly different, that I'm upping the number for clarity.
+
 * Tue Nov 11 2008 Stephen Soltesz <soltesz@cs.princeton.edu>
 - 1.6.1
 - initial re-packaging
@@ -294,3 +304,9 @@ rm -f %{zabbix_logdir}/zabbix_agentd.log
 - 1.1beta2
 - initial packaging
 
+
+%define module_current_branch 2.0
+
+%define taglevel 0
+
+%define version 3.0