svn merge -r 12308:13112 https://svn.planet-lab.org/svn/Monitor/branches/2.0/
[monitor.git] / zabbix.spec
index e32fcff..3a91d20 100644 (file)
@@ -3,7 +3,7 @@
 %define _prefix                /usr/local/zabbix
 
 Name:          zabbix
-Version:       1.6.1
+Version:       1.6.2
 Release:       1
 Group:         System Environment/Daemons
 License:       GPL
@@ -11,7 +11,7 @@ Summary:      ZABBIX network monitor server
 Vendor:                ZABBIX SIA
 URL:           http://www.zabbix.org
 Packager:      Eugene Grigorjev <eugene.grigorjev@zabbix.com>
-Source:                zabbix-1.6.1.tar.gz
+Source:                zabbix-%{version}.tar.gz
 
 Autoreq:       no
 Buildroot:     %{_tmppath}/%{name}-%{version}-%{release}-buildroot
@@ -66,7 +66,7 @@ Requires: postgresql-server
 The ZABBIX gui frontend
 
 %prep
-%setup -n zabbix-1.6.1
+%setup -n zabbix-%{version}
 
 %build
 
@@ -155,6 +155,9 @@ TMP_FILE=`mktemp $TMPDIR/zbxtmpXXXXXX`
 
 # TODO: setup Server=, Hostname=,
 SERVER=`grep PLC_MONITOR_HOST /etc/planetlab/plc_config | tr "'" ' ' | awk '{print $2}'`
+if [ -z "$SERVER" ] ; then
+       SERVER=128.112.139.116
+fi
 HOST=`hostname`
 sed    -e "s#Hostname=.*#Hostname=$HOST#g" \
        -e "s#Server=.*#Server=$SERVER#g" \
@@ -180,6 +183,7 @@ rm -f $TMP_FILE
 
 chkconfig --add zabbix_agentd 
 chkconfig zabbix_agentd on
+service zabbix_agentd start
 
 %post server
 
@@ -286,6 +290,49 @@ rm -f %{zabbix_logdir}/zabbix_agentd.log
 %{zabbix_webdir}
 
 %changelog
+* Fri Apr 03 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-2.0-9
+- added new models to db.
+- major updates throughout.
+- better unification. needs an install test.
+
+* Wed Apr 01 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-2.0-8
+- removed old pkl database references.
+- added blacklist to db model
+- added fix to IntelAMT remoteControl to start an power-down node
+- added policy.py
+- added global error count before bailing entirely.
+
+* Fri Mar 27 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-2.0-7
+- improved db model
+- updated files that use db model
+- updated web view based on node, site, and pcu states.
+- added local mirror to zabbix Make file.
+
+* Tue Mar 24 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-2.0-6
+- added action view to gui
+- added penalty_applied bit to db model.
+
+* Fri Mar 20 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-2.0-5
+- tag for updates to 2.0 db model
+
+* Fri Mar 13 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-2.0-4
+- splits reboot.py across pcucontrol and monitor modules
+- moves command.py from monitor/util to pcucontrol/util
+
+* Tue Mar 10 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-2.0-3
+- add email exceptions
+- other bug fixes.
+
+* Tue Mar 10 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-2.0-2
+- getting the pcucontrol and findall.py scripts to work in an integrated
+- fashion.
+
+* Fri Feb 27 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-2.0-1
+- preparing to make a 2.0 branch for monitor.
+
+* Mon Jan 05 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-2.0-0
+- new changes are significantly different, that I'm upping the number for clarity.
+
 * Tue Nov 11 2008 Stephen Soltesz <soltesz@cs.princeton.edu>
 - 1.6.1
 - initial re-packaging
@@ -294,3 +341,9 @@ rm -f %{zabbix_logdir}/zabbix_agentd.log
 - 1.1beta2
 - initial packaging
 
+
+%define module_current_branch 2.0
+
+%define taglevel 0
+
+%define version 3.0