fixes to the monitor-server.init to update the password if any of serveral
[monitor.git] / zabbix.spec
index 665f3f2..3f2e548 100644 (file)
@@ -195,6 +195,7 @@ TMP_FILE=`mktemp $TMPDIR/zbxtmpXXXXXX`
 sed    -e "s#AlertScriptsPath=/home/zabbix/bin/#AlertScriptsPath=%{zabbix_bindir}/#g" \
        -e "s#PidFile=/var/tmp/zabbix_server.pid#PidFile=%{zabbix_piddir}/zabbix_server.pid#g" \
        -e "s#LogFile=/tmp/zabbix_server.log#LogFile=%{zabbix_logdir}/zabbix_server.log#g" \
+       -e "s|#DBPassword|DBPassword|g" \
        %{zabbix_confdir}/zabbix_server.conf > $TMP_FILE
 cat $TMP_FILE > %{zabbix_confdir}/zabbix_server.conf
 mkdir -p %{_sysconfdir}/zabbix
@@ -221,7 +222,7 @@ chkconfig zabbix_server on
 # 
 
 TMP_FILE=`mktemp $TMPDIR/zbxtmpXXXXXX`
-sed    -e "s#;date.timezone =#date.timezone = 'UTC'#g" \
+sed    -e "s#;date.timezone =#date.timezone = UTC#g" \
        -e "s#max_execution_time = 30 #max_execution_time = 300 #g" \
        %{_sysconfdir}/php.ini > $TMP_FILE
 cat $TMP_FILE > %{_sysconfdir}/php.ini