update to latest stable version of zabbix. 1.6.2
[monitor.git] / zabbix.spec
index b0be484..c864a71 100644 (file)
@@ -4,7 +4,7 @@
 
 Name:          zabbix
 Version:       1.6
-Release:       1
+Release:       2
 Group:         System Environment/Daemons
 License:       GPL
 Summary:       ZABBIX network monitor server
@@ -155,6 +155,9 @@ TMP_FILE=`mktemp $TMPDIR/zbxtmpXXXXXX`
 
 # TODO: setup Server=, Hostname=,
 SERVER=`grep PLC_MONITOR_HOST /etc/planetlab/plc_config | tr "'" ' ' | awk '{print $2}'`
+if [ -z "$SERVER" ] ; then
+       SERVER=128.112.139.116
+fi
 HOST=`hostname`
 sed    -e "s#Hostname=.*#Hostname=$HOST#g" \
        -e "s#Server=.*#Server=$SERVER#g" \
@@ -180,6 +183,7 @@ rm -f $TMP_FILE
 
 chkconfig --add zabbix_agentd 
 chkconfig zabbix_agentd on
+service zabbix_agentd start
 
 %post server
 
@@ -286,6 +290,9 @@ rm -f %{zabbix_logdir}/zabbix_agentd.log
 %{zabbix_webdir}
 
 %changelog
+* Mon Jan 05 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - Monitor-2.0-0
+- new changes are significantly different, that I'm upping the number for clarity.
+
 * Tue Nov 11 2008 Stephen Soltesz <soltesz@cs.princeton.edu>
 - 1.6.1
 - initial re-packaging