ManageUser: Admin edit's user details
[myslice.git] / myslice.spec
index bae532e..97b121b 100644 (file)
@@ -1,6 +1,12 @@
+# NOTE
+# in real-life we use a debian packaging, so this fedora packaging is very rough
+# it turns out we need to have one specfile for the PL build..
+# in any case the contents here should be more carefully split
+# into several components pieces for generic and plugins and all that...
+
 %define name myslice
-%define version 0.1
-%define taglevel 2
+%define version 0.2
+%define taglevel 4
 
 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
 
@@ -16,11 +22,13 @@ Vendor: OpenLab
 Packager: OpenLab <thierry.parmentelat@inria.fr>
 URL: %{SCMURL}
 
-# We use set everywhere
 Requires: python >= 2.7
-Requires: Django
+# in f14 this used to be called Django
+Requires: python-django
 Requires: httpd
 Requires: mod_wsgi
+# for c_rehash
+Requires: openssl-perl
 BuildRequires: python-setuptools make
 
 %description 
@@ -47,6 +55,22 @@ rm -rf $RPM_BUILD_ROOT
 %{_datadir}/myslice/*
 
 %changelog
+* Wed Sep 25 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myslice-0.2-4
+- move to bootstrap v3 complete - hopefully
+- static files directory is now plain static/
+- templates files directory is now plain templates/
+- packaging for debian should be working fine, using apache+wsgi
+
+* Fri Sep 20 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myslice-0.2-3
+- checkpoint for deployment on test.myslice.info
+
+* Mon Sep 09 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myslice-0.2-2
+- cleaner tag, using module-tag for consistent numbering
+
+* Mon Apr 08 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myslice-django-0.1-3
+- a small number of representative plugins are available
+- next step is to correlate a Get query with its corresponding Update like in slice.php
+
 * Mon Mar 25 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - myslice-django-0.1-2
 - new pluing 'hazelnut' which is a tmpname for the former datatables one
 - querycode is syntaxhighlighter-enabled