update time server per site contact request
[nodeconfig.git] / nodeconfig.spec
index ef5e128..015d43f 100644 (file)
@@ -1,11 +1,11 @@
 #
-# $Id: PLCWWW.spec 7881 2008-01-22 14:45:22Z thierry $
+# $Id$
 #
-%define url $URL: svn+ssh://thierry@svn.planet-lab.org/svn/WWW/trunk/PLCWWW.spec $
+%define url $URL$
 
 %define name nodeconfig
 %define version 4.2
-%define taglevel 1
+%define taglevel 17
 
 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
 
@@ -27,7 +27,8 @@ URL: %(echo %{url} | cut -d ' ' -f 2)
 # We use set everywhere
 Requires: php >= 5.0
 Requires: PLCAPI >= 4.0
-
+# need the apache user at install-time 
+Requires: httpd  
 %description
 
 The nodeconfig package provides various php scripts that are used to
@@ -40,22 +41,90 @@ reasons these scripts get installed in /var/www/html/PlanetLabConf.
 %setup -q
 
 %build
-echo "There is no build stage for this component."
-echo "All files just need to be installed as is from the codebase."
+EXCLUDE="exclude=kernel* util-vserver* iptables iproute"
+for filein in $(find . -name '*.in') ; do
+    file=$(echo $filein | sed -e "s,\.in$,,")
+    sed -e "s,@EXCLUDE@,$EXCLUDE,g" $filein > $file
+done
 
 %install
 rm -rf $RPM_BUILD_ROOT
 
 echo "* nodeconfig: Installing PlanetLabConf pages"
 
-mkdir -p $RPM_BUILD_ROOT/var/www/html/PlanetLabConf
+for dir in boot PlanetLabConf PLCAPI ; do
+    mkdir -p $RPM_BUILD_ROOT/var/www/html/$dir
+done
 # let's be conservative and exclude codebase files, though there should not be any
-rsync -a --exclude \*.spec --exclude .svn --exclude CVS ./ $RPM_BUILD_ROOT/var/www/html/PlanetLabConf
+rsync -a --exclude \*.spec --exclude .svn --exclude \*.in ./ $RPM_BUILD_ROOT/var/www/html/
+
+%post
+# the boot manager upload area
+mkdir -p /var/log/bm
+chown apache:apache /var/log/bm
+chmod 700 /var/log/bm
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(-,root,root,-)
+/var/www/html/boot
 /var/www/html/PlanetLabConf
+/var/www/html/PLCAPI
+
+%changelog
+* Mon Mar 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodeconfig-4.2-17
+- fixed bmlog uploading
+
+* Fri Feb 27 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - nodeconfig-4.2-16
+- make sure the /var/log/bm dir is created correctly.  didn't seem to work where
+- it was.
+
+* Wed Feb 25 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodeconfig-4.2-15
+- merge changes in upload-bmlog from the trunk
+
+* Fri Feb 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodeconfig-4.2-14
+- bootmanager upload script
+
+* Fri Sep 19 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - nodeconfig-4.2-13
+- This configuration file has a single line addition to the standard configuration and it's based on state maintained in the DB.  This has been deprecated in favor of maintaining it in NM.  The standard configuration is in the iptables module and the nodegroup specific addition is created when the ipset is created by NM.
+
+* Mon Sep 15 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodeconfig-4.2-12
+- yum config for nodes needs to mention the additional 'newkey' repository
+
+* Mon Aug 04 2008 Sapan Bhatia <sapanb@cs.princeton.edu> - nodeconfig-4.2-11
+- PlanetFlow/codemux fix
+- Used "./module-tag -b 4.2 nodeconfig:4.2".
+
+* Fri Jul 25 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - nodeconfig-4.2-10
+- syntax error. Fixed.
+
+* Fri Jul 25 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - nodeconfig-4.2-9
+- Updated ntp conf files.
+- I2 iptables for nodes on I2.
+
+* Thu Jul 24 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - nodeconfig-4.2-8
+- iptables superceded by svn/iptables/planetlab-config
+
+* Sat Jul 19 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodeconfig-4.2-7
+- svn keyword expansion fixed, no functional change
+
+* Fri Jul 04 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodeconfig-4.2-6
+- yum config on nodes improved -- see https://svn.planet-lab.org/ticket/342
+
+* Wed Jun 25 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodeconfig-4.2-5
+- yum.conf.php handles nodegroups and slicefamily
+- svn keywords fixed
+
+* Tue Apr 22 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodeconfig-4.2-4
+- keys.php know about monitor
+- new sudoers.php script
+
+* Thu Apr 03 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - nodeconfig-4.2-2 nodeconfig-4.2-3
+- Added support for centralized PlanetFlow.
+
+* Wed Mar 26 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodeconfig-4.2-1 nodeconfig-4.2-2
+- integrated /var/www/html/{boot,PLCAPI} from PLCWWW
+- former content has moved down into PlanetLabConf