Setting tag nodeconfig-5.0-1
[nodeconfig.git] / nodeconfig.spec
index 17fe645..1586dfe 100644 (file)
@@ -4,8 +4,8 @@
 %define url $URL: svn+ssh://thierry@svn.planet-lab.org/svn/WWW/trunk/PLCWWW.spec $
 
 %define name nodeconfig
-%define version 4.3
-%define taglevel 7
+%define version 5.0
+%define taglevel 1
 
 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
 
@@ -28,8 +28,6 @@ URL: %(echo %{url} | cut -d ' ' -f 2)
 # We use set everywhere
 Requires: php >= 5.0
 Requires: PLCAPI >= 4.3
-# need the apache user at install-time
-Requires: httpd 
 
 %description
 
@@ -43,67 +41,40 @@ reasons these scripts get installed in /var/www/html/PlanetLabConf.
 %setup -q
 
 %build
-pushd nodeconfig/yum
-
-KEXCLUDE="exclude=$(../../build/getkexcludes.sh)"
-
-# expand list of kexcludes
-for filein in $(find . -name '*.in') ; do
-    file=$(echo $filein | sed -e "s,\.in$,,")
-    sed -e "s,@KEXCLUDE@,$KEXCLUDE,g" $filein > $file
-done
-
-# scan fcdistros and catenate all repos in 'stock.repo' so db-config can be distro-independant
-
-for fcdistro in $(ls); do
-    [ -d $fcdistro ] || continue
-    pushd $fcdistro/yum.myplc.d
-    rm -f stock.repo
-    cat *.repo > stock.repo
-    popd
-done
-
-popd
 
 %install
 rm -rf $RPM_BUILD_ROOT
 
-pushd nodeconfig
-
 echo "* nodeconfig: Installing PlanetLabConf pages"
 
-for dir in boot PlanetLabConf PLCAPI ; do
+for dir in PlanetLabConf PLCAPI ; do
     mkdir -p $RPM_BUILD_ROOT/var/www/html/$dir
     rsync -a --exclude .svn ./$dir/ $RPM_BUILD_ROOT/var/www/html/$dir/
 done
 
-# the yum area -- se db-config
-# expose (fixed) myplc.repo.php as                                         https://<plc>/yum/myplc.repo.php
-install -D -m 644 ./yum/myplc.repo.php                      $RPM_BUILD_ROOT/var/www/html/yum/myplc.repo.php
-# expose the fcdistro-dependant yum.conf as                                https://<plc>/yum/yum.conf
-install -D -m 644 ./yum/%{distroname}/yum.conf              $RPM_BUILD_ROOT/var/www/html/yum/yum.conf
-# expose the (fcdistro-dependant) stock.repo as                                    https://<plc>/yum/stock.repo
-install -D -m 644 ./yum/%{distroname}/yum.myplc.d/stock.repo $RPM_BUILD_ROOT/var/www/html/yum/stock.repo
-
-popd
+# Install db-config.d files
+echo "* Installing db-config.d files"
+mkdir -p ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d
+cp db-config.d/* ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d
+chmod 444 ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d/*
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
 %post
-# the boot manager upload area
-mkdir -p /var/log/bm
-chown apache:apache /var/log/bm
-chmod 700 /var/log/bm
 
 %files
 %defattr(-,root,root,-)
-/var/www/html/boot
 /var/www/html/PlanetLabConf
 /var/www/html/PLCAPI
-/var/www/html/yum
+/etc/planetlab/db-config.d
 
 %changelog
+* Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodeconfig-5.0-1
+- first working version of 5.0:
+- pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
+- the yum/ and boot/ subdirs have moved away from here
+
 * Wed Dec 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - nodeconfig-4.3-7
 - - decompose PlanetLabConf/sysctl.php into sysctl.conf and
 - sysctl-ip_forward.php. This is in prep of phasing out the latter
@@ -153,4 +124,4 @@ chmod 700 /var/log/bm
 - former content has moved down into PlanetLabConf
 
 
-%define module_current_branch 4.2
+%define module_current_branch 4.3