Branch 5.0 for module nodeconfig created (as new trunk) from tag nodeconfig-4.3-7
[nodeconfig.git] / nodeconfig.spec
index 17fe645..49ddcef 100644 (file)
@@ -4,8 +4,8 @@
 %define url $URL: svn+ssh://thierry@svn.planet-lab.org/svn/WWW/trunk/PLCWWW.spec $
 
 %define name nodeconfig
-%define version 4.3
-%define taglevel 7
+%define version 5.0
+%define taglevel 0
 
 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
 
@@ -72,12 +72,12 @@ pushd nodeconfig
 
 echo "* nodeconfig: Installing PlanetLabConf pages"
 
-for dir in boot PlanetLabConf PLCAPI ; do
+for dir in PlanetLabConf PLCAPI ; do
     mkdir -p $RPM_BUILD_ROOT/var/www/html/$dir
     rsync -a --exclude .svn ./$dir/ $RPM_BUILD_ROOT/var/www/html/$dir/
 done
 
-# the yum area -- se db-config
+# the yum area -- see db-config
 # expose (fixed) myplc.repo.php as                                         https://<plc>/yum/myplc.repo.php
 install -D -m 644 ./yum/myplc.repo.php                      $RPM_BUILD_ROOT/var/www/html/yum/myplc.repo.php
 # expose the fcdistro-dependant yum.conf as                                https://<plc>/yum/yum.conf
@@ -85,6 +85,12 @@ install -D -m 644 ./yum/%{distroname}/yum.conf                    $RPM_BUILD_ROOT/var/www/htm
 # expose the (fcdistro-dependant) stock.repo as                                    https://<plc>/yum/stock.repo
 install -D -m 644 ./yum/%{distroname}/yum.myplc.d/stock.repo $RPM_BUILD_ROOT/var/www/html/yum/stock.repo
 
+# Install db-config.d files
+echo "* Installing db-config.d files"
+mkdir -p ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d
+cp db-config.d/* ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d
+chmod 444 ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d/*
+
 popd
 
 %clean
@@ -98,10 +104,10 @@ chmod 700 /var/log/bm
 
 %files
 %defattr(-,root,root,-)
-/var/www/html/boot
 /var/www/html/PlanetLabConf
 /var/www/html/PLCAPI
 /var/www/html/yum
+/etc/planetlab/db-config.d
 
 %changelog
 * Wed Dec 23 2009 Marc Fiuczynski <mef@cs.princeton.edu> - nodeconfig-4.3-7
@@ -153,4 +159,4 @@ chmod 700 /var/log/bm
 - former content has moved down into PlanetLabConf
 
 
-%define module_current_branch 4.2
+%define module_current_branch 4.3