Added ReCreate. Also added try catch to api eval of rpc method.
[nodemanager.git] / NodeManager.spec
index e025afa..2cb2e32 100644 (file)
@@ -1,7 +1,7 @@
 Summary: PlanetLab Node Manager
 Name: NodeManager
-Version: 1.1
-Release: 1%{?pldistro:.%{pldistro}}%{?date:.%{date}}
+Version: 1.5
+Release: 7%{?pldistro:.%{pldistro}}%{?date:.%{date}}
 License: PlanetLab
 Group: System Environment/Daemons
 URL: http://cvs.planet-lab.org/cvs/NodeManager
@@ -13,7 +13,7 @@ Obsoletes: sidewinder, sidewinder-common
 
 # vuseradd, vuserdel
 Requires: vserver-reference
-Requires: util-vserver
+Requires: util-vserver >= 0.30.208-17
 
 # vserver.py
 Requires: util-vserver-python
@@ -44,9 +44,27 @@ local operations on slices.
 rm -rf $RPM_BUILD_ROOT
 %{__make} %{?_smp_mflags} install DESTDIR="$RPM_BUILD_ROOT"
 
+install -D -m 755 conf_files.init $RPM_BUILD_ROOT/%{_initrddir}/conf_files
 install -D -m 755 nm.init $RPM_BUILD_ROOT/%{_initrddir}/nm
 install -D -m 644 nm.logrotate $RPM_BUILD_ROOT/%{_sysconfdir}/logrotate.d/nm
 
+%post
+chkconfig --add conf_files
+chkconfig conf_files on
+chkconfig --add nm
+chkconfig nm on
+service nm restart
+
+
+%preun
+# 0 = erase, 1 = upgrade
+if [ $1 -eq 0 ] ; then
+    chkconfig nm off
+    chkconfig --del nm
+    chkconfig conf_files off
+    chkconfig --del conf_files
+fi
+
 %clean
 rm -rf $RPM_BUILD_ROOT
 
@@ -57,6 +75,7 @@ rm -rf $RPM_BUILD_ROOT
 %{_datadir}/NodeManager/*
 %{_bindir}/forward_api_calls
 %{_initrddir}/nm
+%{_initrddir}/conf_files
 %{_sysconfdir}/logrotate.d/nm
 
 %changelog