log subprocess calls.
[nodemanager.git] / NodeManager.spec
index 49b74b7..415bf84 100644 (file)
@@ -7,7 +7,7 @@
 
 %define name NodeManager
 %define version 1.7
-%define taglevel 26
+%define taglevel 47
 
 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
 
@@ -25,6 +25,8 @@ Packager: PlanetLab Central <support@planet-lab.org>
 Distribution: PlanetLab %{plrelease}
 URL: %(echo %{url} | cut -d ' ' -f 2)
 
+BuildArch: noarch
+
 # Old Node Manager
 Obsoletes: sidewinder, sidewinder-common
 
@@ -44,6 +46,9 @@ Requires: curl
 # Uses function decorators
 Requires: python >= 2.4
 
+# sioc/plnet
+Requires: pyplnet = 4.2
+
 %description
 The PlanetLab Node Manager manages all aspects of PlanetLab node and
 slice management once the node has been initialized and configured by
@@ -95,9 +100,7 @@ rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(-,root,root,-)
-%doc
-%dir %{_datadir}/NodeManager
-%{_datadir}/NodeManager/*
+%{_datadir}/NodeManager/
 %{_bindir}/forward_api_calls
 %{_initrddir}/nm
 %{_initrddir}/conf_files
@@ -105,6 +108,75 @@ rm -rf $RPM_BUILD_ROOT
 %{_sysconfdir}/logrotate.d/nm
 
 %changelog
+* Tue Mar 10 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.7-47
+- *  Removed thread in conf_files.  The thread with die but the module's callback would happily return without any errors.
+
+* Tue Mar 10 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.7-46
+- Log calls to vuseradd.  If vuseradd fails, the exception will be reported in /valog/nm.
+
+* Mon Mar 02 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.7-45
+- Allowing controller accounts to use unique GIDs can overwrite the default "slice" group.  Controllers now use the "slice" GID instead of unique GIDs.
+
+* Thu Feb 26 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.7-44
+- Delegation code optimization
+- Fixed some comments
+
+* Mon Feb 02 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.7-43
+- BUGFIX:  Extra logging was causing the main thread to die when the API was unavailable (which happens nightly due to db cleanup job).  Fixed.
+
+* Fri Jan 30 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.7-42
+- * Can add or remove BW limits from PLC w/o reboots.
+
+* Fri Jan 30 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.7-41
+- Syntax fix.
+
+* Fri Jan 30 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.7-40
+- * Ensure RSPEC update on all account types per epoch.
+- * BUGFIX:  HTBs were never being created when default slice's overrides weren'tset.
+
+* Thu Jan 29 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.7-39
+- Supports disabling of HTBs from PLC.
+
+* Wed Dec 03 2008 Daniel Hokka Zakrisson <daniel@hozac.com> - NodeManager-1.7-38
+- Add support for plugins.
+- Move network code to a separate module.
+- Add AdminTicket API.
+- Add support for sysctl slice attributes.
+
+* Tue Sep 23 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.7-37
+- Slices are created 1 at a time to avoid race conditions.
+
+* Fri Sep 19 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.7-36
+- Internet2 clique flow classification is now setup by NM.
+
+* Wed Sep 17 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.7-35
+- Clique network shares don't exist.  Removed from bwmon.
+
+* Fri Sep 12 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.7-34
+- * Fixed slice restart via xmlrpc to actually set resources
+- * Reverted bwmon to check current min/max limits before manipulating HTB.
+
+* Wed Sep 03 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.7-33
+- bwmon now has enable/disable flag to control throttling.
+
+* Mon Sep 01 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-1.7-32
+- always log message when expected vserver reference is missing
+
+* Mon Aug 25 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.7-31
+- Emails were only being sent of high bandwidth caps were being exceeded.  Fixed.
+
+* Thu Aug 21 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.7-30
+- bwmon:  Only mention the limit the slice went over.  Not both it and the second limit.
+
+* Wed Aug 20 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.7-29
+- Fixed KeyError in logging.
+
+* Wed Aug 20 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.7-28
+- Fixed syntax error in notify function call.  Also fixed values in email message and logging.
+
+* Mon Aug 18 2008 Daniel Hokka Zakrisson <daniel@hozac.com> - NodeManager-1.7-27
+- Fix the FUSE initscript.
+
 * Sun Aug 17 2008 Daniel Hokka Zakrisson <daniel@hozac.com> - NodeManager-1.7-26
 - FUSE support.