Simple module for toggling network namespaces based on slice attributes
[nodemanager.git] / NodeManager.spec
index 9fe3b51..8d000b7 100644 (file)
@@ -7,7 +7,7 @@
 
 %define name NodeManager
 %define version 1.7
-%define taglevel 20
+%define taglevel 37.1.trellis
 
 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
 
@@ -29,7 +29,7 @@ URL: %(echo %{url} | cut -d ' ' -f 2)
 Obsoletes: sidewinder, sidewinder-common
 
 # vuseradd, vuserdel
-Requires: vserver-%{slicefamily}
+Requires: vserver-%{slicefamily}
 Requires: util-vserver >= 0.30.208-17
 
 # vserver.py
@@ -62,6 +62,7 @@ rm -rf $RPM_BUILD_ROOT
 %{__make} %{?_smp_mflags} install DESTDIR="$RPM_BUILD_ROOT"
 
 install -D -m 755 conf_files.init $RPM_BUILD_ROOT/%{_initrddir}/conf_files
+install -D -m 755 fuse-pl.init $RPM_BUILD_ROOT/%{_initrddir}/fuse-pl
 install -D -m 755 nm.init $RPM_BUILD_ROOT/%{_initrddir}/nm
 install -D -m 644 nm.logrotate $RPM_BUILD_ROOT/%{_sysconfdir}/logrotate.d/nm
 
@@ -70,14 +71,19 @@ chkconfig --add conf_files
 chkconfig conf_files on
 chkconfig --add nm
 chkconfig nm on
+chkconfig --add fuse-pl
+chkconfig fuse-pl on
 if [ "$PL_BOOTCD" != "1" ] ; then
        service nm restart
+       service fuse-pl restart
 fi
 
 
 %preun
 # 0 = erase, 1 = upgrade
 if [ $1 -eq 0 ] ; then
+    chkconfig fuse-pl off
+    chkconfig --del fuse-pl
     chkconfig nm off
     chkconfig --del nm
     chkconfig conf_files off
@@ -95,9 +101,66 @@ rm -rf $RPM_BUILD_ROOT
 %{_bindir}/forward_api_calls
 %{_initrddir}/nm
 %{_initrddir}/conf_files
+%{_initrddir}/fuse-pl
 %{_sysconfdir}/logrotate.d/nm
 
 %changelog
+* Tue Sep 23 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.7-37
+- Slices are created 1 at a time to avoid race conditions.
+
+* Fri Sep 19 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.7-36
+- Internet2 clique flow classification is now setup by NM.
+
+* Wed Sep 17 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.7-35
+- Clique network shares don't exist.  Removed from bwmon.
+
+* Fri Sep 12 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.7-34
+- * Fixed slice restart via xmlrpc to actually set resources
+- * Reverted bwmon to check current min/max limits before manipulating HTB.
+
+* Wed Sep 03 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.7-33
+- bwmon now has enable/disable flag to control throttling.
+
+* Mon Sep 01 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-1.7-32
+- always log message when expected vserver reference is missing
+
+* Mon Aug 25 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.7-31
+- Emails were only being sent of high bandwidth caps were being exceeded.  Fixed.
+
+* Thu Aug 21 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.7-30
+- bwmon:  Only mention the limit the slice went over.  Not both it and the second limit.
+
+* Wed Aug 20 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.7-29
+- Fixed KeyError in logging.
+
+* Wed Aug 20 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.7-28
+- Fixed syntax error in notify function call.  Also fixed values in email message and logging.
+
+* Mon Aug 18 2008 Daniel Hokka Zakrisson <daniel@hozac.com> - NodeManager-1.7-27
+- Fix the FUSE initscript.
+
+* Sun Aug 17 2008 Daniel Hokka Zakrisson <daniel@hozac.com> - NodeManager-1.7-26
+- FUSE support.
+
+* Wed Aug 13 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.7-25
+- Removed thread created for each sliver (!!!).
+- Slivers now spawned out of main thread.
+- This closes the Delegation bug and closes the recent rash of NM instabilities due to queue overflows. [ticket: 384]
+
+* Fri Aug 01 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.7-24
+- * Update bandwidth related attributes on every NM sync.  Bwlimit will check if values have changed.
+- * Vsys supports local_ scripts and NM will disregard them.
+
+* Mon Jul 28 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.7-23
+- After removing the fork() to the slice's uid when writing .ssh/authorized_keys, .ssh had the wrong owner/group.  Fixed.
+
+* Fri Jul 25 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.7-22
+- Small change.  Change uid to slice owner of authorized_keys.
+
+* Wed Jul 23 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.7-21
+- Slices with initscripts kept restarting.  Fixed.
+- Also removed unnecessary fork just to write .ssh/authorized keys for every slice.
+
 * Tue Jul 15 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.7-20
 - * Check slice is_running() every cycle.  If not, assume damaged and restart.