Setting tag nodemanager-5.2-8
[nodemanager.git] / nodemanager-lib.spec
index eb54716..02f216f 100644 (file)
@@ -1,10 +1,11 @@
 %define slicefamily %{pldistro}-%{distroname}-%{_arch}
 
 %define name nodemanager-lib
-%define version 2.0
-%define taglevel 38
+%define version 5.2
+%define taglevel 8
 
 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
+%global python_sitearch %( python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)" )
 
 Summary: PlanetLab Node Manager Library
 Name: %{name}
@@ -33,6 +34,8 @@ Requires: gnupg
 Requires: pyplnet >= 4.3
 # we do need the slice images in any case
 Requires: sliceimage-%{slicefamily}
+# for bwlimit
+Requires: plnode-utils
 
 %description
 The PlanetLab Node Manager manages all aspects of PlanetLab node and
@@ -54,6 +57,7 @@ either nodemanager-vs or nodemanager-lxc
 # make manages the C and Python stuff
 rm -rf $RPM_BUILD_ROOT
 %{__make} %{?_smp_mflags} install-lib DESTDIR="$RPM_BUILD_ROOT"
+PYTHON_SITEARCH=`python -c 'from distutils.sysconfig import get_python_lib; print get_python_lib(1)'`
 
 # install the sliver initscript (that triggers the slice initscript if any)
 mkdir -p $RPM_BUILD_ROOT/usr/share/NodeManager/sliver-initscripts/
@@ -67,6 +71,7 @@ chmod 755 $RPM_BUILD_ROOT/%{_initrddir}/*
 install -d -m 755 $RPM_BUILD_ROOT/var/lib/nodemanager
 
 install -D -m 644 logrotate/nodemanager $RPM_BUILD_ROOT/%{_sysconfdir}/logrotate.d/nodemanager
+install -D -m 755 sshsh $RPM_BUILD_ROOT/bin/sshsh
 
 ##########
 %post
@@ -124,11 +129,118 @@ rm -rf $RPM_BUILD_ROOT
 %{_initrddir}/
 %{_sysconfdir}/logrotate.d/nodemanager
 /var/lib/
+/bin/sshsh
 
 %changelog
+* Fri Sep 20 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-8
+- omf plugin does not block any longer when running trigger script
+- log goes into sliver's /var/log instead
+
+* Wed Aug 28 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-7
+- new install-scripts target in Makefile
+- conf_files and fuse-pl initscripts chmod'ed +x
+- omf_resctl config template tweaked to use _slicename_%_hostname_
+
+* Sun Jul 14 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-6
+- make sure to create /etc/planetlab/virt so others can read that
+- expose get_node_virt() and command_in_slice()
+- refined omf_resctl plugin (fetches trigger, and calls it on expire change)
+- user's .profile now has right owner
+- other tweaks in lxc slivers
+
+* Wed Jul 03 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-5
+- lxc slice creation: slice user was created with unknown gid - fixed
+- lxc slice creation: .profile for root and user - fixed
+
+* Sat Jun 29 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-4
+- fix umounting of ssh directory when deleting omf-friendly slivers
+- support for writing cgroups in subsystems other than cpuset
+- add xid to template match
+- finer-grained split between -lib -vs and -lxc
+- first roughly complete omf_resctl for omfv6
+- minor fix for when getslivers does not have minexemptrate
+
+* Fri May 24 2013 Andy Bavier <acb@cs.princeton.edu> - nodemanager-5.2-3
+- Fix path, machine arch in slivers
+
+* Tue Apr 30 2013 Stephen Soltesz <soltesz@opentechinstitute.org> - nodemanager-5.2-2
+
+* Thu Mar 07 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-1
+- no-op bump to 5.2 to be in line with the rest of the system
+
+* Thu Feb 21 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-22
+- improvements to privatebridge
+
+* Sat Jan 19 2013 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-21
+- change hostnames related to private IPs to use pvt.hostname instead of slice_name.hostname
+
+* Mon Jan 14 2013 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-20
+- fix wrong gre tunnel deleted when topology changes
+
+* Mon Jan 14 2013 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-19
+- Update /etc/hosts in slivers from sliver_hostmap tag.
+
+* Mon Jan 07 2013 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-18
+- Support passing a list of interfaces in slice interface tag to configure multiple interfaces,
+- initial check-in of privatebridge plugin.
+
+* Fri Dec 14 2012 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-17
+- set ownership of slice homedir, att slice user to etc/sudoers inside of slice
+
+* Wed Dec 12 2012 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-16
+- fix slices not deleted properly when they use vsys
+
+* Mon Dec 10 2012 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-15
+- fix error in syndicate plugin, add error message to nodemanager for attributeerror during load/start
+
+* Mon Dec 10 2012 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-14
+- Add syndicate plugin, create /etc/hostname and home directory in LXC guests
+
+* Tue Nov 13 2012 Andy Bavier <acb@cs.princeton.edu> - nodemanager-2.1-13
+- Bridge virtual interfaces to VLANs
+
+* Wed Oct 24 2012 Andy Bavier <acb@cs.princeton.edu> - nodemanager-2.1-12
+- Add support for L2 bridged interfaces with public IPs inside a slice
+
+* Thu Oct 18 2012 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-11
+- Support for freezing BestEffort slices for Vicci
+
+* Wed Sep 05 2012 Andy Bavier <acb@cs.princeton.edu> - nodemanager-2.1-10
+- Change to use new vsh (wrapper for lxcsu)
+
+* Fri Aug 31 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-9
+- add missing import
+- 2.1-8 is less broken than 2.1-7 for omf-friendly slices, in that the slivers would get created, but the OMF-feature probably won't work as .ssh won't get exposed to the sliver
+
+* Thu Aug 30 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-8
+- tag 2.1-7 was broken for OMF-friendly slices
+- expose_ssh_dir was erroneously defined on the Worker class
+
+* Thu Jul 19 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-7
+- bwlimitlxc now ships with plnode-utils
+
+* Mon Jul 09 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-6
+- set LD_PRELOAD for linux-containers nodes
+
+* Thu Jun 28 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-5
+- first complete version for vs and lxc - functional but not thoroughly tested though
+
+* Tue Jun 26 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-4
+- split packaging in 3 (lib, lxc, vs)
+- this tag will only work with lxc though
+
 * Tue Jun 26 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-38
 - split packaging, nodemanager-vs (obsoletes NodeManager) and nodemanager-lib
 
+* Mon Jun 25 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-3
+- renamed bwlimit as bwlimitlxc to avoid conflicts with util-vserver-pl
+- purpose being to be able to run this branch on vserver nodes as well
+
+* Thu Jun 21 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-2
+- merged nodemanager-2.0-37 in 2.1/lxc_devel and add initscript support to lxc
+- passes tests with lxc but won't build against vs due to conflict
+- as bwlimit.py also ships with util-vserver-pl
+
 * Thu Jun 21 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-37
 - refactoring: isolate initscript functionality
 - aimed at making initscript implementation with lxc straightforward
@@ -138,6 +250,10 @@ rm -rf $RPM_BUILD_ROOT
 * Sun Jun 03 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-36
 - /var/log/nodemanager shows duration of mainloop
 
+* Fri Apr 13 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-1
+- first working draft for dealing with libvirt/lxc on f16 nodes
+- not expected to work with mainline nodes (use 2.0 for that for now)
+
 * Fri Apr 13 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-35
 - remove Requires to deprecated vserver-* rpms, use sliceimage-* instead
 
@@ -381,12 +497,14 @@ rm -rf $RPM_BUILD_ROOT
 - Codemux supports multiple hosts mapping to single slice
 - Fixed bug in delegation support where tickets delivered weren't
   being passed to sm.deliver_ticket().
+
 * Fri Mar 28 2008 Faiyaz Ahmed <faiyaza@cs.prineton.edu - NodeManager-1.7.3
 - Codemux now configured via slice attribute (host,port)
 - Support for multiple vserver reference images (including different archs)
 - Mom BW emails are sent to list defined by MyPLC's config
 - Sirius BW loans honored correctly.  Fixed.
 - BW totals preserved for dynamic slices so as not to game the system.
+
 * Thu Feb 14 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.7-1 NodeManager-1.7-2
 - Configures vsys via vsys slice attribute {name: vsys, value: script}
 - CPU reservations are now calculated via percentages instead of shares