imagezip also needed
[omf.git] / omf-resctl.spec
index c92e586..1e28fce 100644 (file)
@@ -3,8 +3,8 @@
 #
 %define url $URL$
 
-# Marc E. Fiuczynski <mef@cs.princeton.edu>
-# Copyright (C) 2006 The Trustees of Princeton University
+# Thierry Parmentelat - INRIA
+# Copyright (C) 2010 INRIA
 # License is GPL.
 
 %define name omf-resctl
@@ -29,7 +29,6 @@ Distribution: %{pldistro} %{plrelease}
 URL: %(echo %{url} | cut -d ' ' -f 2)
 BuildArch: noarch
 
-Requires: imagezip
 Requires: pciutils  
 Requires: ruby  
 Requires: wget  
@@ -40,6 +39,7 @@ Requires: rpmlib(PayloadFilesHavePrefix) <= 4.0-1
 Requires: omf-common  
 Requires: liblog4r
 Requires: libxmpp4r
+Requires: imagezip
 
 %description 
 The OMF Resource Controller (RC) is the experiment-side of the
@@ -73,6 +73,15 @@ Group: System Environment/Base
 %description -n libxmpp4r
 An XMPP/Jabber library for Ruby, needed by OMF software
 
+####################
+%define imagezip_actual_name imagezip-1.0.0-3
+
+%package -n imagezip
+Summary:  filesystem image compression tool from EMULAB
+Group: System Environment/Base
+%description -n imagezip
+filesystem image compression tool from EMULAB
+
 ####################
 
 %prep
@@ -91,6 +100,8 @@ make liblog4r
 (cd unwrap; rpm2cpio ../%{liblog4r_actual_name}.noarch.rpm | cpio -diu)
 make libxmpp4r 
 (cd unwrap; rpm2cpio ../%{libxmpp4r_actual_name}.noarch.rpm | cpio -diu)
+make imagezip 
+(cd unwrap; rpm2cpio ../%{imagezip_actual_name}.i386.rpm | cpio -diu)
 
 # cleanup svn sequels
 find unwrap -type d -name .svn -print0 | xargs -0 rm -rf
@@ -142,5 +153,13 @@ ln -s /usr/bin/ruby /usr/bin/ruby1.8
 /usr/lib/ruby/1.8/xmpp4r
 /usr/share/doc/libxmpp4r-ruby1.8
 
+####################
+%files -n imagezip
+%defattr(-,root,root)
+/usr/bin/imagedump
+/usr/bin/imageunzip
+/usr/bin/imagezip
+/usr/share/doc/imagezip
+
 ####################
 %changelog