Setting tag oml-2.6.1-1
[oml.git] / liboml.spec
1 # Thierry Parmentelat - INRIA
2 # Copyright (C) 2010 INRIA
3 # License is GPL.
4
5 %define name liboml
6 %define version 2.6.1
7 %define taglevel 1
8
9 %define oml_actual_name oml2-%{version}
10
11 Summary: OMF Measurement Library
12 Name: %{name}
13 Version: %{version}
14 Release: %{taglevel}
15 License: GPL
16 Group: System Environment/Base
17 Source0: %{oml_actual_name}.tar.gz
18 BuildRoot: %{_tmppath}/%{oml_actual_name}-buildroot
19
20 Vendor: NICTA
21 Packager: OneLab <devel@planet-lab.org>
22 Distribution: %{pldistro} %{plrelease}
23 URL: %{SCMURL}
24
25 %description 
26 The OML (Orbit Measurement Library) provides utilities to capture measurements...
27
28 # buildrequires 
29 BuildRequires: libxml2-devel
30 BuildRequires: sqlite-devel
31 #BuildRequires: libpcap-devel
32 BuildRequires: popt-devel
33 BuildRequires: autoconf
34 BuildRequires: automake
35 BuildRequires: libtool
36 BuildRequires: check
37 #BuildRequires: libtrace3-dev
38 #BuildRequires: libsigar-dev
39
40 # requires (build or runtime ?)
41 Requires: libxml2
42 Requires: libsqlite3
43 #Requires: libpcap
44 Requires: libpthread
45 Requires: libpopt
46 #Requires: libtrace3
47 #Requires: libsigar
48
49 # don't create the debuginfo package
50 %define _enable_debug_packages 0
51 %global __debug_package 0
52 ####################
53
54 %prep
55 %setup -n %{oml_actual_name}
56
57 %build
58 rm -rf $RPM_BUILD_ROOT
59
60 # retrieve tarball
61 make oml
62 # extract it
63 tar -xzf %{oml_actual_name}.tar.gz
64
65 pushd %{oml_actual_name}
66 ./configure --prefix=/usr
67 make
68 # skip this optional step
69 # make check
70 popd
71
72 %install
73 rm -fr $RPM_BUILD_ROOT
74 pushd %{oml_actual_name}
75 make install DESTDIR=$RPM_BUILD_ROOT
76 popd
77
78 %clean
79 rm -rf $RPM_BUILD_ROOT
80
81 ####################
82 %files
83 %defattr(-,root,root)
84 /usr/bin
85 /usr/include
86 /usr/lib/lib*
87 /usr/share
88
89 ####################
90 %changelog
91 * Mon Aug 29 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - oml-2.6.1-1
92 - updated with latest release from NICTA
93
94 * Fri Feb 04 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - oml-2.5.1-1
95 - dropped unneeded dep to pcap
96
97