spec file fix
[openvswitch.git] / openvswitch.spec
index a384470..7dbc1d9 100644 (file)
@@ -1,11 +1,11 @@
 %define url $URL$
 
 %define name openvswitch
-%define version 1.4pre
+%define version ef72dd8
 %define taglevel 1
 
 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
-%define upstream http://openvswitch.org/releases/openvswitch-%{version}.tar.gz
+%define upstream "http://openvswitch.org/cgi-bin/gitweb.cgi?p=openvswitch;a=snapshot;h=ef72dd87d6ad4e511d1e0bddc31d4716f0914fab;sf=tgz"
 
 Vendor: PlanetLab
 Packager: PlanetLab Central <support@planet-lab.org>
@@ -22,17 +22,19 @@ BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
 #Requires: 
 BuildRequires: kernel-devel
 
-Source0: openvswitch-sources.tar.gz
+Source0: openvswitch-%{version}.tar.gz
 
 %description
 Openvswitch - virtual switches on PlanetLab
 
 %prep
 %setup
-tar xvfz openvswitch-sources.tar.gz --strip=1
+wget -Oopenvswitch-%{version}.tar.gz %{upstream}
+tar xvfz openvswitch-%{version}.tar.gz --strip=1
 
 %build
 KVER=`ls -l /usr/src/kernels | awk '{printf $9;}'`
+./boot.sh
 ./configure --with-linux=/usr/src/kernels/$KVER
 make -j17