spec file fix
[openvswitch.git] / openvswitch.spec
index ae491a0..7dbc1d9 100644 (file)
@@ -5,7 +5,7 @@
 %define taglevel 1
 
 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
-%define upstream http://openvswitch.org/releases/openvswitch-%{version}.tar.gz
+%define upstream "http://openvswitch.org/cgi-bin/gitweb.cgi?p=openvswitch;a=snapshot;h=ef72dd87d6ad4e511d1e0bddc31d4716f0914fab;sf=tgz"
 
 Vendor: PlanetLab
 Packager: PlanetLab Central <support@planet-lab.org>
@@ -29,9 +29,12 @@ Openvswitch - virtual switches on PlanetLab
 
 %prep
 %setup
+wget -Oopenvswitch-%{version}.tar.gz %{upstream}
+tar xvfz openvswitch-%{version}.tar.gz --strip=1
 
 %build
 KVER=`ls -l /usr/src/kernels | awk '{printf $9;}'`
+./boot.sh
 ./configure --with-linux=/usr/src/kernels/$KVER
 make -j17