Attempts to write to vsys FIFO when file exists. If process is blocked, kill and...
[pf2slice.git] / pf2slice.spec
index 029fbcb..64d808d 100644 (file)
@@ -1,7 +1,7 @@
 # please keep these three lines as they are used by the tagging script
 # see build/module-tag.py for details
 %define name pf2slice
-%define version 1
+%define version 1.0
 %define taglevel 1
 
 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
@@ -26,9 +26,11 @@ pf2slice - Populates the planetflow slice with the right initscript, keychains a
 rm -rf %{buildroot}
 install -d -v %{buildroot}/etc/init.d
 install -m 755 -v pf2slice-initscript %{buildroot}/etc/init.d/pf2slice
+install -d -m 700 %{buildroot}/home/pl_netflow/.ssh
+install -m 600 authorized_keys %{buildroot}/home/pl_netflow/.ssh/authorized_keys
 mkdir -p %{buildroot}/home/pl_netflow/.ssh
 mkdir -p %{buildroot}/pf
-cp authorized_keys %{buildroot}/home/pl_netflow/.ssh
+
 
 %clean
 rm -rf %{buildroot}
@@ -36,7 +38,7 @@ rm -rf %{buildroot}
 %files
 %defattr(-,root,root)
 /etc/init.d/pf2slice
-/root/.ssh/authorized_keys
+/home/pl_netflow/.ssh/authorized_keys
 /home/*
 /pf