Attempts to write to vsys FIFO when file exists. If process is blocked, kill and...
[pf2slice.git] / pf2slice.spec
index be20948..64d808d 100644 (file)
@@ -1,7 +1,7 @@
 # please keep these three lines as they are used by the tagging script
 # see build/module-tag.py for details
 %define name pf2slice
-%define version 1
+%define version 1.0
 %define taglevel 1
 
 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
@@ -26,8 +26,11 @@ pf2slice - Populates the planetflow slice with the right initscript, keychains a
 rm -rf %{buildroot}
 install -d -v %{buildroot}/etc/init.d
 install -m 755 -v pf2slice-initscript %{buildroot}/etc/init.d/pf2slice
-mkdir -p /root/.ssh
-cp authorized_keys /root/.ssh
+install -d -m 700 %{buildroot}/home/pl_netflow/.ssh
+install -m 600 authorized_keys %{buildroot}/home/pl_netflow/.ssh/authorized_keys
+mkdir -p %{buildroot}/home/pl_netflow/.ssh
+mkdir -p %{buildroot}/pf
+
 
 %clean
 rm -rf %{buildroot}
@@ -35,7 +38,9 @@ rm -rf %{buildroot}
 %files
 %defattr(-,root,root)
 /etc/init.d/pf2slice
-/root/.ssh/authorized_keys
+/home/pl_netflow/.ssh/authorized_keys
+/home/*
+/pf
 
 %post
 chkconfig --add pf2slice