- remove old files no longer usable
[pingofdeath.git] / ipod.spec
index 4e5af2a..f22b5ba 100644 (file)
--- a/ipod.spec
+++ b/ipod.spec
@@ -1,5 +1,5 @@
 %define name ipod
-%define version 2.1
+%define version 2.2
 %define release 1%{?pldistro:.%{pldistro}}%{?date:.%{date}}
 
 Vendor: PlanetLab
@@ -7,7 +7,7 @@ Packager: PlanetLab Central <support@planet-lab.org>
 Distribution: PlanetLab 3.0
 URL: http://cvs.planet-lab.org/cvs/ipod
 
-Summary: PlanetLab ICMP Ping of Death
+Summary: PlanetLab ICMP/UDP Ping of Death
 Name: %{name}
 Version: %{version}
 Release: %{release}
@@ -19,6 +19,14 @@ BuildRoot: %{_tmppath}/%{name}-%{version}root
 %description
 Startup service to enable Ping Of Death
 
+%package client
+Summary: PlanetLab ICMP/UDP Ping of Death Client Tools
+Group: System Environment/Kernel
+Requires: python
+
+%description client
+Client utilities to use Ping of Death
+
 %prep
 
 %setup
@@ -28,12 +36,16 @@ make
 
 
 %install
+# ipod
 mkdir -p $RPM_BUILD_ROOT/usr/local/planetlab/bin
 mkdir -p $RPM_BUILD_ROOT/etc/init.d
 
 cp pl-poddoit $RPM_BUILD_ROOT/usr/local/planetlab/bin/
 cp pod $RPM_BUILD_ROOT/etc/init.d/
 
+# ipod-client
+mkdir -p $RPM_BUILD_ROOT/usr/bin/
+cp pod.py $RPM_BUILD_ROOT/usr/bin
 
 %clean
 [ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
@@ -44,6 +56,11 @@ cp pod $RPM_BUILD_ROOT/etc/init.d/
 /etc/init.d/pod
 /usr/local/planetlab/bin/pl-poddoit
 
+%files client
+%defattr(0755, root, root)
+/usr/bin/pod.py
+
+
 %pre
 
 %post 
@@ -66,6 +83,9 @@ fi
 
 
 %changelog
+* Wed Jan 11 2006 Aaron Klingaman <alk@absarokasoft.com>
+- add support for building client tool rpm
+
 * Fri Aug  5 2005 Aaron Klingaman <alk@absarokasoft.com>
 - updated to use new source of POD Hash (/etc/planetlab/session)
 - minor build changes to simply build process