support pldistro "variants"
[pingofdeath.git] / ipod.spec
index 3161ead..4e5af2a 100644 (file)
--- a/ipod.spec
+++ b/ipod.spec
@@ -1,10 +1,20 @@
+%define name ipod
+%define version 2.1
+%define release 1%{?pldistro:.%{pldistro}}%{?date:.%{date}}
+
+Vendor: PlanetLab
+Packager: PlanetLab Central <support@planet-lab.org>
+Distribution: PlanetLab 3.0
+URL: http://cvs.planet-lab.org/cvs/ipod
+
 Summary: PlanetLab ICMP Ping of Death
-Name: ipod
-Version: 2.0
-Release: 2
+Name: %{name}
+Version: %{version}
+Release: %{release}
 Copyright: GPL
 Group: System Environment/Kernel
-Source: ipod-2.0.tar.gz
+Source: %{name}-%{version}.tar.gz
+BuildRoot: %{_tmppath}/%{name}-%{version}root
 
 %description
 Startup service to enable Ping Of Death
@@ -16,26 +26,32 @@ Startup service to enable Ping Of Death
 %build
 make
 
+
 %install
-make install
+mkdir -p $RPM_BUILD_ROOT/usr/local/planetlab/bin
+mkdir -p $RPM_BUILD_ROOT/etc/init.d
+
+cp pl-poddoit $RPM_BUILD_ROOT/usr/local/planetlab/bin/
+cp pod $RPM_BUILD_ROOT/etc/init.d/
+
 
 %clean
+[ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
+
 
 %files
-%defattr(-, root, root)
+%defattr(0755, root, root)
 /etc/init.d/pod
 /usr/local/planetlab/bin/pl-poddoit
 
 %pre
 
 %post 
-RUNLEVEL=`/sbin/runlevel`
-
 if [ "$1" = 1 ]; then
        chkconfig --add pod
        chkconfig pod on
 
-       if [[ "$RUNLEVEL" != "unknown" ]]; then
+       if [[ "$PL_BOOTCD" != "1" ]] ; then
                /etc/init.d/pod start
        fi
 fi
@@ -48,3 +64,13 @@ fi
 
 %postun
 
+
+%changelog
+* Fri Aug  5 2005 Aaron Klingaman <alk@absarokasoft.com>
+- updated to use new source of POD Hash (/etc/planetlab/session)
+- minor build changes to simply build process
+- remove unnecessary call to runlevel in post section
+
+* Mon Apr 12 2004 Aaron Klingaman <alk@cs.princeton.edu>
+- moved to new build process
+- added change log