- check $PL_BOOTCD instead of $RUNLEVEL
[pingofdeath.git] / ipod.spec
index 5185c41..77cef16 100644 (file)
--- a/ipod.spec
+++ b/ipod.spec
@@ -1,6 +1,11 @@
 %define name ipod
 %define version 2.0
-%define release 3
+%define release 6.planetlab%{?date:.%{date}}
+
+Vendor: PlanetLab
+Packager: PlanetLab Central <support@planet-lab.org>
+Distribution: PlanetLab 3.0
+URL: http://cvs.planet-lab.org/cvs/ipod
 
 Summary: PlanetLab ICMP Ping of Death
 Name: %{name}
@@ -9,7 +14,7 @@ Release: %{release}
 Copyright: GPL
 Group: System Environment/Kernel
 Source: %{name}-%{version}.tar.gz
-BuildRoot: /tmp/%{name}-%{version}-root
+BuildRoot: %{_tmppath}/%{name}-%{version}root
 
 %description
 Startup service to enable Ping Of Death
@@ -31,11 +36,11 @@ cp pod $RPM_BUILD_ROOT/etc/init.d/
 
 
 %clean
-rm -rf $RPM_BUILD_ROOT
+[ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
 
 
 %files
-%defattr(-, root, root)
+%defattr(0755, root, root)
 /etc/init.d/pod
 /usr/local/planetlab/bin/pl-poddoit
 
@@ -48,7 +53,7 @@ if [ "$1" = 1 ]; then
        chkconfig --add pod
        chkconfig pod on
 
-       if [[ "$RUNLEVEL" != "unknown" ]]; then
+       if [[ "$PL_BOOTCD" != "1" ]] ; then
                /etc/init.d/pod start
        fi
 fi