mark pod.py as running on python2
[pingofdeath.git] / ipod.spec
index e4bec3f..fae1afd 100644 (file)
--- a/ipod.spec
+++ b/ipod.spec
@@ -1,17 +1,24 @@
+#
+# $Id$
+#
+%define url $URL$
+
 %define name ipod
-%define version 2.0
-%define release 6.planetlab%{?date:.%{date}}
+%define version 2.2
+%define taglevel 1
+
+%define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
 
 Vendor: PlanetLab
 Packager: PlanetLab Central <support@planet-lab.org>
-Distribution: PlanetLab 3.0
-URL: http://cvs.planet-lab.org/cvs/ipod
+Distribution: PlanetLab %{plrelease}
+URL: %(echo %{url} | cut -d ' ' -f 2)
 
-Summary: PlanetLab ICMP Ping of Death
+Summary: PlanetLab ICMP/UDP Ping of Death
 Name: %{name}
 Version: %{version}
 Release: %{release}
-Copyright: GPL
+License: GPL
 Group: System Environment/Kernel
 Source: %{name}-%{version}.tar.gz
 BuildRoot: %{_tmppath}/%{name}-%{version}root
@@ -19,6 +26,14 @@ BuildRoot: %{_tmppath}/%{name}-%{version}root
 %description
 Startup service to enable Ping Of Death
 
+%package client
+Summary: PlanetLab ICMP/UDP Ping of Death Client Tools
+Group: System Environment/Kernel
+Requires: python
+
+%description client
+Client utilities to use Ping of Death
+
 %prep
 
 %setup
@@ -28,12 +43,16 @@ make
 
 
 %install
+# ipod
 mkdir -p $RPM_BUILD_ROOT/usr/local/planetlab/bin
 mkdir -p $RPM_BUILD_ROOT/etc/init.d
 
 cp pl-poddoit $RPM_BUILD_ROOT/usr/local/planetlab/bin/
 cp pod $RPM_BUILD_ROOT/etc/init.d/
 
+# ipod-client
+mkdir -p $RPM_BUILD_ROOT/usr/bin/
+cp pod.py $RPM_BUILD_ROOT/usr/bin
 
 %clean
 [ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
@@ -44,16 +63,19 @@ cp pod $RPM_BUILD_ROOT/etc/init.d/
 /etc/init.d/pod
 /usr/local/planetlab/bin/pl-poddoit
 
+%files client
+%defattr(0755, root, root)
+/usr/bin/pod.py*
+
+
 %pre
 
 %post 
-RUNLEVEL=`/sbin/runlevel`
-
 if [ "$1" = 1 ]; then
        chkconfig --add pod
        chkconfig pod on
 
-       if [[ "$RUNLEVEL" != "unknown" ]]; then
+       if [[ "$PL_BOOTCD" != "1" ]] ; then
                /etc/init.d/pod start
        fi
 fi
@@ -68,6 +90,14 @@ fi
 
 
 %changelog
+* Wed Jan 11 2006 Aaron Klingaman <alk@absarokasoft.com>
+- add support for building client tool rpm
+
+* Fri Aug  5 2005 Aaron Klingaman <alk@absarokasoft.com>
+- updated to use new source of POD Hash (/etc/planetlab/session)
+- minor build changes to simply build process
+- remove unnecessary call to runlevel in post section
+
 * Mon Apr 12 2004 Aaron Klingaman <alk@cs.princeton.edu>
 - moved to new build process
 - added change log