mark pod.py as running on python2
[pingofdeath.git] / ipod.spec
index f22b5ba..fae1afd 100644 (file)
--- a/ipod.spec
+++ b/ipod.spec
@@ -1,17 +1,24 @@
+#
+# $Id$
+#
+%define url $URL$
+
 %define name ipod
 %define version 2.2
-%define release 1%{?pldistro:.%{pldistro}}%{?date:.%{date}}
+%define taglevel 1
+
+%define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
 
 Vendor: PlanetLab
 Packager: PlanetLab Central <support@planet-lab.org>
-Distribution: PlanetLab 3.0
-URL: http://cvs.planet-lab.org/cvs/ipod
+Distribution: PlanetLab %{plrelease}
+URL: %(echo %{url} | cut -d ' ' -f 2)
 
 Summary: PlanetLab ICMP/UDP Ping of Death
 Name: %{name}
 Version: %{version}
 Release: %{release}
-Copyright: GPL
+License: GPL
 Group: System Environment/Kernel
 Source: %{name}-%{version}.tar.gz
 BuildRoot: %{_tmppath}/%{name}-%{version}root
@@ -58,7 +65,7 @@ cp pod.py $RPM_BUILD_ROOT/usr/bin
 
 %files client
 %defattr(0755, root, root)
-/usr/bin/pod.py
+/usr/bin/pod.py*
 
 
 %pre