This commit was generated by cvs2svn to compensate for changes in r5,
[pl_sshd.git] / pl_sshd.spec
1 Summary: SSH server config for PlanetLab
2 Name: pl_sshd
3 Version: 0.1
4 Release: 1
5 Requires: automount, sshd
6 Copyright: GPL
7 URL: http://www.planet-lab.org
8 Group: System Environment/Base
9 Source: %{_fullname}.tar.gz
10
11 %description 
12 SSH server configuration for PlanetLab nodes.  Configures an automounted
13 directory as source for authorized_keys files and points sshd to that
14 directory.
15
16 %prep
17 %setup
18
19 %build
20
21
22 %install
23 install -m 0755 -o root -g root pl_sshd.sh $RPM_BUILD_ROOT/usr/local/sbin
24 install -m 0755 -o root -g root pl_sshd $RPM_BUILD_ROOT/etc/init.d
25 install -m 0755 -o root -g root auto.pl_sshd $RPM_BUILD_ROOT/etc
26 echo "OPTIONS='-p 806'" >$RPM_BUILD_ROOT/etc/sysconfig/sshd
27
28 %clean
29 rm -rf $RPM_BUILD_ROOT
30
31 %files
32 %defattr(-,root,root)
33 %attr(0755,root,root) /usr/local/sbin/pl_sshd.sh
34 %attr(0755,root,root) /etc/init.d/pl_sshd
35 %attr(0755,root,root) /etc/auto.pl_sshd
36
37 %pre
38
39
40 %post
41 RUNLEVEL=`/sbin/runlevel`
42
43 if [ "$1" -ge 1 ]; then
44         chkconfig --add pl_sshd
45
46         if [[ "$RUNLEVEL" != "unknown" ]]; then
47                 /etc/init.d/pl_sshd restart
48         fi
49 fi
50
51 %preun
52 if [ "$1" = 0 ]; then
53         chkconfig --del pl_sshd
54 fi
55
56
57 %postun
58
59
60 %changelog
61 * Tue Nov 25 2003 Steve Muir <smuir@cs.princeton.edu>
62 - fixed a couple of Node Manager bugs:
63   - bootstrapping pl_conf state when boot server unreachable
64   - canonical hostnames should be all lower-case
65 - fixup UID and GID of users within vservers to match real world
66 - enable access to dynamic slices through port 806 sshd
67
68 * Sun Oct 26 2003 Aaron Klingaman <Aaron.L.Klingaman@intel.com>
69 - readded start/stop only when runlevel is known, for install purposes
70
71 * Thu Oct 16 2003 Jeff Sedayao <Jeff.Sedayao@intel.com>
72 - Fixed bug in pl_conf  - it was getting negative wait times.  Also added
73   duke4 as a trusted user. 
74
75 * Tue Oct  8 2003 Jeff Sedayao <Jeff.Sedayao@intel.com>
76 - Removed special fetch login from init function, updated release
77
78 * Tue Oct  7 2003 Jeff Sedayao <Jeff.Sedayao@intel.com>
79 - Moved special fetch login into main loop, fix account deletion
80   problem
81
82 * Tue Oct  7 2003 Aaron Klingaman <Aaron.L.Klingaman@intel.com>
83 - Commented out code to start pl_* upon install
84
85 * Wed Aug 26 2003 Tammo Spalink <tammo.spalink@intel.com>
86 - Initial build.
87