Some file moved and little changes
[planetlab-umts-tools.git] / backend.spec
1 %define module_taglevel_varname release
2
3 %define name planetlab-umts-tools-backend
4 %define version 0.5
5 %define release 2
6
7 Summary: Umts-tools for PlanetLab - backend part
8 Name: %{name}
9 Version: %{version}
10 Release: %{release}
11 Source0: %{name}-%{version}.tar.gz
12 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
13 BuildArch: noarch
14 Vendor: Universita Federico II di Napoli for Onelab
15 Group: Utilities
16 URL: http://www.unina.it
17 License: GPL
18 Prefix: %{_prefix}
19
20 Requires: vsys
21
22 %description
23 Backend part of a program that allows users of a slice to control a PPP connection over a 3G umts/hsdpa connect card and set the route entries required to use it.
24
25 %prep
26 %setup -q
27
28 %build
29 rm -rf $RPM_BUILD_ROOT
30
31 %install
32 pushd backend
33 rm -rf $RPM_BUILD_ROOT
34 mkdir -p $RPM_BUILD_ROOT
35 make clean
36 make install prefix=$RPM_BUILD_ROOT
37 popd
38
39 %clean
40
41
42 %post 
43 /sbin/udevadm control reload_rules
44 /sbin/chkconfig umts on
45 /etc/rc.d/init.d/umts start
46 /sbin/service vsys restart
47
48 %preun
49 /sbin/chkconfig umts off
50
51 %files
52 /vsys/umts_backend
53 /usr/lib/umts_functions
54 /etc/udev/rules.d/96-umts-tools.rules
55 /etc/rc.d/init.d/umts
56
57 %defattr(-,root,root)
58 %doc backend/AUTHORS backend/TODO
59
60 %changelog
61 * Tue Sep 30 2008 Giovanni Di Stasi <giovanni.distasi@unina.it> -
62 - initial revision