bump version
[planetlab-umts-tools.git] / backend.spec
1 %define name planetlab-umts-tools-backend
2 %define version 0.5
3 %define release 1
4
5 Summary: Umts-tools for PlanetLab - backend part
6 Name: %{name}
7 Version: %{version}
8 Release: %{release}
9 Source0: %{name}-%{version}.tar.gz
10 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
11 BuildArch: noarch
12 Vendor: Universita Federico II di Napoli for Onelab
13 Group: Utilities
14 URL: http://www.unina.it
15 License: GPL
16 Prefix: %{_prefix}
17
18 Requires: vsys
19
20 %description
21 Backend part of a program that allows users of a slice to control a PPP connection over a 3G umts/hsdpa connect card and set the route entries required to use it.
22
23 %prep
24 %setup -q
25
26 %build
27 rm -rf $RPM_BUILD_ROOT
28
29 %install
30 pushd backend
31 rm -rf $RPM_BUILD_ROOT
32 mkdir -p $RPM_BUILD_ROOT
33 make clean
34 cp -af root/* $RPM_BUILD_ROOT/
35 popd
36
37 %clean
38
39
40 %post 
41 /sbin/udevadm control reload_rules
42 /sbin/chkconfig umts on
43 /etc/rc.d/init.d/umts start
44 /sbin/service vsys restart
45
46 %preun
47 /sbin/chkconfig umts off
48
49 %files
50 /vsys/umts_backend
51 /usr/lib/umts_functions
52 /etc/udev/rules.d/96-umts-tools.rules
53 /etc/rc.d/init.d/umts
54
55 %defattr(-,root,root)
56 %doc backend/AUTHORS backend/TODO
57
58 %changelog
59 * Tue Sep 30 2008 Giovanni Di Stasi <giovanni.distasi@unina.it> -
60 - initial revision