d6f55e441f639934420437d3e577f4399a19ca94
[planetlab-umts-tools.git] / frontend.spec
1 %define module_taglevel_varname release
2
3 %define name planetlab-umts-tools-frontend
4 %define version 0.6
5 %define release 5
6
7 Summary: UMTS tools for PlanetLab
8 Name: %{name}
9 Version: %{version}
10 Release: %{release}
11 Source0: %{name}-%{version}.tar.gz
12 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
13 Vendor: Universita Federico II di Napoli for Onelab
14 Group: Utilities
15 URL: http://www.unina.it
16 License: GPL
17 Prefix: %{_prefix}
18
19 %description
20 Frontend part of a program that allows users of a slice to control a PPP connection over a 3G umts/hsdpa connect card and set the route entries required to use it.
21
22 %prep
23
24 %setup -q
25
26 %build
27 rm -rf $RPM_BUILD_ROOT
28 pushd frontend
29 make 
30 popd 
31
32 %install
33 rm -rf $RPM_BUILD_ROOT
34 pushd frontend
35 mkdir -p $RPM_BUILD_ROOT/usr/bin/
36 install -D -s umts $RPM_BUILD_ROOT/usr/bin/
37 popd
38
39 %clean
40 rm -rf $RPM_BUILD_ROOT
41
42 %post
43
44 %postun
45
46 %files
47 %defattr(-,root,root)
48 /usr/bin/umts
49 %doc AUTHORS VERSION README.User README.PI
50
51 %changelog
52 * Tue Jul 06 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - planetlab-umts-tools-0.6-5
53 - cosmetic changes from Giovanni.
54
55 * Tue Sep 30 2008 Giovanni Di Stasi <giovanni.distasi@unina.it> -
56 - initial revision
57