old code would nuke default_config.xml, this version will add it to a local
[plcrt.git] / plcrt.spec
1 #
2 # $Id$
3
4
5 %define url $URL: svn+ssh://svn.planet-lab.org/svn/PLCRT/trunk/plcrt.spec $
6
7 %define name plcrt
8 %define version 1.0
9 %define taglevel 1
10
11 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
12
13 Name: %{name}
14 Version: %{version}
15 Release: %{release}
16 Source0: %{name}-%{version}.tar.bz2
17 License: GPL
18 Group: Applications/System
19 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
20
21 Vendor: PlanetLab
22 Packager: PlanetLab Central <support@planet-lab.org>
23 Distribution: PlanetLab %{plrelease}
24 URL: %(echo %{url} | cut -d ' ' -f 2)
25
26 Summary: PLCRT account initialization for the root image.
27 Group: Applications/System
28 Requires: python
29 Requires: perl
30 Requires: rt3
31 Requires: rt3-mailgate
32 Requires: myplc
33
34 %description
35 PLCRT is a collection of configuration scripts for configuring RT.
36 By default RT does not come with all the settings needed for a standard PLC,
37 or PlanetLab in particular.  
38
39 %prep
40 %setup -q
41
42 %install
43
44 install -d $RPM_BUILD_ROOT/%{_datadir}/%{name}
45 install -D -m 755 plcrt.init $RPM_BUILD_ROOT/%{_sysconfdir}/plc.d/plcrt
46
47 echo " * Installing core scripts"
48 rsync -a ./ $RPM_BUILD_ROOT/%{_datadir}/%{name}/
49
50 echo " * Installing cron scripts"
51 install -D -m 644 rt.cron $RPM_BUILD_ROOT/%{_sysconfdir}/cron.d/rt.cron
52
53 chmod 755 $RPM_BUILD_ROOT/%{_datadir}/%{name}/adduserstort.pl
54 chmod 755 $RPM_BUILD_ROOT/%{_datadir}/%{name}/cron.d/*.sh
55
56 %clean
57 rm -rf $RPM_BUILD_ROOT
58
59 %files 
60 %defattr(-,root,root)
61 #%config /etc/plcrt.conf
62 %{_datadir}/%{name}
63 %{_sysconfdir}/plc.d/plcrt
64 %{_sysconfdir}/cron.d/rt.cron
65
66 %post
67 if grep 'pam_loginuid.so' /etc/pam.d/crond ; then
68     sed -i -e 's/^session    required   pam_loginuid.so/#session    required   pam_loginuid.so/g' /etc/pam.d/crond
69 fi
70
71 if ! grep '<category id="plc_rt">' /etc/planetlab/default_config.xml ; then 
72     sed -i 's|<category id="plc_net">| <category id="plc_rt">\n <name>RT Configuration</name>\n <description>RT</description>\n <variablelist>\n <variable id="enabled" type="boolean">\n <name>Enabled</name>\n <value>false</value>\n <description>Enable on this machine.</description>\n </variable>\n <variable id="host" type="hostname">\n <name>Hostname</name>\n <value>localhost.localdomain</value>\n <description>The fully qualified hostname.</description>\n </variable>\n <variable id="ip" type="ip">\n <name>IP Address</name>\n <value/>\n <description>The IP address of the RT server.</description>\n </variable>\n </variablelist>\n </category>\n <category id="plc_net">|' /etc/planetlab/default_config.xml
73 fi
74
75 mkdir -p /etc/planetlab/configs
76 plc-config --save /etc/planetlab/configs/site.xml \
77                 --category plc_rt --variable enabled --value true
78
79 %changelog
80 * Fri Jun 26 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - PLCRT-1.0-1
81 - trying to get the tag to work for new package.
82
83 * Thu Jun 26 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - PLCRT-1.0-1
84 - initial addition.